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Lettering Kiosk

EmbroideryStudio provides an easy-to-use Kiosk capability for cap and 
other embroidery. The lettering kiosk is primarily intended for use at 
retail outlets where fast and simple personalization of standard design 
layouts is required in consultation with customers.

The benefits to retail staff are:
 Minimal training time
 Minimal production errors
 Improved customer satisfaction
 Increased productivity
 Easy configuration for changing requirements
 Support for several brands of machine
 Simplicity of kiosk mode together with full embroidery lettering 

capabilities for supervisors.
The lettering kiosk provides a set of predefined design layouts and the 
ability to easily personalize them by modifying text and color. You can 
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create your own layouts as well. Designs can be sent to machine from the 
kiosk via a single button press.

Operations summary

Here are some steps to get you up-and-running quickly with the lettering 
kiosk.

Configure the kiosk settings
1 Run the EmbroideryStudio software:
 You need the Kiosk Element enabled.
 There is no special setting required for kiosk mode.

2 Configure the kiosk design layouts:
 Located under C:\ProgramData\Wilcom\EmbroideryStudio 

e4.x\Kiosk\Designs
 Set palette colors in the design layouts to match the thread colors 

and needle assignments used on your machines. See Setting up 
thread colors for details.

 Check the fonts and stitch settings being used.
3 Configure the machine connections for the kiosk:
 Select Setup > Connection Manager Setup.

4 Configure the kiosk password:
 Select Setup > Options > Kiosk.
 Enable ‘Lock Kiosk’.
 Set a password.

5 Configure character count limits. See Configuring kiosk character 
count limits for details.

Switch to and from kiosk mode
1 To switch to kiosk mode, select menu command Window > Kiosk…
2 Type the kiosk password to enter into kiosk mode.
3 To close the application while in kiosk mode, click on the red X button 

in upper right corner.
When you restart EmbroideryStudio, it will automatically re-start in 
kiosk mode directly.

4 To return to the EmbroideryStudio screen, click Exit Kiosk and key in 
the password if prompted.

Operate the software in kiosk mode
1 Select a layout from the design chooser.
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2 Key in a name. Lettering adjusts to fit the allowed space. By default, 
a maximum of 16 characters is allowed. See Configuring kiosk 
character count limits for details.

3 Change fonts by selecting a different design layout.
4 Select a thread color.
5 When finished, click a button to send the design to the machine:
 Stitching starts and ends at the bottom center of the allowable 

embroidery area.
 The design is auto-rotated 180° for the machine, according to 

connection settings. See Setting up machine connections for 
details.

 A machine file is created and sent to the folder set in the 
Connection Settings dialog.

 The file name uses the text to be embroidered.
6 Click Start Again for the next name.

Operating modes

The Lettering Kiosk has all the capabilities and functionality of a 
commercial kiosk system together with EmbroideryStudio embroidery 
functionality.

Screen modes

In Wilcom Workspace mode, supervisors can use the full range of 
software capabilities to fine-tune settings. All adjustments can be saved 
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to a template ready for use when the software is run in kiosk mode. 
Onscreen help is available via the Help menu.

Kiosk screen mode
A password configuration setting allows supervisors to bypass the 
EmbroideryStudio screen and run the software in kiosk mode by default. 
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Operators normally work in this screen and never need to leave it. In fact, 
they cannot exit without, optionally, a supervisor password.

Kiosk mode includes a 56-color default palette together with a number of 
packaged designs. However, in practice you will want to limit the palette 
to the colors available on your machines. The screen is divided into three 
functional areas apart from the banner at the top.

Choose design panel
The Choose Design panel is positioned on the left side. It contains a set 
of predefined design layouts to choose from. It is easily extensible with 
other supervisor-created designs.

Working design area
A working design area in the middle is optimized for 1366 x 768 
resolution. It includes a dotted line indicating the maximum stitching 
boundary.

Design chooser
panel

EmbroideryStudio
Kiosk title banner

Design work
area

Customization
panel

Selected design shown
within allowable stitching

boundary
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Customization panel
The customization panel on the right allows the operator to easily 
customize designs by changing color and text of the selected layout. The 
supervisor can pre-configure the number and values of standard colors 
to match the thread color setup on the machines. Custom designs can be 
sent to one of several attached embroidery machines.

Send to machine
Machines are pre-configured by the supervisor – typically up to 6. 
Color-coded buttons easily identify machine by number and machine 
name. The supervisor can set color-coded icons for each machine brand. 
For example:
 Brother - Cyan
 Barudan - Navy Blue
 SWF - Red

Normal Kiosk operation

Once in kiosk mode, typical operation will flow as follows.

To operate the kiosk
 Choose a design layout from prepared templates in the left panel.

Choose a design
layout



EmbroideryStudio e4 Lettering Kiosk Supplement 7

 Enter a new name in the text field and press Enter.

This text automatically replaces default text. By default, a maximum 
of 16 characters is allowed.

 Click in design window and zoom in / out by the following means:
 Press 1 for actual size.
 Press 0 to show all.
 Use the mouse scroll wheel to zoom.
 Click Start Again to return to default view.

 Choose a thread color from the list of available colors.
You can switch layouts and colors as desired and text will be 
preserved.

Default 9-color
design palette

Enter new
name

Send design to
a machine

Input text
replaces default

text

Template
switched
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 When you are satisfied with the design, press a Send to Machine 
button. A separate button is present for each machine configured on 
the system.

 Press Start Again to create another design. The current design is 
automatically saved to the watching folder with a filename equal to 
text name. 

Note  If the operator does not press Start Again but instead selects 
a new design layout, the new design overrides the current one, 
preserving any typed text.

 To exit kiosk mode altogether, press the lock icon. Normally you are 
prompted for a supervisor password. 

Related topics
 Setting up machine connections
 Configuration options for supervisors

Troubleshooting long descenders

Some characters may extend slightly beyond the allowable stitching 
area. This usually happens with script fonts or characters with long 
descenders or ascenders such as the ‘k’ in this example. This problem is 
easily fixed by adding a space after the final character.

Creating two-line lettering

Kiosk mode allows two-lines of text to be entered and edited. The text 
box in the control panel supports single- or multi-lines depending on the 
selected layout. Two-line layouts need to be predefined and saved to the 
designs folder. When using a multi-line layout, the first Enter keypress 

Add space after 
final character

Long descender 
extends beyond 
stitching area
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will create another line. The next will confirm text entry as for a 
single-line layout.

Note  If you switch design layouts, the system will attempt to preserve 
user-entered text between single- and multi- line designs. For example, 
switching from single to double, the original line of text will be copied to 
the first line. The second will be empty.

Personalizing monograms

The lettering kiosk also supports customization of monogram objects. 
Only text can be changed in Kiosk mode. Monogram templates can be 
created and added to the kiosk.

Edit two-line 
design layout

Personalize 
monogram text
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Configuration options for supervisors

When first running EmbroideryStudio e4, supervisors have access to 
EmbroideryStudio operations. In this mode, they can use the full range 
of software capabilities to fine-tune settings. Primarily, supervisors are 
concerned with:
 Creating a password for the kiosk
 Setting up machine connections
 Setting up thread colors
 Configure kiosk character count limits

Creating kiosk passwords

Supervisors can lock the kiosk to protect against unauthorized use. They 
can later temporarily unlock the kiosk in order to edit designs or change 
other settings.

To create a password for the kiosk
1 Click the Options icon or select Setup > Options. Click the Kiosk 

tab.

2 Enter a secure password and click OK.
3 Select Window > Kiosk start the kiosk. You will be prompted to enter 

the password.

Use Standard > Options to access application options for kiosk and other 
settings.

Tick to lock kiosk
and activate

password
Enter 
password for 
kiosk access

Enter password
for kiosk access
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Note  You can return to Options dialog at any time to change or 
remove password protection. If you forget the password, you will need 
to run the Revert program from the EmbroideryStudio program group 
to restore factory defaults.

Setting up machine connections

Connection Manager allows you to connect to most later model 
machines. These machines often require files to be placed in a specific 
network location or ‘watching folder’. Once set up in EmbroideryStudio, 
a single click from the kiosk is sufficient to send the design to machine. 
Each configured machine:
 has a unique name and assigned button
 has a unique folder to which designs can be sent so they can be 

accessed from the machine control panel or third-party connection 
software.

To set up machine connections
1 Select Setup > Connection Manager Setup.

Run Revert to 
restore defaults

Click to create a 
new connection
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2 Click Create to set up a connection. The Connection Settings dialog 
opens.

3 Make sure the connection type is set to ‘Machine Folder’. Watching 
folders should already have been set up for each machine on the 
network.

4 Enter a unique machine name – e.g. ‘Brother PR600 Mach 1’.
5 Choose a colored icon from the droplist to identify the machine in kiosk 

mode.
6 Select the file type required by the machine. Each machine type uses 

a different file format:

7 If the file type requires it – e.g. PES – click the Options button to 
preset file options such as version type.

8 Enter or browse to a folder location on the network or PC which has 
been set up for the specific machine. When you output a design, 
Connection Manager saves it to this folder in the specified file 
format.

9 If the machine is intended for cap designs, tick the Rotate design by 
180° option.

10 Click OK when complete.

Enter unique 
machine name

Select connection
type

Select file type 
required by machine

Set ‘watching
folder’

Choose a color to 
identify the machine

Tick if the machine is 
to be used for cap 
production

Machine Format

Brother PES
SWF DST
Barudan U??
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11 Repeat as many times as you have machines to connect. Connections 
can be edited or removed at any time.

New machine connections appear as prominent buttons in the 
customization panel of the kiosk.

Setting up thread colors

Thread colors are set up for each design layout. All three sample designs 
need to be edited according to the requirements of your machine setups.

Delete or edit 
connections as required

Color-coded
machine buttons

Use Standard > Open to open an existing design.

Use Standard > Save Design to save the current design. Right-click to 
open the Save As dialog.
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To set up thread colors
1 Click the Open icon. The Open dialog opens.

2 Navigate to the Designs folder of your EmbroideryStudio e4 
installation:
C:\ProgramData\Wilcom\EmbroideryStudio e4.x\Kiosk\Designs
Alternatively, specify your own folder.

3 Select a design to edit and click Open.
4 Use the Color Palette tools to add or remove colors according to the 

thread setup on your machine/s.

Navigate to
Design folder

Add or remove colors

Open Editor
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5 Open the Threads docker and select your thread chart.

6 Assign threads to the palette with the Match All button. Alternatively, 
select threads corresponding to the thread setup on your machine, 
and assign these. The design layout defaults to the first color in the 
palette. The tooltip tells you the corresponding thread of each color.

Access thread
charts

Choose a thread 
chart

Assign threads from
chart to color palette

Default color
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7 Click Save to save the file in the design folder. The modified palette 
for this design will appear in the kiosk when you next run it.

Related topics
 Changing design location

Configuring kiosk character count limits

Different scenarios may lead to variations in the number of characters 
allowed. The commercial requirement is for 16 characters per line, but 
the software allows you to change that limit. For example, maximum 
characters when buying online may be limited to 10, while baby-size caps 
may be less than 16. Optionally, the supervisor can limit the number of 
characters allowed in kiosk mode.

Note  Spaces between words count as characters. However, extra spaces 
are allowed at the start and end of a line without compromising the 
character count.

To configure the kiosk character count limit
 Click the Options icon or select Setup > Options. Click the Kiosk 

tab.

 Tick the Restrict number of characters option and set the 
maximum number of characters – e.g. 16.

Use Standard > Options to access application options for kiosk and other 
settings.

Tick to restrict
text length

Set character 
limit
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When the number of characters is limited by this option, the kiosk 
shows the number used vs the number available – e.g. ‘5 / 16’. Where 
a two-line design is selected, the limit is shown for each line.

Related topics
 Troubleshooting long descenders

Changing design location

The default kiosk design folder is located within the EmbroideryStudio e4 
folder structure. This may not be convenient for you if you are dealing 
with numbers of custom designs. You can easily change the folder 
location to any on your kiosk hard drive or network. If you have more 
than one kiosk set up, they can all reference the same design folder.

To change the design location
 Click the Options icon or select Setup > Options. Click the Kiosk 

tab.

 Tick the Custom kiosk design folder option and browse for the 
folder on your local drive or network. This then becomes the default 

Kiosk shows number 
used vs number 
available per line

Use Standard > Options to access application options for kiosk and other 
settings.

C:\My Kiosk DesignsTick to activate
custom Design

folder

Browse for 
folder location
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kiosk design folder. Any EMB designs kept in this location will appear 
in the kiosk design chooser.

Customizing kiosk banners

Like the kiosk Design folder, the default kiosk banner is located within 
the EmbroideryStudio folder structure. If you want to modify the banner 
in any way – e.g. with a specific location name – it is a simple matter to 
access the banner and update it. Alternatively, you can copy the modified 
banner to a separate location on your kiosk hard disk or network location 
and reference it there. If you have more than one kiosk set up, they can 
all reference the same banner.

To customize the kiosk banner
1 Navigate to the ‘Kiosk’ folder of your EmbroideryStudio e4 installation:

C:\ProgramData\Wilcom\EmbroideryStudio e4.x\Kiosk\
Here you will find the default kiosk banner – dimensions 1200 x 100 
pixels.

2 Customize the banner as required:
 Either replace the current image with one of the same dimensions.
 Edit the current banner in any graphics or paint program and save 

to the same location.
 Copy the banner to the same or another location and edit as 

desired.
If you move the banner to another location, you need to update the 
software settings as follows:

Use Standard > Options to access application options for kiosk and other 
settings.
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3 Click the Options icon or select Setup > Options. Click the Kiosk 
tab.

4 Tick the Custom kiosk banner option and browse to the folder on 
your local drive or network.

5 Select the custom banner file and click Open. This then becomes the 
default banner which the kiosk will reference.

Creating custom design layouts

Various techniques are available to add your own design layouts to 
EmbroideryStudio.

Creating new layouts from old

Tick to activate
custom banner Browse for 

folder location

Navigate to
folder location

Select custom 
banner

Use Standard > Open to open an existing design.

Use Standard > Save Design to save the current design. Right-click to 
open the Save As dialog.



   Lettering Kiosk 20

To create custom design layouts is not very different to setting up thread 
colors. The simplest approach is to base a new design on an existing one 
in order to preserve stitch settings and design scale. You can change 
colors, fonts and stitch settings as required.

To create a new layout from an old one
1 Click the Open icon.

The Open dialog opens.

2 Navigate to the Designs folder of your EmbroideryStudio e4 
installation:
C:\ProgramData\Wilcom\EmbroideryStudio e4.x\Kiosk\Designs
Alternatively, specify your own folder. 

3 Select a design to edit and click Open.
4 Before you do anything else, select File > Save As and save the 

design under a different name.

Navigate to
Design folder
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5 Double-click the design to open its properties.

6 Edit the default text and select an alternative font from the droplist as 
desired.

7 Click the Update Text button to view the result on screen.

8 Change default thread color as desired. The design will appear in the 
kiosk design chooser when you next run it.

Related topics
 Changing design location

Choose font from
droplist

Edit default text
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Creating layouts based on templates

Alternatively, you have access to complete EmbroideryStudio capabilities 
to create designs from scratch. Onscreen help is provided via the Help 
menu.

To create a layout based on a template
 If you are creating a design from scratch, use the File > New from 

Template command.

 Select a kiosk template if you have set one up. For example, you may 
set up your template to include a stitching boundary defining the area 

Use Toolbox > Lettering to create embroidery lettering directly on-screen. 
Right-click to access settings.

Use View > Auto Start & End to toggle function on/off according to the 
current settings. Right-click to open the Auto Start & End dialog.

Select 
template
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to work within, say, for cap designs. This can be drawn in CorelDRAW 
Graphics. You might also want to include a product image.

 Select the Lettering tool and create the text you require. Adjust 
settings such as font, dimensions, etc.

Note  To ensure that text remains within the allowable boundary, it is 
safest to use the Fixed Line baseline.

Kiosk stitching 
boundary

Use ‘Fixed Line’
baseline
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 Change thread color as desired. 

 Set the selected lettering object to position to zero (0,0) as shown. 
This will ensure that the lettering layout automatically centers itself in 
the allowable stitching area.

 When you are happy with the result, click Save.
The file must be saved to the EmbroideryStudio e4 Designs folder:
C:\ProgramData\Wilcom\EmbroideryStudio e4.x\Kiosk\Designs
Alternatively, set your own designs folder. 

 The design will appear in the kiosk design chooser when you next run 
it.

Related topics
 Setting up thread colors
 Changing design location

Creating layouts with included design motifs

For special occasions, you may want to create a kiosk layout which 
includes a special motif – for instance, St Patrick’s Day, with a Shamrock 
at the start of the lettering. These motifs need to be about the size of a 
capital letter. Together with the lettering, they need to fit within the 
allowable stitching boundary.

To create a layout with an included design motif
1 Create a layout from scratch or based on an existing layout. See 

above.

Set X/Y position of
selected lettering to zero

Use Toolbox > Lettering to create embroidery lettering directly on-screen. 
Right-click to access settings.

Click Standard > Import Embroidery to import embroidery design file into 
current design.
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2 Import a suitable design motif using the Import Embroidery 
command. See main help system for details.

3 Place the motif and key in the default lettering.

4 Double-click the lettering and set left justification in Object 
Properties.
Alternatively, if you place the motif on the right, set justification to 
right.

5 When you are happy with the result, click Save.
The file must be saved to the EmbroideryStudio e4 Designs folder:
C:\ProgramData\Wilcom\EmbroideryStudio e4.x\Kiosk\Designs
Alternatively, set your own designs folder. 

6 The design will appear in the kiosk design chooser when you next run 
it. The whole design, including motif and lettering, is auto-centered 
immediately after text is updated in kiosk mode.

Related topics
 Changing design location

Including design backdrops

Select left
justification

Use Color > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.
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It’s a simple matter to include a design backdrop to your design layout – 
e.g. a cap.

To include a design backdrop
 Click the Product Visualizer icon. The docker appears.

 Select a product image – e.g. cap – and set color as desired.

Click View > Show Product to toggle current product display. Right-click for 
Product Visualizer settings.

Use Zoom > Zoom to Product to view the entire product in the design 
window.

Select a 
product folder

Select 
product
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 Set the selected lettering object to position to zero (0,0) as shown.

 As the lettering object and stitching boundary may not be in the 
correct position for the backdrops, click the Auto Start & End icon 
and digitize a start and end point as shown.

Note  The stitching boundary is locked in the template. It has to be 
unlocked to be moved.

 When you are happy with the result, click Save.
The file must be saved to the EmbroideryStudio e4 Designs folder:
C:\ProgramData\Wilcom\EmbroideryStudio e4.x\Kiosk\Designs
Alternatively, set your own designs folder.

 The design will appear in the kiosk design chooser when you next run 
it.

Digitize start and end
point at base of design

Set X/Y position of
selected lettering to zero

New design listed
in kiosk chooser
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Related topics
 Changing design location
 Visualizing products
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