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Chapter 1

Introduction to Chenille

Chenille remains a popular technique for specialist embroidery houses 
with the right equipment. In EmbroideryStudio, the Chenille add-on 
Element supports a wide range of chenille work and includes special 
embroidery capabilities for use with chenille or combination lockstitch 
systems.

Modern chenille machines equipped with multiple loopers and automatic 
color-change capabilities produce chenille embroidery more efficiently 
than earlier mechanical machines. With chenille-capable design software 
such as EmbroideryStudio, it is possible to exploit these machines to the 
maximum of their commercial potential, and appeal to both popular as 
well as custom apparel and fashion markets.
This section provides an overview of the chenille terms and concepts as 
they relate to EmbroideryStudio. For an essential introduction to 
EmbroideryStudio software concepts, refer to the EmbroideryStudio 
Reference Manual.
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Overview

Chenille fabric dates back to 18th century France and refers to velvety 
fabric with the characteristic ‘chenille look’. The material is made on a 
special loom similar to those used in carpet manufacture.

Turned in the light, the fabric takes on a lustrous, glossy appearance. 
Today it is typically associated with soft fuzzy sweaters, bedspreads and 
bathrobes. It also finds applications in home decor, from pillow covers to 
sofa throws.
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Chenille embroidery
Like the fabric, chenille embroidery is made from loops of yarn creating 
a soft, fuzzy appearance. It is one of the most commonly recognized 
embroidery types. 

It is commonly used for sweatshirt emblems. It is often combined with 
regular embroidery for decorated apparel such as sports and woolen 
jackets. It is also widely used with children’s apparel.
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Because chain stitching forms flowing, curved lines, it is mainly used for 
outlines and more delicate work. It can even be used on its own to create 
flatter fills and Schiffli-like lacework.

Chenille machines

There are many types of chenille machine, including machines for taping, 
cording and sequins as well as those with two needles for four-thread 
stitching.
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Some machines can combine both chenille and lockstitch embroidery in 
the same design. Such machines are generally capable of automatic color 
changes and trims. They may also be capable of automatic chenille 
needle-height control for different depths of pile. Other derivations of 
chenille are produced on multihead machines using special attachments 
to sew down looped yarn or cord. 

Chenille yarn
Chenille embroidery is usually done with yarn instead of thread. However, 
chenille machines can employ a variety of threads and needle sizes for 
different effects. The yarn is typically made from cotton but can also be 
made with synthetics. Chenille sometimes employs multiple strands of 
yarn for distinctive looks and textures.

Chenille stitching
True chenille embroidery is made using a single, continuous yarn worked 
into the material and raised in a loop or pile. By contrast, lockstitch 
machines use a top thread and bobbin thread in combination.

Moss stitch fill

Chain stitch border

Chain stitch fill
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All chenille machines produce two basic stitch types, referred to as ‘moss’ 
and ‘chain’. In contrast to lockstitch needles, chenille needles have a hook 
instead of a threaded eye. Yarn is pulled up one loop at a time by a looper 
housed below the needle plate.

Moss stitching, which gives chenille its characteristic look, is the loop 
stitch used in fills to create a sense of depth. It can produce a wide 
variety of effects ranging from low, compact to high, plush stitching.
Chain stitch is produced by a series of looped stitches forming a chain-like 
pattern. Chain stitching is in fact an ancient craft and it was the first stitch 
used by early sewing machines. It was later replaced by the more secure 
lockstitch. It still finds use, however, in chenille machines.

Needle Yarn

Looper

Moss stitching

Needle

Yarn

Looper

Chain stitching
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Chenille backing
Chenille backing, usually felt, is softer than regular embroidery.

Combination machines
With combination machines, patches and emblems often combine moss 
and chain stitch with standard lockstitch embroidery. Automation has 
made this type of work simpler and cheaper to produce.

Chenille design considerations

Chenille design used to be a specialist technique. In reality, digitizing for 
chenille is easier than regular embroidery. In general, shapes are filled 
more simply and registration tolerances are broader. Otherwise, 
designing and digitizing for chenille is similar to standard embroidery, 
with these differences:
 Chenille designs look best at larger size because of yarn thickness and 

relative size of moss and chain stitching. Detail may be added by 
over-sewing with standard embroidery. 

Moss stitch fill

Chain stitch border

Embroidery lettering
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 While chenille is limited in its ability to achieve intricate detail, it is 
possible to achieve elaborate designs using color, texture and 
dimension.

 It is important to map out a design, as you would regular embroidery, 
so as to minimize jumps.

 Chenille shapes generally consist of a fill with one or more offsets of 
chain and sometimes moss stitching. The border is needed to hold the 
fill inside the shape. Wherever possible, use ‘compound chenille’ 
objects which include their own offset outlines.

 Otherwise, chain stitching can be used as ‘tie-ins’ and ‘tie-offs’ to stop 
moss stitching from unraveling.

 Chenille stitching is thicker than the lines in your digitized design so 
you need to recognize and compensate for this. For instance, chain 
stitching appears as a regular run stitch on screen.

 Because chenille yarn is thicker than normal thread, it is critical to 
avoid yarn pile-up caused by overlapping stitches, particularly chain 
stitches.

 Similarly, small clusters of stitches are not suitable for chenille work 
because of yarn thickness. They may cause yarn breakage or holes in 
the fabric. Avoid shapes with sharp angles.

 Chenille embroidery primarily ‘pushes’ or expands, unlike the 
‘pull-push’ factor in traditional embroidery. Large designs require a 
cutaway backing to compensate for this.

 Overlocking is used to prevent chain stitches unraveling. You need to 
manually insert a chain for Barudan and Melco chenille machines. 
Tajima machines can change automatically from moss to chain if the 
machine has this option enabled.
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Chapter 2

Chenille Basics

In EmbroideryStudio, you use a single design workspace for both chenille 
and lockstitch embroidery. In addition, with the Chenille add-on 
activated, there is a dedicated Chenille template, a Chenille toolbar 
with chenille-specific stitch types and machine functions, dedicated 
chenille fonts, and a dedicated tab on the Object Properties docker.

EmbroideryStudio supports a wide range of chenille work and provides:
 Constant stitch length in all objects, for consistent smooth appearance
 Ability to control shortcut angles
 Variable width coil stitching
 Gaps at the ends of columns automatically filled with coil stitching
 Special ‘compound chenille’ objects which can include any kind of fill, 

with up to six offset borders in any combination of chain and moss 
stitching.

Settings for 
compound chenille 
objects

Chain

Moss

Needle Height

View by 
Chain/Moss

Compound Chenille
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You should first become familiar with general EmbroideryStudio 
techniques before employing chenille-specific techniques. 
EmbroideryStudio has a certain design philosophy but once you 
understand it, similarities between individual functions become obvious. 
See the EmbroideryStudio Reference Manual for details.
This chapter provides an overview of digitizing for chenille and visualizing 
chenille stitching. It also introduces chenille settings in 
EmbroideryStudio. It also covers handling chenille design files.

Digitizing for chenille

You digitize chenille objects using regular input methods – traditional and 
graphical. Chenille work involves only two stitch types – Chain and 
Moss. Moss is generally used for fills, Chain for borders or details. 
Chain may also be used for flatter fills. 

Chenille usually involves a combination of two basic fill patterns – 
Square and Coil, single or double. Use these stitch patterns together 
with Moss for chenille fills. Run stitch is typically used with Chain for 
borders. For chenille, you mainly use Compound Chenille with 
Complex Fill to digitize objects – even narrow ones – with built-in chain 
borders.

Chenille stitch types

To qualify as a ‘chenille object’, a digitized shape must have Chain or 
Moss applying. These are the two basic stitch types created by all 
chenille embroidery machines. In EmbroideryStudio, they are added as 
machine functions which can be interpreted only by dedicated chenille or 
combination machines. As such, they cannot be displayed in TrueView. 
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Moss stitch

Chenille Moss produces the typical raised stitching associated with 
chenille work. It can only be applied to two basic fill patterns – Square 
and Coil. It can be stitched at different needle heights – lower for outlines 
and higher for fill. It works best with simple shapes.

Chenille has no bobbin thread. Without tie-ins and tie-offs, Moss stitch 
can loosen during washing. For this reason, Chain borders are used to 
achieve a tie-in and tie-off effect. 

Tip: A sticky fabric can also be used to back Chenille embroidery using a 
heat and press method. Using this production process, moss fill does not 
require a chain border.

Chain stitch

Chenille Chain produces a decorative style of stitching resembling the 
links of a chain. It is used for outlining and bordering designs as well as 
monograms. Chain can also be used for more delicate detailing or fills.

Use Chenille > Moss to create dense cover using looped stitch typical of 
chenille raised stitching – best with simple shapes. Right-click for settings.

Use Chenille > Chain for decorative stitching resembling links of a chain. 
Can be used as a delicate fill or as a border for moss fills. Right-click to 
adjust settings.

Moss stitch

Chain stitch
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Compound Chenille objects generally include built-in offset chain 
borders. Alternatively, chain borders can be digitized separately, usually 
with Run input method. Chain fills can be created in conjunction with 
other, non-chenille, stitch patterns.

Tip: In conjunction with chain stitching, a chenille design typically builds 
in height from the edges to the middle.

Chenille fill patterns

Traditional chenille work usually involves a combination of two basic fill 
patterns – Square and Coil – in combination with chenille Moss. The 
pattern you use depends on input method as well as object shape, size 
and the effect you want to achieve.

Coil and Island Coil are traditional forms of chenille fill. They are both 
stitched in spirals. This fill type mimics hand-made chenille embroidery. 
Coil may be used to fill columns or narrow areas. Larger areas may be 
filled with Island Coil.

Coil

Double Square

Island Coil

Square

Coil

Moss with 
Coil

Moss with Double 
Square + Compound 
Chenille

Moss with 
Square 

Island Coil with 
Moss + Compound 
Chenille

Chain outlines

Chain with Maze

Moss with Square
+ Compound

Chenille

Chain with Offset

Chain with Spiral Lockstitch details

Lockstitch
lettering



Wilcom EmbroideryStudio e4 Chenil le Supplement 13

Alternatively, use Double Square to generate stitches on a grid rather 
than coils. Similarly, Square can be used for narrow shapes as an 
alternative to Coil. These fill patterns are generally better suited to 
squarish shapes with sharper angles.
Chain stitching is mainly used for outlines and more delicate work. It 
can, however, be used to create flatter fills. We recommend using open 
stitch patterns such as Maze Fill, Offset Fill, or Spiral Fill to create the 
kind of effect you see in the above sample.

Related topics
 Chenille patterns
 Chenille fill pattern usage
 Maze fills
 Offset fills
 Spiral fills

Chenille input methods

You can digitize chenille objects manually using practically any input 
method, including Freehand. But the main methods are summarized 
above. Stitch angles have limited effect on chenille embroidery.

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.

Use Traditional Digitizing > Column A to create columns of varying width 
and stitch angle. Right-click for settings.

Use Traditional Digitizing > Column B to create asymmetrical columns of 
turning stitches, where opposite sides are different shapes. Right-click for 
settings.

Use Traditional Digitizing > Column C to digitize columns or borders of 
fixed width. Right-click for settings.

Use Traditional Digitizing > Digitize Run to create row of single stitches 
along a digitized line.

Column A/B with coil

Complex fill with island coil
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Tips for use
 Typically chenille objects are digitized with Complex Fill in 

conjunction with Compound Chenille. Resulting objects include 
borders to contain chenille fills and provide edge definition. This is 
important when using Moss. 

 Compound Chenille objects will only work with two basic stitch 
patterns – Square and Coil. Moss stitch is generally applied to these 
fills.

 Chain has limited applicability to coil or double-square fill patterns.
 Complex Fill cannot be used with Coil and will default instead to 

Island Coil as shown above.
 Variable-width Coil stitching can only be created with Column A or 

Column B input methods. 
 Column C can be used to create columns of constant width.
 Column methods cannot be used with Compound Chenille.
 Moss objects created with these input methods will require chain 

borders. These need to be added manually. This in turn makes scaling 
more problematic as gaps between borders and fills will change.

 While variable width coil looks artistic on screen, it won’t look like this 
on stitchout. Moss stitching is very dense and covers the fabric 
entirely. Variable-width Coil patterns may be better employed with 
lockstitch embroidery.

Related topics
 Start a new chenille design
 Digitizing Shapes
 Chenille Digitizing

Compound chenille

Chenille objects generally include a border to contain chenille fill stitching 
and provide edge definition. One or two offset run-arounds are usually 
sufficient to provide a clear edge and secure fill stitches. The Compound 
Chenille tool allows up to three (1-3) borders to be generated both 

Use Chenille > Compound Chenille to automatically digitize chenille 
shapes with offset borders. Right-click to adjust automatic offset borders.
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before and after the fill. When a compound object is scaled, borders are 
included.

Note: Compound Chenille objects will only work with two basic stitch 
patterns – Square and Coil, single or double. Moss stitch is generally 
applied. Chain has little applicability to these fill patterns.

Related topics
 Create compound chenille objects
 Compound chenille settings

Chenille runs & borders

While borders are built into Compound Chenille objects and can 
therefore be scaled with the object, you can also digitize single-line 
borders manually. For this, you typically use Digitize Run with Chain 
stitching. One or two offset run-arounds provide a clear edge for filled 
areas and help to secure chenille fill stitching. Other input methods can 
be used. If your machine supports it, you may combine chenille with 
regular stitching to tie-off chenille objects.

Related topics
 Creating chenille borders
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Chenille design parameters

There are two parameters of crucial importance to chenille work – needle 
height and stitch length. Chenille design frequently involves juggling 
these two parameters to achieve the desired effect.
Generally speaking, needle height controls the height of the loop formed 
by the chenille machine when it is sewing moss stitch. The needle height 
setting has less effect on chain stitches though it does affect width.
Stitch length has more of an effect on chain stitching. This value 
determines the size of chain. It also affects loop height, though for moss 
stitching, it is easier and more accurate to adjust needle height.

Needle height

Needle height controls the height of the loop formed by the chenille 
machine when it is sewing a moss stitch. The needle height setting has 
less effect on chain stitches though it does affect width.

With moss stitching
You may use different needle heights for different areas of color. Or 
between fills and borders – lower for borders, higher for fills. When using 
Compound Chenille, you can change needle heights of each offset.

The chenille machine pulls up the same length of yarn for each loop 
according to the current needle height setting. Even though stitch length 
affects loop height, it is easier and more accurate to adjust needle height. 
If you intend to use loops of various height, adjust the needle height 
rather than stitch length. 

With chain stitching
Needle height has a thread tensioning effect on chain. For chain, the 
greater the needle height, the tighter the thread tension. With tighter 
thread tension, chain looks narrower.

Needle height control
With some chenille machines, needle height can be specified in the 
design. While stitching out, the chenille machine will automatically 
change needle height according to your selection. Normally, it’s best to 
use default settings. Do a test run on the machine to check the outcome. 
Then, if necessary, adjust needle heights.
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The Melco tape file format has specific codes assigned to each needle 
height position. It uses 26 different needle height positions, which are 
designated ‘A’ through ‘Z’. Height ‘A’ is the lowest - 0.0100’, ‘Z’ is the 
highest - 0.3225’. Each successive letter is 0.0125’ higher than the 
preceding letter. The actual needle height measurement is a distance 
from upper surface of the needle plate to the inside of the needle hook.
The Melco system is an industry standard which is also used by other 
machine formats. Some brands use proprietary needle height 
parameters. Barudan machines, for instance, use numbering rather than 
letters. See also Controlling needle heights.

With some machines, needle height can also be adjusted on the machine. 
In practice, it is more common to adjust there rather than in the design. 
Thus you can choose whether to use heights specified in the design or 
not. See also Needle height default.
Dahao controllers, on the other hand, do not support needle height 
values in the machine file. This is set manually on the machine control 
panel according to the heights specified in the Production Worksheet.

Coil direction
For some machines, best results with Coil are achieved by sewing in a 
counterclockwise direction because when you sew in a clockwise 
direction, you are adding more twist to the yarn causing it to become 
tighter, distorting the moss stitch loops. Refer to your machine handbook 
for details.

Stitch length

Stitch length has more of an effect on chain stitching. This value 
determines the size of chain. The larger the value, the larger the pattern. 

Choose needle
height value

Ideal loop Extra-twisted yarn loop
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It also affects loop height though for moss stitching though it is easier 
and more accurate to adjust needle height.
Stitch length should be constant for the same thread type throughout a 
design. If stitch length varies, the height of moss loops and width of chain 
loops will also vary, causing uneven embroidery. 
Select a stitch length for a design according to yarn thickness, fabric 
thickness, and required density. Using inappropriate stitch length may 
cause yarn breakage, needle breakage, or damage to the fabric. 
If the yarns in use are of the same type, the lengths of chain and moss 
stitch are different. The following table gives an indication of appropriate 
values.

Tip: These values may vary depending on the fabric used. When you use 
a new thread and fabric combination, sew a test design first using the 
above values as an initial guide.

Other parameters

In addition to basic and decorative chenille stitch types and effects, you 
need to be aware of the following chenille settings...

Scaling
As with lockstitch designs, any chenille design created in 
EmbroideryStudio can be scaled. Stitches are automatically recalculated 
from object outlines. Densities are preserved and there are no gaps or 
heavy over-stitching. Compound Chenille objects are recalculated 
together with their offset borders.
When old chenille designs are read from stitch data – e.g. Melco EXP, 
Tajima or Barudan disk – the EmbroideryStudio Stitch Processor converts 
them to objects. However, it does not fully recognize Coil and Square 
stitching. These will be converted to a series of Run stitch objects. This 
limits the scalability of these old designs to ±5-10%. However, old 
designs can be readily stitch-edited and sections re-digitized if required. 
See Opening machine files for details.

Thread type
Rayon 
300d/2P

Miki wool Woolly yarn
Cotton 
thread #12

Softaine G

Chain stitch 
length

2.0-3.0 mm 2.5-3.5 mm 1.8-2.2 mm 2.3mm 2.0mm

Moss stitch 
length

1.5-1.7 mm 2.0-2.2 mm 1.6mm 2.1mm 1.7mm

Moss stitch 
spacing

1.5mm 1.8mm 1.7mm 1.5mm 1.8mm
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Trims
Few chenille machines have an automatic thread trim mechanism as 
connecting threads are under the fabric and are not visible. In this case, 
digitize all shapes and lines of the same color sequentially in order to 
minimize manual trims. This will reduce stitchout time. Be careful how 
you connect from one spot to another. Avoid long connecting stitches 
which may pull previous stitching and require trimming. Typically, most 
objects will include a chain run before the fill to tie-in, and another chain 
run after, to tie-off.

Jumps
Jump(M) functions cause frame movements without needle penetrations. 
The use of jumps is not recommended because the pulling effect on the 
fabric during a jump may distort the design, especially if the fabric is thin. 
To avoid long connecting stitches, plan carefully the order in which you 
digitize shapes and lines. Use chain stitch rather than jumps when 
traveling across a shape filled with moss stitching as chain stitch will be 
hidden beneath moss stitching. Use Jump only if there is a significant 
contrast in colors, particularly if the current stitch is of a lighter color 
where the yarn may show through.

Corners
Avoid corners with an angle smaller than 60° as this can cause a machine 
fault or loop stitching may be changed to chain. EmbroideryStudio 
automatically adds an extra stitch to avoid sharp corners within objects, 
including manual stitch objects. If you round off sharp corners in runs 
and complex fills, you can avoid both sharp angles and small stitches. 
However, sometimes an extra stitch causes chain stitches to swell, giving 
a poor finish.

Tip: Use Smart Corners to achieve smooth, even placement of stitches, 
and eliminate gaps in your design. Smart Corners can be used with 
Square stitch and Coil for Column C objects. See Controlling corner 
stitching for details.

Visualizing chenille stitching

The two basic stitch types created by all chenille embroidery machines 
are ‘moss’ and ‘chain’. In EmbroideryStudio, Moss and Chain are treated 
as machine functions which can be interpreted only by dedicated chenille 
or combination machines. Chenille objects cannot be viewed in TrueView 

Use Chenille > View by Chain/Moss to view chenille objects in special 
mode to allow easy identification of chain and Moss elements – lockstitch 
in green, chain in blue, moss in red.



Chapter 2   Chenil le Basics 20

but they can be viewed in a special viewing mode which allows easy 
identification of chain and moss elements.

To visualize chenille stitching
 Click the icon to activate Chain/Moss display or select View > View 

by Machine Function > Chain/Moss.

 The design appears using only the first three colors in the color 
palette. These color slots are best left for display purposes only, 
where:

 Use the Stitch List to check machine functions in the design.
 To travel by machine function, click/right-click the Travel by 

Function tool. Alternatively, press Ctrl + Page Up or Ctrl + Page 
Down. The needle point will stop at every jump, trim, and color 
change in the design.

Slot Default Element

1 Green Lockstitch
2 Blue Chain
3 Red Moss

Chain/Moss
view

Check chenille 
functions

View by Chain/Moss

Chain stitch 

Moss stitch 

Lockstitch
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Note: TrueView does not display chain and moss stitching. However, 
it can still be useful to give an impression of the design when viewed 
at a small zoom factor (less than 1:1).

Tips for use
When examining your design prior to stitchout, note the following…
 Chenille design always starts with a Chain code.
 A Moss code must be present at the start of any Moss section.
 The Moss section must conclude with a Chain code.
 When continuing after a color change or trim, no additional function 

code is required. The new block will follow on with the same Chain 
code as the previous block.

 To conclude the Chenille section of design, a 'Chenille Off' code must 
be present. In TBF format, this is equivalent to a 'Lockstitch' code.

 After a 'Chenille Off' or 'Lockstitch' code is encountered, machine 
heads switch from Chenille to Lockstitch.

Handling chenille designs

Chenille files open in EmbroideryStudio like any other EMB design. 
Similarly, you save chenille designs to native EMB format or export them 
as machine files. They can be output to embroidery floppy disk, punched 
to a paper tape or sent directly to embroidery machine connected to the 
computer. The same file can be used by combination machines for both 
Chenille and Lockstitch embroidery.

Start a new chenille design

When you start EmbroideryStudio, a new file – Design1 – is automatically 
created ready for you to start digitizing. By default, Design1 is based on 
the NORMAL template. Use the CHENILLE template to create new chenille 
designs.

Use File > New Design to start a new design with the chenille template. 
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To start a new chenille design
 Start EmbroideryStudio and select CHENILLE as your template.

 Alternatively, with the design workspace already open, hold down 
Shift and click New Design. Or select File > New From Template 
to access the dialog. 
The CHENILLE template defaults the system to chenille values. The 
machine format will switch to the default chenille machine.

Note: Auto fabric is not applicable to chenille embroidery. Presets for 
pull compensation, underlay, backing, density, etc, have no relevance 
to chenille work.

 Select your preferred machine format from the droplist if different to 
the default.
Finished designs can be sent direct to most chenille machines, or 
saved to your preferred chenille machine file format.

 If you choose a different machine, you can save it to the CHENILLE 
template via this dialog. 

Tip: You can change machine format at any time on a 
design-by-design basis via the Design menu. 

Related topics
 Switch machine formats

Select Chenille 
template

Select machine 
format

Save to Chenille
template
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 Custom machine formats

Standard machine formats

Different embroidery machines speak different languages. They have 
their own control commands for various machine functions. If a design 
was created as a chenille design, you need to select the associated 
machine format when opening the file in order to display the chenille 
functions correctly. Similarly, before you can stitch a design, it must be 
in a format which can be understood by the machine. Chenille stitch types 
– Moss and Chain – can only be used with a chenille machine format.

EmbroideryStudio supports Tajima – both the old TMCE-100 and new 
TMCE-600 models – Barudan and Melco chenille machines. Chinese 
machines are capable of chenille with Dahao and other brands of control 
panel. Support is provided for these machine types:

Machine format File format

Tajima TBF TBF

Tajima TMCE-100 DST

Tajima TMCE-600 DST

Barudan FDR-II Chenille Combination U??

Barudan Chenille U??

Chenille Moss 
stitch

Chain stitch 

Moss stitch 

Lockstitch

Chenille Chain 
stitch

Lockstitch
lettering
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Tips for use
 ^ When exported, the file extension appears as ‘U01’ or ‘U02’, etc. The 

difference between the two formats is that FDR-3 U?? is compatible 
with newer machine function codes.

 * EmbroideryStudio does not support Dahao DHB machine file format. 
Only WilcomDahao ES can export to this format. However, the Dahao 
control panel can receive DST files. With DST, the machine operator 
must manually assign the Chenille yarn sequence as well as the 
lockstitch needlebar sequence. 

Related topics
 Chenille machine formats
 Machine format settings
 Chenille machine files
 Outputting chenille designs

Open & save chenille designs

As with lockstitch designs, all information about a chenille design is 
stored in the native EMB file format, regardless of machine format. This 

Barudan FDR-II Twin Sequin Chenille Combination U??

Barudan FDR-3 ^ (FDR-3) U??

Barudan FDR-3 Chenille Combination (FDR-3) U??

Dahao * DST

Melco Chenille EXP

ZSK Z??

Machine format File format

Use Standard > Save Design to save the current design. Right-click to open 
the Save As dialog.
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makes it easy to write designs to different formats. Chenille files open in 
EmbroideryStudio like any other EMB design. Similarly, you save chenille 
designs to native EMB like any other embroidery file.

To open or save a chenille design
 Click the Open icon or select File > Open. Open your EMB chenille 

design file like any other native design file.

 Click the Save Design icon. If this is the first time you have saved the 
design, the Save As dialog opens. Alternatively, choose File > Save 
As. File type will default to the latest EMB, but you can save to 
previous versions via the Save as type droplist.

Related topics
 Outputting chenille designs
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Chapter 3

Chenille Digitizing

Chenille design used to be a specialist technique. In reality, digitizing for 
chenille is easier than regular embroidery. In general, shapes are filled 
more simply and registration tolerances are broader.

It is important to map out a design, as you would regular embroidery, so 
as to minimize jumps. Even more than with regular embroidery, chenille 
designs need to employ simple, clear shapes which can be easily 
converted to chenille ‘stitch blocks’.
Concepts to keep in mind:
 Chenille work involves only two stitch types – Chain and Moss. 
 Chenille usually involves a combination of two basic fill patterns – 

Square and Coil, single or double.
 For chenille, you mainly use Compound Chenille in combination with 

Complex Fill to digitize objects – even narrow ones – with built-in 
chain or moss borders.

This chapter covers chenille input methods including creating compound 
chenille objects. It also covers creating chain-stitch fills, narrow chenille 
shapes, and borders. It also deals with needle heights.

Simplify shapes and map 
out artwork for use with 
chenille embroidery
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Creating compound chenille

Because borders are used so frequently, chenille digitizers have to apply 
some thought and special techniques to their work. As much as possible, 
chenille designs should be planned to use Complex Fill together with 
Compound Chenille. The advantage of compound chenille is the 
tie-in/tie-off. However, other techniques are available if you intend to use 
Chain fills. And if your machine supports it, you can use regular 
embroidery for tie-offs at the end of chenille objects, as well as details 
and embellishments.

Chenille fill pattern usage

Chenille work usually involves a combination of four fill patterns – Coil, 
Square, Double Square and Island Coil. The pattern you use depends 
on input method as well as object shape, size and the effect you want to 
achieve.

Pattern types
Coil and Island Coil are traditional forms of chenille fill. They are both 
stitched in spirals, typically of moss stitching. This fill type mimics 
hand-made chenille embroidery. Coil may be used to fill columns or 
narrow areas. Larger areas may be filled with Island Coil.

Alternatively, use Double Square to generate stitches on a grid rather 
than coils. Similarly, Square can be used for narrow shapes as an 
alternative to Coil.

Coil

Double Square with 
Compound Chenille

Square 

Island Coil with 
Compound Chenille

Square



Chapter 3   Chenil le Digit izing 28

Moss stitching
Compound Chenille is usually digitized with Moss stitching as the fill 
type. Chenille objects generally include a Chain border to contain the fill 
and provide edge definition. Single offset run-arounds before and after 
are usually sufficient.

Moss stitch, by its nature, is designed to provide dense cover. In 
stitchout, you should see only the fluffy ‘moss’ and not the underlying 
stitch pattern. In fact, if you are able to see fabric beneath the tufts, 
pattern density should be increased. 
So in theory, it makes little difference to the end result whether you use 
an underlying square or coil pattern. In practice, however, moss 
appearance with square or coil patterns is somewhat different. Bear in 
mind...
 With Coil, the moss effect looks consistent from any direction.
 Square pattern moss varies with the direction of view.
 There is a limitation with Coil in handling sharp corners. Square 

patterns are generally more suited to stitch blocks with sharp corners.
 While stitch angle has no effect on Coil patterns, it can affect the 

appearance of Square patterns. Recommended angles are 30° or 
120°.

Related topics
 Other parameters
 Chenille patterns
 Creating compound chenille
 Creating chain-stitch fills
 Creating narrow chenille shapes
 Creating chenille borders

Create compound chenille objects

Moss stitch
provides dense

all-over cover

Chain stitch border
lower in height

Felt backing

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.
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Digitizing chenille objects involves the same techniques as regular 
lockstitch embroidery with the addition of chenille stitch types, Moss and 
Chain. For chenille work, you mainly use Complex Fill in combination 
with Compound Chenille to digitize objects – even narrow ones – 
mainly in combination with Moss stitching and built-in chain or moss 
borders. 

To digitize a compound chenille object
1 Open a new design using the Chenille template and select a machine 

format to suit.
2 Select a closed shape input tool such as Complex Fill. Some graphic 

tools can be used in combination with Compound Chenille, such as 
Closed Shape, Rectangle, Ellipse, and Basic Shapes.

3 Select Moss stitch and click the Compound Chenille icon. Chain has 
limited applicability to coil or double-square fill patterns.

4 Select a fill pattern. Compound Chenille objects will only work with 
these:

Tip: In theory, it makes little difference to the end result whether you 
use an underlying square or coil pattern. In practice, square patterns 
produce fills that vary in appearance with the direction of view. 
However, they are generally more suited to squarish shapes with sharp 
corners.

Use Chenille > Moss to create a looped pile look.

Use Chenille > Compound Chenille to automatically digitize chenille 
shapes with offset borders.

Fill pattern To fill...

Square Narrow shapes with single layer of straight lines.

Double Square Larger shapes with two layers of straight lines.

Island Coil Larger shapes with double-spiral stitches.
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5 Select a yarn color from the palette. Remember, the View by 
Chain/Moss function uses the first three colors in the palette. Color 
slots 1-3 are best left for display purposes only, where:

6 Digitize the boundary like any embroidery object:
 Left-click for corner points
 Right-click for curve points.

Tip: Use the prompts in the Prompt Bar to help you digitize. If you 
make a mistake, press Backspace to delete the last reference point. 
Press Esc to undo all new reference points.

7 Press Enter to complete.
8 Mark entry and exit points on the boundary.
9 Define stitch angle by digitizing two points.

Tip: While stitch angle has no effect on coil fill patterns, it can affect 
the appearance of square fill patterns. Best angles are 30° or 120°.

Slot Default Element

1 Green Lockstitch
2 Blue Chain
3 Red Moss

Last point marked on top of 
first with right button
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Press Enter – the object is 
closed automatically

str
aight 

lin
e

1

2

3

4
5

6
7

8 9

10

11
12

1

2

3

4
5

6
7

8 9

10

11
12

13

For square fills, set 
stitch angle to 30° or 
120°
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10 Press Enter to complete. The Compound Chenille object is 
generated according to current settings.

11 With the object selected, open the Object Properties > Compound 
Chenille tab to adjust settings.

Tip: The Compound Chenille tool in fact allows for up to three (1-3) 
offset borders, before and after. Borders can employ either moss or 
chain stitching, at specific offsets and needle heights. If you intend to 
use loops of different height, adjust needle height rather than the 
stitch length. This method is easier and more accurate.

Related topics
 Start a new chenille design
 Digitizing with graphical tools
 Creating free-form shapes
 Chenille design parameters
 Compound chenille settings
 Controlling needle heights
 Visualizing chenille stitching

Convert lockstitch to chenille

You can convert complex fill and other closed objects to chenille using 
Compound Chenille. Multiple offset runs are generated automatically 
from the same boundary.

Double 
Square fillsIsland Coil fill

Square fills

Use Chenille > Moss to create a looped pile look.

Use Chenille > Compound Chenille to automatically digitize chenille 
shapes with offset borders. Right-click to adjust automatic offset borders.
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To convert lockstitch to chenille
1 Open a new design using the Chenille template and select a machine 

format to suit.
2 Select the complex fill or other closed object.
3 Select a chenille stitch type – usually Moss.
4 Select a chenille fill pattern – Square, Double Square or Island 

Coil. Once you have selected a pattern, the Compound Chenille icon 
becomes active.

5 Click the icon. Offset borders and a chenille fill are generated 
according to current settings.

Compound Chenille can be applied to many closed objects, including 
standard shapes.

6 With the object selected, open the Object Properties > Compound 
Chenille tab to adjust settings.

Related topics
 Start a new chenille design
 Compound chenille settings
 Controlling needle heights
 Visualizing chenille stitching

Complex Fill
object

Compound
Chenille object
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Creating chain-stitch fills

Because chain stitching forms flowing, curved lines, it is mainly used for 
outlines and more delicate work. It can, however, be used to create 
flatter fills. Because chenille yarn is thicker than normal thread, it is 
critical to avoid yarn pile-up caused by overlapping stitches, particularly 
chain stitches. For this reason, we recommend using open stitch patterns 
such as Maze Fill, Offset Fill, or Spiral Fill to create the kind of effect 
you see in this sample.

Tip: With Chain stitch blocks, there is no need for borders as such. Chain 
itself provides a good border.

To digitize a chain-stitch fill
1 Open a new design using the Chenille template and select a machine 

format to suit.
2 Choose an input method – graphical or traditional.

Since stitch angle has no relevance to chain stitching, Complex Fill is 
fine for most shapes. Some graphic tools may be used – Closed 
Shape, Rectangle, Ellipse, and Basic Shapes.

3 Select Chain stitch and choose a suitable fill pattern:

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.

Use Chenille > Chain for decorative stitching resembling links of a chain. 
Can be used as a delicate fill or as a border for moss fills. Right-click to 
adjust settings.

Fill pattern Uses

Maze Fill Create maze-like stitching which follows object contours 
for open fills.

Offset Fill Create offset fill stitching in any closed shape.

Moss stitch fill

Chain stitch border

Chain stitch fill
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4 Right-click for settings and adjust spacing and length as necessary. 
Stitch length determines the size of chain. The greater the value, the 
larger the pattern. Spacing needs to accommodate yarn thickness.

5 Digitize the boundary like any embroidery object:
 Left-click for corner points
 Right-click for curve points.

Tip: Use the prompts in the Prompt Bar to help you digitize. If you 
make a mistake, press Backspace to delete the last reference point. 
Press Esc to undo all new reference points.

6 Press Enter to complete. The chain-fill object is generated according 
to current settings.

7 With the object selected, open Object Properties to adjust fill 
settings, including spacing.

Related topics
 Start a new chenille design

Spiral Fill Create spiral stitching from the center of any closed object.

Fill pattern Uses

Last point marked on top of 
first with right button
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Press Enter – the object is 
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Chain with Square fill and 
Compound Chenille

Chain with 
Maze fill

Chain with 
Offset fill

Chain with 
Spiral fill
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 Chenille design parameters
 Digitizing with graphical tools
 Creating free-form shapes
 Maze fills
 Offset fills
 Spiral fills
 Visualizing chenille stitching

Creating narrow chenille shapes

Complex Fill, and by extension Compound Chenille, cannot be used 
with Coil and will default instead to Island Coil. Variable-width Coil 
stitching can only be created with Column A or Column B input 
methods. Column C can be used to create columns of constant width. 
Square fill can also be used for narrow shapes. Moss stitching is usually 
applied to both fill types.

Create narrow shapes of varying width

To fill narrow shapes of varying width, use Coil or Square fill with Moss 
stitching. Coil stitches are generated in spirals. Each stitch traverses the 
width of the column. With Square fill you can fill areas diagonally, or on 

Column A/B with coil

Complex fill with island coil

Use Fill Stitch Types > Coil to stitch narrow shapes or columns where each 
stitch traverses the column width. Right-click to adjust settings.

Use Fill Stitch Types > Square to create open straight parallel fills. 
Right-click for settings.

Use Traditional Digitizing > Column A to create columns of varying width 
and stitch angle. Right-click for settings.

Use Traditional Digitizing > Column B to create asymmetrical columns of 
turning stitches, where opposite sides are different shapes. Right-click for 
settings.
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the horizontal and vertical. Stitch length is consistent even over different 
widths. For more delicate work, use Square fill with Chain stitching. 

To digitize shapes of varying width
1 Select your preferred stitch pattern with Fill Stitch > Coil or Square.
2 Select the preferred chenille stitch type:

3 Create a chenille object using Column A or Column B as your input 
method.

Tip: Use the prompts in the Prompt Bar to help you digitize. If you 
make a mistake, press Backspace to delete the last reference point. 
Press Esc to undo all new reference points.

4 Press Spacebar or Enter to generate the shape.

Chenille stitch Uses

Moss Create dense cover using looped stitch typical of chenille 
raised stitching. Can be used with Coil or Square fill patterns.

Chain Create decorative stitching resembling links of a chain. Can 
be used with Square fill pattern.

Column B + 
CoilColumn A + Coil

Column A + Square
Column B + 

Square
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 Use Spacebar to generate open-ended coil stitching. This is useful 
for joining objects. 

 Use Enter to generate closed-ended coil stitching.

Note: Because moss stitching tends to unravel, you need to create a 
border around the object. For this, you typically use the Run method 
with Chain stitching. If your machine supports it, you may also 
combine chenille with regular tie-off stitching.

Related topics
 Digitize columns of varying width
 Creating chenille borders
 Chenille design parameters
 Chenille patterns
 Visualizing chenille stitching

Create narrow shapes of constant width

To fill narrow shapes of constant width, use Coil or Square outlines with 
Moss stitching. 

Press Spacebar for open coil Press Enter for closed coil

Use Outline Stitch Types > Coil to Use to create borders or columns of even 
width for an open ‘coil’ effect. Right-click to adjust settings.

Use Outline Stitch Types > Square to create open borders or columns of 
even width for an open ‘toothed’ effect. Right-click for settings.

Use Traditional Digitizing > Column C to digitize columns or borders of 
fixed width. Right-click for settings.

Column C + Coil Column C + Square
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To digitize coil shapes of fixed width
 Select your preferred stitch pattern with Outline Stitch > Coil or 

Square.
 Select the preferred chenille stitch type:

 Create a chenille object using Column C as your input method.

Tip: There is a limitation with Coil in handling sharp corners. Square 
patterns are generally better suited. The Smart Corners effect can be 
used with Column C objects.

 Press Enter to generate the shape.

Chenille stitch Uses

Moss Create dense cover using looped stitch typical of chenille 
raised stitching. Can be used with Coil or Square fill patterns.

Chain Create decorative stitching resembling links of a chain. Can 
be used with Square fill pattern.
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 Juggle spacing settings in accordance with yarn thickness.

 Adjust coil spacing for looser or tighter looking chenille. Combine with 
width to achieve the desired chenille look.

 Stitch length determines the gap between needle points. For chain 
stitching, 2mm is standard. For moss stitching, it may be adjusted for 
yarn thickness.

Note: If you are using moss stitching, you need to create a border 
around the object. For this, you typically use the Run method with 
Chain stitching. If your machine supports it, you may also combine 
chenille with regular tie-off stitching.

Related topics
 Create columns & borders
 Controlling corner stitching
 Chenille design parameters
 Chenille patterns
 Visualizing chenille stitching

Stitch spacing: 2.5mm Stitch spacing: 5.0mm

Coil spacing: 5mm Coil spacing: 10mm

Stitch length: 2mm Stitch length: 5mm
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Creating chenille borders

Chenille objects, particularly with moss stitching, need to have a border 
to contain stitches within the shape and provide edge definition. One or 
two offset run-arounds provide a clear edge and help to secure chenille 
fills. The Compound Chenille tool allows up to three (1-3) offset 
borders to be generated before and after the fill. Typically, a compound 
object will include moss fill with a chain run border before and after to tie 
it all together. You can, however, digitize single-line borders manually. For 
this, you often use the Run method with Chain stitching. 

Tip: If your machine supports it, you may also combine chenille with 
regular tie-off stitching.

To digitize a chenille border
1 Select Digitize Run input method. Chenille Run stitches are similar 

to lockstitch except that stitch length should be constant.
2 Open Object Properties and turn off Variable run length.

3 Set a suitable stitch length. This value determines the size of chain. 
The larger the value, the larger the pattern. It is a matter of 
experience and preference based on yarn thickness.

4 Choose Chain stitch type for chenille runs and borders.

Use Chenille > Chain for decorative stitching resembling links of a chain. 
Can be used as a delicate fill or as a border for moss fills. Right-click to 
adjust settings.

Use Traditional Digitizing > Digitize Run to create row of single stitches 
along a digitized line.

Use Graphics Digitizing > Digitize Open Shape to digitize open shapes. 
Press <Ctrl> to constrain.

Use Toolbox > Simple Offsets to create simple outlines for any filled 
embroidery or closed vector object.

Adjust nominal 
stitch length

Turn off variable
run length
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5 Digitize the boundary like any embroidery object:
 Left-click for corner points
 Right-click for curve points.

Tip: Use the prompts in the Prompt Bar to help you digitize. If you 
make a mistake, press Backspace to delete the last reference point. 
Press Esc to undo all new reference points.

6 Press Enter to complete.

Tip: Use Backtrack and Repeat to reinforce outlines while specifying 
the direction of stitching.

Tips for use
 You may also create closed chenille borders with most of the graphical 

input methods in combination with Run outlines, including Basic 
Shapes.
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 You can also generate chenille borders by duplicating or cloning 
objects and applying Run with, say, Chain stitch. Or use the Simple 
Offsets tool to quickly generate one or multiple borders.

 Remember too that you can create standalone chenille boundaries by 
turning off stitch fills in Compound Chenille objects.

Related topics
 Digitizing outlines & details
 Duplicate & clone objects
 Generating outlines & offsets
 Reinforce outlines
 Chenille design parameters
 Visualizing chenille stitching

Compound chenille settings

Turn off stitch 
fill altogether

Use Traditional Digitizing > Complex Fill to digitize filled shapes with a 
single stitch angle. Right-click for settings.

Use Chenille > Moss to create a looped pile look.
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Most chenille objects are digitized with Complex Fill in combination with 
Compound Chenille to create objects – even narrow ones – with built-in 
chain or moss borders. Some graphical tools can be used in combination 
with Compound Chenille, including Closed Shape, Rectangle, 
Ellipse, and Basic Shapes. Compound chenille objects must include a 
fill of Coil or Square stitching, usually with Moss stitch applying.

The Compound Chenille tool allows for up to three (1-3) offset borders, 
before and after. Borders can employ either moss or chain stitching, at 
specific offsets and needle heights.

Border settings

Chenille has no bobbin thread. Without tie-ins and tie-offs, Moss 
stitching can loosen during washing. It is common for a chenille object to 
employ moss fill with a chain border, before and after. Normally you first 
run a chain border as a tie-in. After the fill, a chain border is again applied 
as a tie-off.

As mentioned, Compound Chenille allows for up to three (1-3) offset 
borders, before and after. The number you add depends on size of object 

Use Chenille > Compound Chenille to automatically digitize chenille 
shapes with offset borders.

Offsets outside object
boundary (negative values)

Offsets inside object
boundary (positive values)

Object boundary

Fill stitch
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– the bigger the object, the more borders can be added. You have 
independent control over offset distance, stitch type – chain or moss – as 
well as needle height. As well as holding chenille objects in place, borders 
provide edge definition and embellishment. Variable heights can also be 
used to create gradations from center fill to outside edge.

To set border properties
 Select a Compound Chenille object and right-click the icon. The 

Object Properties > Compound Chenille docker opens.

 Set the ‘before fill’ offsets as required:
 Set a stitch type for each: Chain’, ‘Moss’, or ‘None’ (no offset). The 

first, and possibly only border, is usually stitched with Chain to act 
as a tie-in.

 Add borders as preferred: depending on object size, you may add 
more borders for edge definition and embellishment – the bigger 
the object, the more borders can be added. 

 Set offset distance: use a positive value to position the border 
within the boundary, a negative value to offset it outside the 
boundary.

Select before or
after fill

Specify offset 1

Specify offset 2

Specify offset 3
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 From the droplist, set a needle height for each offset. This 
determines the height of loop formed when sewing moss stitch. It 
also affects the width of chain stitches.

 Repeat the operation for ‘after fill’ borders as required. Again:
 Set border stitch type: the first, and possibly only border, is usually 

stitched with Chain. This helps ‘tie-off’ the chenille object.

Tip: In practice, multiple borders tend to be stitched before rather 
than after the fill. From a stitch quality point of view, borders ‘after 
fill’ should be reserved for tie-off stitching. In the final stitch-out, you 
will see the number of borders but you won’t be able to tell which were 
stitched ‘before’ or ‘after’ the fill.

Related topics
 Create compound chenille objects
 Chenille design parameters
 Controlling needle heights

Other settings

The Compound Chenille docker allows you to:
 Set the number of overlapping stitches between offset runs.
 Change run stitch direction, clockwise or anti-clockwise.
 Set offset stitch length – both chain and moss.
 Set offset needle height for machines which support it.
 Exclude stitch fill altogether.

Overlapping stitches
The Overlapping Stitches setting allows you to set the number of 
overlapping stitches between offset runs. This shifts connectors between 

 Offset 1.5mm
outside outline

Offset 1.5mm inside 
outline

Object outline 
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offset runs by a few stitches to prevent stitch buildup at the joins. Also, 
connectors are less visible if they are not in one line.

Run stitch direction
You can set the run stitching direction for offset borders. 

The correct direction is important for moss borders. When stitching out, 
the yarn should not loosen due to any counter-twisting effect. Instead, it 
should be more tightly twisted. When purchasing yarns, some 
embroiders check the twisting direction to make sure it is right for the 
machine.

Offset stitch length
You can adjust stitch length for both chain and moss offsets. 

Stitch length should be constant for the same thread type throughout a 
design. If stitch length varies, the height of moss loops and width of chain 
loops will also vary, causing uneven embroidery. The chenille machine 
pulls up the same length of yarn for each loop according to the current 
needle height setting. 

Offset needle height
Needle Height controls are available for each offset. If you intend to use 
loops of varying height, always adjust needle height rather than stitch 
length. Even though stitch length also affects the loop height, it is easier 
and more accurate to adjust needle height. Needle height has less effect 

Enter number of
overlapping stitches

Two overlapping stitches

Select run direction

Adjust stitch length for 
both chain and moss
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on chain stitches although it does affect width. See also Controlling 
needle heights.

Fill offset
Optionally, enter a Fill Offset value. Fill Offset sets the gap between the 
digitized boundary and fill area. It is always measured from the object 
boundary, not from the last offset. Use a positive value to position the 
border within the boundary, a negative value to offset it outside the 
boundary.

Tip: Color changes can be manually inserted between fill and offsets.

Borders without fills
The fill in a compound chenille object is included by default. However, you 
can choose to include or exclude it and just use offset borders. You might, 

Set needle height
for each offset as

required

Fill offset: 0.0mm Fill offset: 2.5mm
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for example, want to exclude the fill when creating a common chenille 
border around multiple chenille objects.

Related topics
 Create compound chenille objects
 Chenille design parameters
 Controlling needle heights

Controlling needle heights

Needle height controls the height of the loop formed by the chenille 
machine when it is sewing a moss stitch. The needle height setting has 
less effect on chain stitches though it does affect width. Normally, it’s 
best to use default settings. Do a test run on the machine to check the 
outcome. Then, if necessary, adjust needle heights.
If you intend to use loops of varying height, you can insert Needle 
Height functions and set their positions during digitizing. Even though 
stitch length affects loop height, it is easier and more accurate to adjust 
needle height. For safety, apply needle height values to each Moss block, 
even of the same height.

Note: When you apply an explicit needle height to Compound Chenille 
objects, it only affects the fill, usually moss. It does not affect the values 
associated with included borders.

To adjust needle heights
 Select the Moss object, including Compound Chenille, you want to 

adjust.

Untick to exclude fill
altogether

Click Chenille > Needle Height to set needle height values.
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 Click the Needle Height icon. The dialog opens.

 Select a needle height value from the list and click OK. When stitching 
out, the chenille machine will automatically change needle height 
according to your selection. 

 In the Stitch List, check that the setting has been applied.

Tip: With some machines, needle height can optionally be adjusted on 
the machine. In practice, it is more common to adjust there rather than 
in the design. If so, clear the checkbox in the Machine Format Values 
dialog if you want to select needle heights manually on the machine.

Related topics
 Chenille design parameters
 Machine format settings
 Needle height default

Choose needle
height value
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Chapter 4

Chenille Lettering

EmbroideryStudio allows you to create special chenille lettering. The 
chenille fonts provided with the software can be scaled and recolored like 
other fonts. Or you can create your own.

This chapter deals with chenille lettering. It covers scaling chenille 
lettering and using other fonts with chenille.

Adding lettering to chenille designs

The Chenille add-on Element includes dedicated chenille fonts. These 
fonts can be scaled and colored like regular fonts. By their nature, 

Click Toolbox > Lettering to enter text on screen. Right-click to enter text in 
the docker and adjust settings for embroidery lettering.

Use Chenille > Moss to create a looped pile look. Right-click to adjust 
settings.
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however, chenille fonts are digitized for relatively large applications – 
anywhere between 2" (50mm) and 6" (150mm).

Add chenille lettering as you would regular lockstitch lettering. Select a 
chenille font via the Lettering docker. Chenille fonts are tagged with the 
prefix ‘CH’.

Chenille fonts can be used like regular fonts except that they must 
employ the ‘As Digitized’ joining method. Some are digitized with Coil fill, 
others with Double Square. If you break chenille lettering into its 

Select chenille
font
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component letters, you will find each one is a compound chenille object 
with a single chain and two moss offsets before the moss fill.

If you check the Stitch List, you will see again that each letter is stitched 
with its own chain and moss stitching.

Related topics
 Creating Embroidery Lettering
 Chenille fonts

Scaling chenille lettering

Some chenille fonts are made to suit a particular letter size and one type 
of thread (thickness) only. The size of these fonts cannot be successfully 
varied by more than 5-10% from that recommended. It is not 
recommended that you change the stitching values (stitch length, 
spacing, etc) of these fonts at all. Other chenille fonts have been 
designed for use within certain size ranges and of these some Double 

Moss fill
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Square fonts allow object properties such as stitch length, spacing and 
offsets to be varied.

Related topics
 Modifying lettering

Using other fonts with chenille

You can, with some effort, use standard embroidery fonts and even 
TrueType font for chenille lettering. Font letters are usually digitized with 
Column A so you cannot automatically add borders with Compound 
Chenille. You need to add a border either manually or by generating 
offsets. For instance, let’s say you want to create chenille lettering with 
a regular block font and coil fill. Each letter would quickly unravel without 
traditional chenille chain and moss outlines.

You could attempt to use the Simple Offsets to generate outlines and 
turn them into chain runs. However, as shown here, you are likely to end 
up with a single outline around the entire lettering object.
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A solution can be found by increasing letter spacing before generating 
simple offsets. However, there is a problem in that the offsets are 
generated as separate objects following the lettering.

The lettering object must be broken apart and everything resequenced. 

For additional embellishment, you could generate other offsets around 
the entire object – e.g. Column C with Coil and Moss.

Lettering object
followed by generated

outlines

Break apart lettering
and resequence
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Chenille fonts

A selection of standard fonts is included, both Coil and Double Square 
filled fonts. Chenille fonts can be used like regular fonts except that they 
must employ the ‘As Digitized’ joining method. By their nature, chenille 
fonts are digitized for relatively large applications – anywhere between 
2" (50mm) and 6" (150mm). They are not suitable for, say, a chest 
pocket. The table lists the Chenille fonts with their recommended size 
ranges:

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm

CH 2Color 
Numbers 2 50 5 125 AD

CH 2inch 
Pennant Script 2 50 2 50 AD

CH 3inch 
Pennant Script 3 75 3 75 AD

CH 3.5inch 
Shadow Nos 3.5 87 3.5 87 AD

CH 6inch 
3D-Block 6 150 6 150 AD
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CH Chenille 
Block 2 50 6 150 AD

CH Playbill 4 100 6 150 AD

CH Prince 
Athletic 2 50 6 150 AD

CH Square 
Block 2 50 6 150 AD

CH Tall 
Pennant Script 3 75 4 100 AD

Font Sample
 Recommended Sizes Join 

MethodMin Max

in. mm in. mm
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Chapter 5

Chenille Output

Different embroidery machines speak different languages. They have 
their own control commands for the various machine functions. Before 
you can stitch a design, it must be in a format which can be understood 
by the embroidery machine. When you select a machine format, 
EmbroideryStudio translates the functions that were applied during 
digitizing into machine functions that can be understood by the machine. 
Chenille stitch types – Moss and Chain – can only be used with a chenille 
machine format.

Chenille files open in EmbroideryStudio like any other EMB design. 
Similarly, you save chenille designs to native EMB format or export them 
as machine files. They can be output to embroidery floppy disk, punched 
to a paper tape or sent directly to embroidery machine connected to the 
computer. The same file can be used by combination machines for both 
Chenille and Lockstitch embroidery.
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01
01
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01
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Tip: From the same design file, you can also output a production 
worksheet for the embroidery machine operator. See Design Reports for 
details.
This chapter deals with chenille machine formats and settings. It also 
covers chenille machine files and chenille output.

Chenille machine formats

If you select the CHENILLE template when opening a design, the machine 
format will default to a chenille machine. You can change machine 
formats at any time. Finished designs can be sent direct to a Melco 
chenille machine, or stitched on Tajima and Barudan chenille machines. 
If your machine is different, you can customize machine format settings. 
For example, different models of the same machine may require different 
values for the same functions. You have three options:
 Modify the format for a specific design, creating a custom format to 

use only with that design.
 Modify one of the standard formats provided. Obviously, you would 

only do this if you no longer needed the original values.
 Create a new format, based on the original, and make it available to 

all designs. 

Switch machine formats

Once a design is complete, you can output to any supported embroidery 
machine without changing the original machine format. Explicit support 
is provided for these machine types:
 Tajima TBF 
 Tajima TMCE-100 
 Tajima TMCE-600
 Barudan FDR-II Chenille Combination
 Barudan Chenille
 Barudan FDR-II Twin Sequin Chenille Combination
 Barudan FDR-3 
 Barudan FDR-3 Chenille Combination
 Melco Chenille
If a selected machine format does not support a particular function in the 
design – either automatically or manually inserted – it is simply ignored. 
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To switch machine formats
 Select Design > Select Machine Format.

 Select the required chenille machine format from the list.
 To check the settings for the selected format, click Settings.
 Click OK.

Combined chenille & lockstitch

Chenille designs can be converted to any machine format, including 
lockstitch machines. This is useful when you wish to combine regular 
embroidery and chenille embroidery in a single design. Combined chenille 
and lockstitch design can be output to machine from a single file.

To combine chenille and lockstitch
 Plan your chenille and lockstitch design.

Select machine
format

Current machine 
format
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 Select a combination machine format via the Design menu.

 Design you design using a combination of chenille and lockstitch stitch 
types.

 When using a machine that supports both lockstitch and chenille, you 
can easily interchange lockstitch and chenille objects by selecting or 
deselecting chenille stitch types – Chain or Moss.

Modify format for specific designs

Use this method if you intend to modify machine format values for a 
specific design without changing the original format. Select Design > 
Machine Format Settings.

Adjust format settings as required. A new machine format is created for 
the particular design. It is automatically named after the original machine 
format together with the design name – e.g. Melco - Design1. This 
appears in the Select Machine Format dialog and is saved with the 
design.

Select
combination

machine format

Modify values

Adjust both standard 
and advanced 
settings

Format name
cannot be changed
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Related topics
 Machine format settings

Modify standard formats

If the standard machine values are incorrect for your particular machine, 
you can change them. From the Select Machine Format dialog, select 
a machine format to modify.

Click Settings to access the format settings. Adjust format settings as 
required. The new settings are saved with the selected format and are 
available to all new designs.

Related topics
 Machine format settings

Create custom formats

If you don’t want to overwrite standard machine formats, you can create 
a new format, based on an original, and make it available to all designs. 

Select machine
format to modify

Access format 
settings

Format name 
cannot be changed

Modify settings
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Select Design > Select Machine Format and select a machine format 
on which to base the new format.

Click Create. The Machine Format Settings > Standard tab opens.

Enter a name for the new format. Overwrite the default – e.g. ‘Chenille 
Combination-1’. In the Comment field, enter any information that will 
help you identify the format – e.g. ‘No Trim’. Adjust machine format 
settings as required. The new format appears in the Available Machine 
Formats list.

Select machine
format

Create new 
format based on 
selected

Enter a name for 
the format

Modify settings

Custom machine
format

Click to remove 
format
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Note: You can’t remove standard formats but you can remove custom 
machine formats from your system when they are no longer required.

Related topics
 Machine format settings

Check control commands

If you change the machine format of a design that contains manual 
machine functions, you may need to check whether the functions are 
compatible with the new format. Generally, functions that cannot be 
performed by the machine are simply ignored. If an ignored function was 
inserted on an Empty Stitch or Empty Jump, the stitch or jump is 
automatically removed. Sometimes, however, functions may not be 
correctly translated. For example, trim commands may be 
misinterpreted, as some machines use trim codes, and others a sequence 
of jumps.

Note: If a function is not available in the new machine format, the word 
Ignored appears in brackets after the function name.

To check control commands
 Travel to the position of the machine function. 
 Alternatively, use the Stitch List to identify and select a given 

machine function. 
The machine function name appears in the Prompt Bar. Extra 
information may appear in brackets after the function name – e.g. 
needle number.

Machine format settings

Different machines require different settings. When you select a machine 
format, only fields relevant to the selected machine format will appear. 
To modify settings, access the Machine Format Settings dialog. Typical 
modifiable values are maximum and minimal stitch and shortcut angle 
values.
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Chenille machine format values

Chenille machines have the same machine format values as standard 
lockstitch, except for the following:

The Advanced tab lets you set additional machine format options. Again, 
available settings depend on the selected machine format. You can set 
color change sequence, and insert special codes for the start or end of a 
design. 

Warning: Only change settings if you are familiar with the codes used 
by your embroidery machine.

Minimal & maximal stitch values

The chenille stitch length settings avoid small stitches during chenille 
stitch generation. This filter operates only on chenille stitch types and has 
no effect on lockstitch stitch types. That is, unless the format pertains to 
a combination machine. In that case, you can set values independently 
for lockstitch and chenille.

In the Minimal Stitch field, enter the smallest stitch to allow when 
outputting to the selected machine. The Maximum Stitch value depends 
on the tape code used by your machine:

Machine Additional values

Melco Chenille Minimal Stitch, Shortcut Angle, Needle Height Explicit value

Tajima TMCE-600 Minimal Stitch, Shortcut Angle

Tajima TMCE-100 Minimal Stitch, Shortcut Angle, No Boring
Maximum frame movement is 4.0mm

System Value

Binary 12.7 mm

Ternary 12.1 mm

Minimal and maximal
stitch length settings
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Related topics
 Machine Formats

Shortcut angle values

Some chenille machine types require that the angle between one stitch 
and the next is not very sharp – e.g. Tajima chenille machines require it 
to be at least 60°. The Chenille Shortcut Angle setting avoids sharp 
changes in stitch direction during chenille stitch generation. 

This filter operates only on chenille stitch types and has no effect on 
lockstitch stitch types. Chenille automatically applies the shortcut angle 
to all cover stitches inside an object. However connections between travel 
stitches and offsets and fills are not always checked. Also, the shortcut is 
not applied to connecting stitches and jumps between objects.

Design checker
A design checker is provided to identify chenille Shortcut Angle 
violations. The design checker is activated by hot key Ctrl+K. The stitch 
cursor will jump to the first stitch which violates the Shortcut Angle. You 
must correct this problem by stitch editing. Press the hot key 
combination again for the software to detect any problems further into 
the design. 

Note: Non-EMB embroidery format chenille designs can be 
shortcut-checked when opened into EmbroideryStudio by clearing the 
Outlines/Objects checkbox.

Related topics
 Machine Formats

Adjust shortcut
angle
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Color-change values

Chenille machines interpret ‘Color Change’ functions in the design either 
as a Needle Number or Stop functions on the machine.

The following rules apply:
 Single-needle machines simply stop when a Color Change or Stop 

function is encountered.
 Some multi-needle machines default to the next color without 

stopping.
 Some multi-needle machines support direct needle addressing.

Needle addressing
For needle addressing machines, you need to specify how many needles 
or loopers are on the machine. Or both, in the case of combination 
machines. This tells the machine how often it needs to stop for the 
operator to change threads. For example, for a design with 15 colors to 
be stitched out on a machine with five needles, it must stop after every 
three color changes in order for the operator to change threads.

Function Purpose

Stop Stop functions allow the operator to manually change threads. They 
are generally used with machines that only have one needle. Stop 
functions are sometimes combined with Jump functions to indicate 
color changes.

Color 
Change

For those machines that support them, Color Change functions tell 
the machine to move to the next needle whenever a CC function is 
encountered. The machine must have the correct thread colors 
loaded according to the production worksheet.

Needle 
Number

For needle addressing machines, each color ‘slot’ on the color 
palette corresponds to a needle number. Needle Number functions 
are sometimes combined with Jump functions to indicate color 
changes.

Color change settings
in combination

machine
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Other settings
Other settings may include:

Related topics
 Machine Formats

Trim functions

Trim functions in chenille are basically the same as lockstitch. The 
difference is the absence of tie-ins and tie-offs due to mechanical 
limitation of the chenille head. With some machine formats you can 
specify how to format and interpret trim commands. Some machines 
understand specific trim codes. Other machines interpret multiple jumps 
as a trim command. 

Machines without an automatic trimmer may not know how to interpret 
trim commands, and may even shift the design when a trim code is 
encountered. For these machines you need to deselect the Output trims 
checkbox so that trim functions are ignored when the design is stitched.

Note: If you deselect the Output Trims checkbox, the trim functions are 
not removed from the design but simply ignored for the selected machine 
format. 

Setting Purpose

Use group 
addressing

Some machines can group two heads together so you can stitch 
a design using needles from both heads. For example, if a 
machine has two heads and nine needles per head, the machine 
moves the hoop from the first head under the second head, which 
allows you to stitch 18 colors without a manual change. 

First CC 
required

Some machines require a First CC code to initialize the machine 
and bring the head back to the first color change needle position.

Return to start This returns the needle to the start of design, preparing the 
machine for the repeat run.

Select to output
trim functions

Specify number of 
jumps to trim
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Related topics
 Machine Formats

Needle height default

On some chenille machines, needle height can be set to control the loop 
size formed when a machine sews moss stitch.

With some machines, needle height can also be adjusted on the machine. 
Thus you can choose whether to use heights specified in the design or 
not. Clear the checkbox if you want to select needle heights manually on 
the machine.

Related topics
 Machine Formats

Borer functions

Some embroidery machines are equipped with a borer. The borer often 
replaces one of the needles. 

Borers are often ‘knife’ attachments where the cutting position is offset 
12mm from the main needle. You need to specify the needle position of 
the borer and its offset value. 
 If your machine automatically enters an offset when a Borer In 

function is encountered, enter an offset of 0mm.
 If your machine requires an offset value, enter an offset of 12.0mm.

Check to use the
needle heights

specified in the design

Color change settings
in combination

machine

Enter borer 
offset
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Related topics
 Machine Formats

Color-change sequence

Some machines cannot interpret Color Change commands unless they 
form part of a ‘color change sequence’ made up of Empty Jumps and 
Empty Stitches before and after each Color Change command. Check 
the requirements of your machine to determine whether you need to 
enter color change sequence values.

In the Advanced tab, the Color Change Sequence panel reads from 
top to bottom, in the order the codes appear in the sequence. The first 
two fields show the number of Empty Stitches and Empty Jumps to 
insert before the Color Change command. The other fields show the 
Empty Jumps and Empty Stitches to insert after the command.

Related topics
 Machine Formats

Start/end of design sequence

In addition to any End of Design function, some machines require extra 
Empty Stitches and Empty Jumps in order to stitch the start and end of 
a design. Other machines require a Stop function. Depending on the 
machine type, you may also require commands to initialize the machine 
or trigger the frame out exit after stitching. Remember that these fields 

The color-change sequence in 
Stitch List corresponds to 
sequence defined in the 
machine format settings.
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show the number of extra codes you want to insert in addition to the 
default values.

When starting with chain stitching, an empty stitch (non-data) code will 
automatically be inserted at the start of the design. When starting with 
moss stitching, an empty stitch (non-data) and a stop code will be 
automatically inserted at the start of the design.

Warning: Do not digitize two Empty Stitches at the beginning of the 
design, as this will affect registration. Avoid using Empty Stitches 
elsewhere in the design. Other Tajima chenille values are the same as the 
standard lockstitch Tajima machine values.

Related topics
 Machine Formats

Chenille machine files

Different embroidery machines understand different languages. Each has 
its own control commands. Before you can stitch out a design, it must be 
in a format which can be interpreted by the machine. Machine or ‘stitch’ 
designs are low-level formats for direct use by embroidery machines. 
They contain only stitch coordinates and machine functions. They are 

Specify extra codes to 
insert in addition to 
default values
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generally created on-the-fly when sending designs to machine. Or they 
are converted when saving to disk or memory stick.

Tip: There is no chenille-specific machine file format as such. However, 
if a design was created as a chenille design, you will need to select the 
associated machine format when you open the file in order to display it 
correctly.

Read chenille designs

When you read a chenille machine file, it is converted to EMB format. The 
chenille functions appear in the converted design in the same way as they 
are stored in the machine file or on paper tape. When reading a chenille 
design from stitch data – e.g. Melco EXP, Tajima or Barudan disk – Stitch 
Processor converts stitches to objects. However, it does not fully 
recognize Coil and Square stitching. These will be converted to a series 
of Run stitch objects. This limits the scalability of these designs to 
±5-10%. However, old designs can be readily stitch-edited and sections 
re-digitized if required.

To read a chenille design
 Open a chenille design from DOS or embroidery disk as follows:

Use Standard > Open to open an existing design.

Use Legacy Features > Embroidery Disk to open designs from or save to 
proprietary embroidery disk formats.
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 To open a chenille machine file, choose a specific machine file 
format from the droplist or choose ‘All Machine Files’.

 If your chenille design is saved to proprietary disk, select 
Embroidery Disk from the Legacy Features toolbar and choose 
your format from the dialog.

 If you are opening a machine file, the Options button is activated. 
Chenille designs cannot be automatically distinguished from lockstitch 

Options available for
machine formats

Open embroidery disk
and choose a

proprietary format

Options available for
machine formats
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designs. You need to tell the system which machine format you are 
using.

Tip: In Tajima TMCE-600, all Chenille stops are interpreted as color 
changes.

 Select a chenille machine from the Machine Type list and click OK.

Related topics
 Machine format settings
 Read chenille designs
 Open machine files

Chenille machine file encoding

Select the correct machine format before outputting the design. Each 
machine requires its own machine file format. There is no 
chenille-specific machine file format as such. Typically:

Machine type File type Purpose

Tajima DST For pure chenille machines

TBF For combination chenille and regular embroidery 
(including sequin)

Barudan DSB For pure chenille machines

U?? For combination chenille and regular embroidery 
(including sequin)

(FDR-3) U?? Barudan FDR-3 machines
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Upon output, EmbroideryStudio translates chenille stitch types – Moss 
and Chain – into machine functions that can be understood by the 
selected machine. TBF and U?? are newer formats intended for 
combination chenille machines. Upon export, machine head assignments 
are automatically encoded in the machine file.

Machine file encoding
Most chenille machine files are encoded in DOS format. Some older style 
files are encoded in proprietary embroidery disk formats.

Check the following values before sending the design.

Stop code sequence
 Tajima DST file uses ‘Stop Code’ to switch between Chain and Moss. 

By default, it starts with Chain on Tajima Chenille machines.
 Later, Tajima introduced the multi-color TMCE-600 Chenille machine. 

Some Stop codes are used for switching between Chain and Moss, 
while others are for color changes.

 It is machine operator’s task to set Stop codes correctly. Some may be 
used for switching between Chain and Moss, some for color changes.

 Later, Tajima introduced multi-color Chenille combination machine, 
mixing chenille with normal machine heads. In this scenario, the Stop 
code sequence becomes more complicated. In addition to switching 
between Chain and Moss, they also trigger normal head color changes.

 Needle height is another setting which operators need to program into 
the machine.

Dahao DST For Dahao-controlled chenille machines

Melco EXP For pure chenille machines

ZSK Z?? For ZSK chenille machines

Disk type Melco format Barudan format Tajima format

DOS Melco EXP Barudan 2HD
Barudan S-FMC

Tajima T01
Tajima DST

Embroidery Melco Barudan Tajima

Machine type Format Check...

Melco Melco EXP

Barudan Barudan Jump stitch length is within 4mm.

Tajima TMCE-100 Tajima DST Shortcut angle is set to 60°

Tajima TMCE-600 Tajima DST Shortcut angle is set to 60°

Machine type File type Purpose
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Outputting chenille designs

Chenille files open in EmbroideryStudio like any other EMB design. 
Similarly, you save chenille designs to native EMB format or export them 
as machine files. They can be output to embroidery floppy disk, punched 
to a paper tape or sent directly to embroidery machine connected to the 
computer. The same file can be used by combination machines for both 
Chenille and Lockstitch embroidery.

Export chenille designs

While chenille design files are saved to native EMB format, this cannot be 
read by machine. You can export designs to local disk, embroidery disk, 
or even punch them to paper tape. 

To export a chenille design
 To export a chenille design as a machine file, select File > Export 

Machine File.

Use Legacy Features > Embroidery Disk to open designs from or save to 
proprietary embroidery disk formats.
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 To save a chenille design to a proprietary embroidery disk, choose 
Legacy Features > Embroidery Disk > Save As.

Tip: Once a design is complete, you can output to any supported 
embroidery machine without changing the original machine format. If 
a selected machine format does not support a particular function in the 
design – either automatically or manually inserted – it is simply 
ignored.

Related topics
 Chenille machine formats
 Exporting designs for machine

Send chenille designs to machine

Select proprietary 
disk format

Use Standard > Send to Connection Manager to connect to supported 
machines via proprietary machine software.

Use Legacy Features > Send to Stitch Manager to send a design to any 
supported embroidery machine without changing the original design 
format.
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Chenille designs can be sent directly to an embroidery machine if 
connected to the computer. Select the correct machine format before 
sending the design.

Newer machines use USB or Wired-Wireless network connections. 
EmbroideryStudio supports these connections via the Connection 
Manager. Older-style machines generally use serial port connections. 
EmbroideryStudio supports connection to these machines via the Stitch 
Manager.

Related topics
 Chenille machine formats
 Machine format settings
 Sending designs to machine

Output to Tajima chenille machines

Tajima chenille machines have three functions – Chain, Moss and Color 
Change. The Tajima code system does not have specific codes assigned 
to these machine functions; each Tajima chenille machine uses different 
combinations of empty stitch and stop codes to indicate these machine 
functions. Chenille provides machine formats for both Tajima chenille 
machines.
There are two types of Tajima chenille machine – TMCE-100 and 
TMCE-600. The newer Tajima TMCE-600 machine only uses single stop 
codes for switching between chain and moss stitching. The old ‘multistop’ 
TMCE-100 machine uses different combinations of multiple stop codes 
and empty stitch codes for the chain, moss and needle height functions. 
If you intend to stitch a design on one of these machines, make sure that 
you select the ‘Tajima Chenille multi-stop’ machine format. The chain, 

Select machine
format
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moss and needle height functions will be automatically converted to the 
correct combinations of empty stitch and stop codes.

The Tajima TMCE-S chenille machine only uses single stop codes for 
switching between chain and moss stitching. These machines cannot 
distinguish between the functions, so you need to select a function for 
each stop at the machine, in the same way as you select needle numbers 
for color stops. If you are using one of these machines, select the Tajima 
chenille TMCE-600 machine format. Each chain, moss and needle height 
function will be output as a single stop code.

Condition file
When using TMCE-600 format and saving a design as a DST file, a 
condition file (*.cc0) is saved alongside the design. This file contains 
information that the machine can read so that the setup process is 
partially automated.

From
Change 
color

Change 
needle height

To Function codes
Machine setup for 
needle height

Chain 3 7 Chain stop -

Chain 7 3 Chain stop set new height

Chain 3 3 Chain stop-empty-stop set new height 2

Chain 7 7 Moss stop-stop -

Chain 3 7 Moss stop-stop-stop-
stop

-

Chain 7 3 Moss stop-stop set new height

Chain 3 3 Moss stop-stop-stop-
stop

set new height 2

Moss 3 7 Moss stop-stop -

Moss 7 3 Moss stop-stop set new height

Moss 3 3 Moss stop-stop-stop-
stop

set new height 2

Moss 7 7 Chain stop-stop -

Moss 3 7 Chain stop-empty-stop -

Moss 7 3 Chain stop set new height

Moss 3 3 Chain stop-empty-stop set new height 2
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Index

A
angles, stitches 19

B
borders

add offsets before fill 43
chenille 15, 40

C
Chain

stitch type 38
tool 11, 33, 40

chain stitching 3, 5
chain-stitch fills 33
chenille

adding lettering 50
backing 7
borders 15, 40
Compound Chenille 14
embroidery 3
fabric 2
fill patterns 12
lettering 50
looper 5
stitch types 10
yarn 5

Chenille alphabets 50
chenille machines 4

combination 7
outputting designs 76
supported machines 77

chenille settings, compound 42
chenille stitching

types 5
visualize 19

Chenille toolbar
Chain 11, 33, 40
Compound Chenille 14, 29, 31, 

43
Moss 11, 29, 31, 42, 50
Needle Height 48
View by Chain-Moss 19

children’s apparel 3
Coil

Coil tool 35, 37
coil direction 17
Column A tool 13, 35
Column B tool 13, 35
Column C tool 13, 37
combination machines 7
Complex Fill tool 13–42

Compound Chenille
tool 14, 29, 31, 43

compound chenille
objects 28
settings 42

condition file (*.cc0) 78
control commands, checking 63
corners, sharp 19

D
design considerations, chenille 7
designs

adding lettering 50
combining with lockstitch 59
opening 71
opening multiple 71
scalability 18

dialogs
Save As 25, 75

Digitize Open Shape tool 40
Digitize Run tool 13, 40
Double Square

stitch 29

E
Embroidery Disk tool 71–75
existing designs, opening 71

F
felt backing 7
file, condition file (*.cc0) 78
Fill Offset Distance 47
fill patterns, chenille 12, 27
Fill Stitch Types toolbar

Coil 35, 37
Square 35

Fills
Square 35

fills
chain-stitch 33
Compound Chenille 14
Square 35

font samples, chenille 55

G
Graphics Digitizing toolbar

Digitize Open Shape 40

H
height

adjust needle height 48
needle 16

I
input methods, chenille 18
Island Coil

stitch 29

J
jumps 19

L
Legacy Features toolbar

Embroidery Disk 71–75
Send to Stitch Manager 76

length, stitch 17
lettering

adding to chenille designs 50
chenille 50
scaling 52

lockstitch
combine with chenille 59
convert to chenille 31

M
machine formats

checking 63
machine functions

checking control commands 63
Tajima Chenille 77

machines
outputting to Chenille 

machines 76
supported chenille machines 77

Maze Fill stitch 33
Moss stitch 28, 38
moss stitching 5
Moss tool 11, 29, 31, 42, 50

N
narrow shapes

constant width 37
varying width 35

needle height 16
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adjust 48
Needle Height tool 48

needles, chenille 5
New Design tool 21

O
object properties

changing stitch type 33, 40
objects

compound chenille 28
convert to chenille 31
scaling lettering objects 52

offset borders
add before fill 43

Offset Fill stitch 33
Open tool 71
Outline Stitch Types toolbar

Square 37
outlines

Square 37

P
patterns

Moss stitch 28
usage 27

S
samples of chenille alphabets 55
Save As dialog 25, 75
Save tool 24
scalability of designs 18
scaling lettering objects 52
Send to Stitch Manager tool 76
sharp corners 19
Simple Offsets

tool 40
Spiral Fill stitch 34
Square

stitch 29
tool 37

Standard toolbar
New Design 21
Open 71
Save 24
Send to Connection Manager 76

stitch angles 30
stitch length 17
Stitch Manager

Send to Stitch Manager tool 76
stitch types

Chain 11, 38
changing 33, 40
chenille 10
Double Square 29
Island Coil 29
Maze Fill 33
Moss 38
Offset Fill 33
select 33
selecting 33, 40

Spiral Fill 34
Square 29, 37

stitches
selecting a stitch type 40

stitching designs
Send to Connection Manager 

tool 76
Send to Stitch Manager tool 76

sweatshirt emblems 3

T
Tajima Chenille machine

functions 77
thread type and stitch length 17
Toolbox

Simple Offsets 40
Traditional Digitizing toolbar

Column A 13, 35
Column B 13, 35
Column C 13, 37
Complex Fill 13–??
Digitize Run 13, 40

trims 19

V
View by Chain-Moss tool 19
visualize chenille stitching 19
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