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Bead Embroidery

Bead embroidery is a type of applied decoration where beads, like 
sequins, are stitched rather than glued to fabric, suede, or leather. Unlike 
woven, knitted, and crocheted beading, embroidered beading does not 
form part of the fabric structure. Traditionally, it has been used on 
garments and decorative textiles. Accessories such as handbags or belt 
buckles may also be embellished with bead embroidery. As may 
household items such as pillowcases or cushions.

Embroidery machines can be equipped with a device that drops beads 
onto fabric as it stitches, similar in principle to sequin embroidery. 
EmbroideryStudio includes a Beading capability which supports beading 
devices. A library of beads of different size, shape and color, is available, 
together with fixing stitches supporting classic upright, flat and sideways 
beading.
This section describes how to set up bead palettes and how to visualize 
bead designs. It explains how to create single-bead as well as multi-bead 
runs. It also covers bead fixings as well as reshaping and editing. It also 
deals with individual bead drops.

Beading mode

Before using the Bead tools, you must select a machine format that 
supports bead output. You can then set up a dedicated palette for your 
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design from a list of shapes. Each can be adjusted in size, height and 
color.

Machine beading

Capabilities vary but bead devices are not as varied as sequin devices. 
There are two categories: bead tape and loose beads. For both types of 
setup, twin-bead configurations are currently the most popular.

Twin-bead tape device Twin-beading loose
bead device
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Bead tapes, like sequin reels, provide controlled placement of beads on 
fabric. With loose beads, containers hold them on top of the dispenser. 
This method is not quite as reliable as beads on tape. 

Various layout methods are available on the machine. EmbroideryStudio 
supports the classic fixing stitch types – ‘upright’, ‘flat’, and ‘sideways’ – 
as well as decorative variants.

Beading machine formats
Before using the Bead tools, you need to choose a suitable machine 
format. Only some machine formats support beading – e.g. Tajima TBF, 
Dahao and SWF Twin Sequin. Refer to your machine manual for 
information about support for this type of decoration.

Note  For machine formats that have no bead capability, the bead palette 
will display. However, if you attempt to create a bead object, fixing 
stitches will be digitized without bead drops.

Related topics
 Embroidery machine formats

Select bead-capable machines

Before you can use the Bead tools, you need to choose a suitable 
machine format.
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To select a bead-capable machine
1 Select Design > Select Machine Format.

2 From the Available Machine Formats list, select a bead-capable 
machine format – e.g. Tajima TBF, Dahao.

3 Click OK. Default bead shapes are now available for selection from the 
Bead Palette. If you have selected a twin-bead-capable machine, 
bead shapes and sizes are displayed in pairs. Up to eight (8) beads can 
be supported when the Dahao machine format is selected.

Note  Different machines require different presets. Typical modifiable 
values include stitch and jump length, trim functions and color change 

Select
bead-capable

machine format

Modify format 
as necessary

Twin-bead palette Single-bead palette
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functions. Use the Machine Format Settings dialog to customize 
values if outputting to a specific machine format. 

Related topics
 Embroidery machine formats
 Exporting designs for machine

Visualize bead designs

Beading can be viewed in TrueView or stitch view while Show 
Functions is toggled on.

Click View > TrueView to toggle between stitch view and TrueView™. 
Right-click for settings.

Use View > Show Stitches to toggle embroidery stitching display. 
Right-click for settings.

Use View > Show Functions to toggle display of machine function symbols. 
Right-click for settings.

Beading in TrueView Beading turned off
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Both beads and fixing stitches appear in their selected colors and can be 
turned on or off via Show Functions and Show Stitches toggles.

When traveling through a beading design, ‘undropped’ beads appear in 
the ‘unsewn’ color defined in the Background & Display Colors dialog.

Related topics
 Travel through designs
 Viewing design repeats
 Change display colors

Creating bead runs

EmbroideryStudio provides tools for creating a string of beads along a 
digitized line according to preset spacings or as marked by the digitizer. 

Digitize bead runs as you would do sequin runs. If you use the manual 
method, you define spacings between bead-drops with every click you 
make. If you use the automatic method, bead-drops are calculated 
according to current Bead Run object properties.

Beading in stitch view ‘Undropped’ beads when traveling



EmbroideryStudio e4 Beading Supplement 7

Set up bead palette

Use the Bead Palette Editor to prepare a palette of beads for use 
according to your machine capabilities. Bead devices are normally 
attached to the first or last needle of the machine head.

To set up a bead palette
1 Select the machine format that supports the machine you are using.
2 Click the Bead Palette Editor icon. Fields for each bead are arranged 

in tabular form.

3 Set the number of beads available per device. Depending on machine 
type, up to eight (8) beads may be supported. If you have chosen a 
twin-bead machine, this value is limited to 2.

4 Use the More button to add devices. Click X in the column header to 
remove.

5 Select a bead from the droplist.

Use Bead > Bead Palette Editor to select shapes from a bead library, and 
define bead colors and sizes.

Click to add 
more devices

Set number of 
beads per device

Select bead shape 
from the droplist
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6 Set color, bead and hole size, as well as height.

7 Set up other beads in the same way, and click OK. Beads are available 
for selection.

Related topics
 Select bead-capable machines

Digitize bead runs

Normally beads are stitched last, after motifs and other embroidery are 
complete. With the Bead Run tools you have the option of digitizing 
individual bead drops or letting the system generate them for you. 
Automatic bead runs can be scaled.

To digitize a bead run
1 Select a bead-capable machine from the Select Machine Format 

dialog. 

Click to
select color

More colors 
available

Beads available 
per device

Use Bead > Bead Run Auto to create a string of beads along a digitized 
line according to current settings.

Use Bead > Bead Run Manual to manually digitize bead-drops along a 
digitized line.

Use Bead > Bead Palette to select from a user-defined palette of 
bead shapes for the current design.



EmbroideryStudio e4 Beading Supplement 9

2 Define your palette and select bead shapes you want to use from the 
droplist, in this case a twin-bead setup.

To digitize automatic bead placements
 To digitize a scalable bead run, use the Bead Run Auto tool. Enter 

reference points – left-click for corner points, right-click for curve 
points.

 Press Enter to complete. Bead drops are automatically generated 
along with fixing stitches according to current Bead Run object 
properties.

Tip  You can convert a normal run to bead run by selecting and clicking 
the Bead Run Auto tool.

Beads available 
per device

Digitize outline – left-click
corner points, right-click

curve points

Bead drops and fixing
stitches generated

automatically
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 Double-click the object to access properties and swap beads as 
preferred.

 In the Spacing field, enter a nominal spacing. By default, this is 
measured ‘along baseline’, from one bead drop to the next. Minimum 
spacing is automatically calculated.

 Adjust Positioning method as preferred:

 Exact: Uses nominal spacing. This may result in gap formation at 
the end of the path.

Swap beads

Enter nominal 
spacing

Adjust positioning 
method

Exact



EmbroideryStudio e4 Beading Supplement 11

 Expand to fit: Expands spacing to evenly spread bead distribution.

 Contract to fit: Contracts spacing to evenly spread bead 
distribution, sometimes resulting in an extra bead.

 Manual: Turns bead run to ‘manual’ so that the number of beads 
won’t change when scaling.

 Change the Spacing measure as necessary in order to prevent bead 
bunching.

Expand to fit

Contract to fit

Along baseline

Between shapes

Choose spacing 
method
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 Use Angle to orientate beads in relation to the run line. Fixing stitches 
are adjusted accordingly.

 Set Angle to -90° to flip bead orientation.

 To change fixing stitches, click the ‘...’ button in the Fixing field. The 
docker expands to display a library of fixing stitch types. See below.

To digitize manual bead placements
 Alternatively, to control the exact placement of your bead drops, use 

the Bead Run Manual tool. Digitize individual bead drops with left 
and right mouse-clicks. 

Enter bead 
angle

Set bead angle to 
-90° to flip orientation

Digitize outline – left-click
corner points, right-click

curve points
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 Press Enter to complete. Bead drops are generated at each reference 
point. Connecting and fixing stitches are automatically generated.

Note  Manual placements can be reset by choosing a different 
Positioning method. If you change to exact spacing, all drops are 
recalculated and manual placements lost.

Create patterned bead runs

With EmbroideryStudio, you can create bead run patterns for immediate 
use. Patterns generally involve multi-bead drops.

To create a patterned bead run
 Create a bead-run object with Bead Run Auto or select an existing 

object. This allows you to preview your pattern as you go.

Bead drops and fixing
stitches automatically

generated

Use Bead > Bead Run Auto to create a string of beads along a digitized line 
according to current settings.

Use Docker > Object Properties to toggle the docker on/off. Set properties 
for the current design.
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 Select the bead combination you want to use.

 Open Object Properties. The Pattern table displays beads currently 
available.

 Add or remove beads via the + and X buttons in the column header.
 Select a bead from the droplist. The selected sample updates 

immediately.
 In the Spacing field, enter a nominal spacing for each bead. By 

default, spacing is measured along the digitized line.

 In the Fixing field, select the type of fixing you want. Generally you’ll 
use the same fixing for all beads in the pattern.

Related topics
 Select bead-capable machines
 Digitize bead runs

Select bead 
combination

Define parameters
for each bead in

the pattern

Add beads to pattern

Click to change 
fixing stitch

Click to change bead
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Bead fixings

EmbroideryStudio provides a library of predefined fixing stitches for use 
with bead runs. Generally digitizers reserve a single thread color for all 
beads, regardless of bead color. Transparent thread is often used in order 
to avoid differences between thread color and bead color. Various layout 
methods are available. EmbroideryStudio supports the classic types – 
‘upright’, ‘flat’, and ‘sideways’ – as well as variants. Fixing stitches are 
generally not part of the decoration.

Bead fixing considerations

Fixing type is independent of device type. The bead is always dropped in 
the same way. Fixing stitches control bead orientation. However, different 
machines and dispensers have their own production requirements and 
idiosyncrasies.

Upright

Flat

Sideways
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Bead production vs sequin production
Bead production is more exacting than sequin production. While sequin 
devices used to have similar issues, they have matured to the point 
where they can manage all kinds of fixing types at high speed. Moreover, 
sequin materials are more forgiving. Needle penetrations do not 
generally cause serious problems. The minimum commercial operating 
speed for bead production is 800 rpm or higher. Typical problems which 
can occur at high speed:
 Beads are missed
 Beads are smashed
 Needles are broken.

Testing for high speed production
You may need to modify or ‘tweak’ predefined fixing types provided by 
the software in order to run reliably at high speed. This will involve 
testing on the machine. While fixing stitches in EmbroideryStudio 
automatically adapt to bead size, each bead type will need to be tested 
separately. Generally speaking, bead production can be stabilized when 
running machines at low speed, say, 600 rpm. This is suitable for testing. 
A typical scenario:
 You develop a bead embroidery design.
 You carry out a sampling test at low speed.
 You test at production speed in order to calculate costs. 
 You find bead fixing does not meet high speed requirements – beads 

are missed or smashed.
 You adjust bead fixings to obtain a suitable result.

Options for editing bead fixings
Options available in EmbroideryStudio for bead designers are:
 Modify or ‘tweak’ fixing stitches by means of object properties. This 

may involve:
 Trying out different fixing stitch types
 Testing automatic as well as fixed spacings
 Modifying margin settings.

 Manually edit bead fixings with the Bead Edit tool.
 Manually digitize bead drops with the Manual Bead tool.
 Manually insert bead drops with the Insert Function capability.
 Create your own bead fixings and save them as custom motifs.

Apply bead fixings

Use Bead > Bead Palette to select from a user-defined palette of 
bead shapes for the current design.
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You can select beads before or after digitizing. Similarly, you can preset 
fixing stitches or change them at any stage.

To apply bead fixing stitches
 To change fixing stitches, double-click to access object properties.

Click to change 
fixing stitch
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 Click the ‘...’ button in the Fixing field. The docker expands to display 
a library of fixing stitch types.

 Select the preferred style – ‘upright’, ‘flat’, ‘sideways’.

 To adjust fixing stitch size, select a method:

Method Function

Match bead Automatically sets a margin around the bead so that fixing 
stitches don’t punch too close.

Set manually Activates the Size field and lets you set a fixing stitch size 
independent of bead size.

 Fixing stitch
preview

Select fixing
stitch type

Choose fixing 
size method

Adjust fixing stitch 
size if manual 
option selected
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 If you choose ‘set manually’, specify a value in the Size field. Size 
is measured from the center of the bead. Enter a value from 
2.50mm to 30.00mm. 

 If you choose automatic matching, specify a margin for the fixing 
stitch in the Margin field. Enter a value from 0.20mm to 2.00mm. 
This ensures that the fixing stitch does not punch too close to the 
bead. 

 To adjust fixing orientation, choose one of the preset directions – 
left/right, up/down. 

Related topics
 Create sequin fixings

Set fixed 
fixing size

Orientation: Left

Orientation: Right

Orientation: Vertical

Choose fixing 
orientation
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Editing bead runs

Bead-run objects can be edited like any other embroidery object. 
Parameters can be adjusted via object properties, or bead runs reshaped 
and edited, right down to individual bead orientations and fixings.

Convert objects to bead runs

Most objects in EmbroideryStudio are inter-convertible. Bead runs are no 
exception. Any outline object – Run, Stemstitch, Motif Run, Freehand, 
Column C, Vector – can be quickly converted to bead run.

To convert an object to a bead run
 Select the object – Run, Stemstitch, Motif Run, Freehand, Column C, 

or Vector.
 Right-click and select Convert > Convert to Bead Run.

Use Bead > Bead Run Auto to create a string of beads along a digitized line 
according to current settings.
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 Alternatively, click the Bead Run Auto icon.

 Double-click to access object properties.

Edit bead runs

You have complete control over editing bead-run objects, from scaling to 
adding or removing individual beads. You can also manually fine-tune 
bead spacing and orienation. You can even edit individual fixing stitches.

Tip  Performing manual edits automatically sets bead positioning to 
Manual. If you reset to Exact, Contract to fit, or Expand to fit, all 
manual edits are lost.

To edit a bead run
 Scale bead-run objects by clicking and dragging selection handles, or 

by adjusting general properties. 

Use Select > Select Object to resize objects using selection handles.

Use Reshape > Reshape Object to reshape selected bead-run objects.

Use Bead > Bead Edit to fine-tune placement of individual beads.
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 With Bead Run Auto objects, bead drops are automatically 
recalculated.

 With Bead Run Manual objects, the original number of bead drops 
is preserved while spacing is increased.

 Edit bead runs with Reshape:
 Add nodes by left- or right-clicking the outline.
 To remove a node, select and press Delete.
 Click-and-drag to move the start point. To reverse stitch direction, 

apply Edit > Reverse > Reverse Curves.

Bead drops regenerated
according to current settings

Original number of
bead drops preserved

Add or delete
nodes

Click-and-drag to 
move start point
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 Fine-tune individual bead spacings with the Bead Edit tool. 
Click-and-drag a diamond control point. Hold down Shift or Ctrl keys 
to select a range or multiple control points.

 Remove selected beads by pressing Delete or via the popup menu. 
Use the same menu to replace individual beads from the current 
palette.

 Add beads from the popup menu by holding down the Alt key and 
clicking the bead run.

Click-and-drag 
spacing handle

Right-click to access
popup menu

Hold <Alt> and click
to add beads
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 To rotate an individual bead, click the diamond control point. Use the 
rotation handle to orient the bead as necessary.

 Click the bead to activate fixing stitches. Use the handles to fine-tune 
as necessary.

Related topics
 Scaling objects
 Reshaping embroidery objects

Manual bead digitizing

If you require precise control over the positioning and encoding of your 
bead drops, EmbroideryStudio provides manual techniques for this 
purpose. Digitize your own bead drops with fixings. Even insert individual 

Click-and-drag
rotation handle

Click-and-drag
to reposition

fixing stitches
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bead-drop functions while traveling through the design. Or create your 
own bead fixings for use as custom motifs.

Digitize manual bead drops

The Manual Bead input method 
allows you individual control over 
bead placement and fixing stitches. 
Create decorative bead placements 
or ‘clusters’ using beads from the 
palette. To add a bead to the 
stitching sequence, simply drop it 
onto the design and secure it with 
manual stitches.

Note  Manual bead stitching is a difficult digitizing skill to master and you 
need to plan the stitching sequence carefully in order to minimize 
unnecessary stitches. Experiment with your machine and stitch length 
and spacing settings to achieve the desired result.

To digitize manual bead drops
1 Select a machine format that supports bead mode via the Select 

Machine Format dialog. See Select bead-capable machines for 
details.

2 Set up your palette in the Bead Palette Editor according to the 
machine type – single, twin, multi-bead – that you have selected.

Use Bead > Manual Bead to digitize individual beads.
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3 Select a color for the fixing stitch from the Color toolbar.
4 Click the Manual Bead icon. If you have activated twin-bead mode, 

bead options are displayed in the droplist.

Tip  Zoom in for more accurate digitizing. Hold down Ctrl+Shift to 
constrain the cursor to horizontal and vertical directions, or 15° 
increments.

5 Select a bead and left-click to begin your manual bead placement. It 
must start with at least one stitch. How you proceed depends on the 
layout style you are aiming for. The most common is ‘flat’:

6 The procedure for creating a ‘flat’ fixing stitch is as follows:
 Click-stitch forward as manual run stitching.
 Move forward one bead length and right-click to drop a bead. An 

outline appears.
 Click-stitch backwards. This stitch is going through the hole and will 

pull the bead back and down.
 Click-stitch forward across the bead to the drop point.

 Click-stitch forward as manual run stitching until you reach the next 
drop point.

Tip  If you make a mistake while digitizing, press Backspace to 
retrace your steps.

Beads available 
per device

Flat

Click-stitch backwards
and then forwards

Right-click to
drop bead

Click-stitch forward
as manual run
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7 Continue digitizing manually in the same way – right-click to drop a 
bead, left-click to digitize fixing stitches. Press Enter to finish.

8 If you have activated multi-bead mode, press the Tab key to switch 
between available bead shapes while digitizing.

9 Press Enter to finish.

Tip  Typically, you combine manual bead drops with Run stitch. Use 
Run to ‘map out’ the design and use Manual Bead to digitize 
individual bead drops or ‘bead clusters’.

To digitize sideways fixing stitches
The technique for creating a ‘sideways’ layout is similar in principle to 
‘flat’.

1 Click-stitch forward as manual run stitching.
2 Turn sideways at the point you want to drop the bead.
3 Move forward one bead length and right-click to drop the bead. A bead 

outline appears.

Continue digitizing –
right-click for bead drops,
left-click for fixing stitches

Press <Tab> to
switch beads

Sideways
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4 Click-stitch backwards. This stitch is going through the hole and will 
pull the bead back and down.

5 Click-stitch forward as manual run stitching until you reach the point 
of the next bead drop.

6 Press Enter to finish.

To digitize upright fixing stitches
Below is the ‘classic’ upright layout. In this procedure we add some stitch 
reinforcement to help position the bead.

1 Click-stitch forward as manual run stitching.
2 Optionally, click-stitch a bead surround in manual run stitching. This 

will help ‘seat’ the upright bead.
3 Right-click in the center of the surround to drop the bead. A bead 

outline appears.

Click-stitch one 
stitch back to 
secure

Right-click to 
drop bead

Press <Enter> to 
finish

Upright
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4 Click-stitch forwards to the edge of the bead surround. This stitch is 
going through the hole and will secure the bead in the upright position.

5 Click-stitch forward as manual run stitching until you reach the point 
of the next bead surround.

6 Press Enter to finish.

Related topics
 Select bead-capable machines
 Beading mode

Insert bead drops

In preference to the Manual Bead tool, some digitizers flesh out designs 
using Run or Motif Run and then travel through it, dropping beads 

Click-stitch to secure the
upright bead

Right-click to
drop bead

Click-stitch a bead surround
to ‘seat’ the bead drop

Press <Enter> to 
finish

Use Outline > Digitize Run to place a row of single or triple run stitches 
along a digitized line.

Use Outline Stitch Types > Motif Run to create a string of motifs along a 
digitized line.

Use Docker > Stitch List to toggle Stitch List display on and off. Use it to 
select individual stitches.

Use Travel > Travel 1 Stitch to move stitch cursor forwards/backwards 1 
stitch at a time. Left/right click.

Click Function > Insert Function to insert machine function at current stitch 
cursor position. 

Use Bead > Clear Function to remove any bead functions from the current 
needle position.
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manually as and where required. This technique can be used with single 
or multi-beads.

To insert bead drops
1 Select a machine format that supports bead mode via the Select 

Machine Format dialog.
2 Set up your bead palette – single or more – according to machine 

capabilities.
3 Set a fixed run length to suit the bead type/s you are using.

Set run length to 
suit beads
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4 Create the design or pattern you want and choose the bead or beads 
to use.

5 Optionally, open the Stitch List.
6 Press the Home button and travel through the design using arrow 

keys or Travel tools.
7 Travel to the insertion point and select Insert Function from the 

toolbar or Stitch List popup menu.

8 From the Functions list, select Drop Bead. Depending on machine 
requirements, you will either add the function to the current stitch, or 

Twin-bead 
palette available

Travel to 
insertion point
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insert it on an empty stitch or empty jump. See your machine manual 
for details.

9 When the Drop Bead function is correctly defined, click OK. The 
Select Bead dialog opens showing available beads.

10 Choose a preferred bead. The Bead Drop function, together with any 
additional empty stitches or jumps, is added at the current needle 
position.

Select Drop
Bead function

Insert additional 
empties as 
necessary

Choose preferred 
bead

Bead dropped at 
insertion point
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11 Continue traveling and inserting beads by the same method.

12 To delete a bead drop, travel to the location and click the Clear Bead 
icon.

Related topics
 Digitizing outlines & details
 Motif runs
 Select bead-capable machines
 Travel through designs
 Inserting machine functions manually

Custom bead motifs

Another technique for deploying custom bead fixings is to save them as 
motifs and use them singly or in motif runs. The Create Motif function 

Bead dropped at 
insertion point

Use Traditional Digitizing > Use Motif to add motifs to design one-by-one. 
Rotate, scale, or mirror as you add.

Use Outline Stitch Types > Motif Run to create a string of motifs along a 
digitized line.
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lets you save your own motifs for future use. Custom motifs are saved in 
custom ‘motif sets’. 

To create and save a motif
1 Create your custom bead and fixing stitch or edit an existing one.

2 Duplicate and align the motif as you want it to appear in a motif run. 
Use Alignment tools for precise arrangement.

3 Once you have determined the layout, select objects and apply 
Closest Join. Use the middle motif to determine reference points.

4 Select the motif and choose Object > Create Motif.

5 Select a custom motif set from the droplist and enter a name in the 
Motif Name field.

6 Deselect the Remove other functions option. This ensures that 
beads are preserved.

7 Click OK.

Determine 
nominal layout

Select motif set

Enter motif name

Deselect ‘Remove
other functions’

Bead 1
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8 Click two reference points for the bead motif. These should coincide 
with entry and exit points.

9 Use you custom bead and fixing in bead runs or individual placements.

Related topics
 Custom motifs
 Selecting & placing motifs
 Motif runs

Bead encoding & decoding

In EmbroideryStudio, dedicated ‘Bead’ functions are used for bead 
designs. Analogous functions exist for sequins.

When exporting to Tajima DST file format, both ‘Drop Bead’ and ‘Drop 
Sequin’ functions are replaced by Jump codes. When exporting to DST 
format with Dahao as your selected machine format, the machine file 

Mark reference 
points

Create individual 
bead placements as 
preferred

Dedicated sequin and
bead functions in

EmbroideryStudio
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employs a modified protocol for non-standard use of Jump codes. This is 
a modified Dahao-specific DST format.

Encode beads as sequins
You do not need to be concerned with machine file encoding unless your 
design contains both sequins and beads. Since both object types are 
encoded the same way in the machine file, you need to explicitly map 
beads and sequins to respective ‘slots’ on the machine. You do this on 
output via the Save Options dialog. Droplists on the Save Options > 
Beading tab are available whenever you export as Tajima DST with 
Dahao as your current machine format.

Let’s say your design contains two (2) sequins and two (2) beads. And 
let’s say your machine is configured with sequins in Slots A and B, and 
beads in Slots C and D. On the Beading tab, Bead A must map to Sequin 
C and Bead B to Sequin D. Then the Dahao controller will be able to 
correctly distinguish sequins from beads on stitchout.
Note that this mapping is not indicated on the production worksheet since 
it only affects the machine file, not the source design file. This means the 
designer must communicate the correct mapping to the machine 
operator (or vice versa) according to how sequins and beads are 
configured. It is important to make sure that mappings do not intersect. 
For instance, you do not want both Bead A and Sequin A to be allocated 
to Slot A.

Note  DST files can only encode up to four (4) sequins and/or beads. This 
means that if you have, say, 3 sequins and 5 beads in the same design, 
mapping will not work. You will run out of slots.

Compensate for bead-switch delay
Some machine configurations have a specific deficiency when it comes to 
beading. Namely, they are one step late when switching beads. When 
controllers encounter a command to drop Bead X, the machine will drop 
whatever bead is in the picker and only then make the switch.

Encode beads as
sequin functions
on the machine
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To correct the error, you must compensate by employing a ‘preemptive 
bead swap’. This will shift bead changes by one step. By ticking 
Compensate for bead swap delay, the first line becomes re-encoded 
as shown...

Note  Installation engineers will be able to advise if it is necessary to 
compensate for ‘bead shift’.

Decode sequins as beads
The Open Options dialog provides an inverse set of controls to decode 
machine files which have been encoded by means of the Save Options 
> Beading mechanism. The Open Options > Conversion Details tab 
allows you to decode sequin functions as beading when opening these 
formats using Dahao target machine.

Note  When you open a Tajima DST file, the software only shows the 
Standard tab. When you choose ‘Dahao’ from the machine type droplist, 
the Conversion Details tab becomes available.

Related topics
 Select bead-capable machines
 Opening machine files
 Exporting designs for machine

Decode sequins
as bead functions

in the software

Restore sequence from bead 
swap where necessary
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