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BE EmbroideryStudio Setup

Welcome to BE EmbroideryStudio 2025, the leading design software 
application for the decorated goods industry. Combining both the 
embroidery capabilities of Wilcom software with the graphical capabilities 
of the CorelDRAW® Graphics Suite, no other product provides the 
flexibility of BE EmbroideryStudio in creating designs for both embroidery 
and multi-decoration. While supporting multi-decoration, the product is 
tailored to the requirements of the embroidery specialist who requires a 
powerful toolset to create and edit high-quality, production-ready 
embroidery. BE EmbroideryStudio is the ultimate embroidery software 
for professional digitizers, embroidery shops, industry educators, apparel 
decorators and hobbyists.

Note: Screen illustrations in this publication are intended as 
representations only. Depending on your software model or product level, 
screen layouts generated by the software may differ slightly. Similarly, 
samples used to illustrate software features and capabilities may not be 
exactly duplicable in your product level.

Product levels & Elements

The BE EmbroideryStudio 2025 suite consists of several product levels. 
These are powerful, well featured, professional embroidery applications 
for different needs.

Product level Applications
2 ES Decorating ^ The power of auto-digitizing and CorelDRAW, backed by 

easy-to-use digitizing tools. ES Decorating provides 
professional lettering, customization and editing tools for 
smaller embroidery houses. Ideal for those who outsource 
digitizing work but need to be able to create logos, 
customize designs, or auto-digitize customer artwork. 
Supports some Elements.

3 ES Editing Be in control of quality and production by bringing design 
editing in-house. ES Editing provides professional lettering, 
customization and editing capabilities for retail and 
production shops. Supports machine connections.

^ Includes CorelDRAW® Graphics Suite as standard
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Add-on Elements
Add-on Elements allow users to access additional tools, effects, or 
automation features beyond the core functions of the licensed 
BE EmbroideryStudio product level. Some are available at extra-cost. 
Some are provided as standard in higher product levels. Benefits 
include...

System requirements

Before you install, or if you experience operating problems, make sure 
that your computer meets the system requirements.

PC specifications

Check CPU/RAM as well as hard disk space. The table below provides 
minimum system requirements.

4 ES Lettering ES Lettering delivers world-class lettering quality. Create 
lettering, name drops, or monograms quickly, without a 
digitizer. Supports full lettering, customization, with machine 
connections.

Subscription 
access

For subscription-based licenses, all Elements for that 
BE EmbroideryStudio level are automatically included.

Enhanced 
functionality

Elements may include advanced lettering, monogramming, 
auto-digitizing, special stitch types, or other 
embroidery-related tools.

Customization Users can enable specific Elements to tailor 
BE EmbroideryStudio to their workflow needs.

Perpetual license 
add-ons

Owners may purchase and assign specific Elements 
separately.

Product level Applications

^ Includes CorelDRAW® Graphics Suite as standard

Component Minimum Recommended

CPU Intel® Core i5 (8th Gen) or AMD Ryzen 5 
4000 Series

Latest Gen Intel® i7 / i9 processor or 
AMD Ryzen 8000 / 9000 series

Operating 
system

Microsoft Windows 10 64-bit Edition Microsoft Windows 11 64-bit Edition with 
the latest updates

Browser Microsoft Edge, Chrome, or similar
Memory 16 GB 32 GB or more
Hard disk size 128 GB 512 GB or more (Solid State Drive)

https://wilcom.com/embroiderystudio/elements
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Check OS and device specifications

Check your CPU (processor) and RAM specifications, and the version of 
Windows you are running, to ensure they meet 
BE EmbroideryStudio 2025 requirements. We recommend updating to 
Windows® 11 (64-bit edition) with latest updates installed. You will, 
however, need to uninstall any earlier versions of CorelDRAW® 
Graphics Suite. For latest operating system information, visit the Wilcom 
Support Center at help.wilcom.com.

To check your OS and device specifications...
1 Go to MS Windows® Settings and open the About tab.

Free disk space 40 GB 60 GB or more
Graphics card Support for Highest Color (32bit) and 

resolution (1600 x 900)
• Support for Highest Color (32bit) and 

resolution (1920 x 1080 or higher) 
• 4 GB or more of graphics memory 

(non-integrated)
Monitor 1600 x 900 screen resolution Dual monitors capable of displaying 

1920 x 1080 screen resolution
Mouse USB mouse or Bluetooth
USB port Required for HL (hardware license) version. Not required for DL (digital license) 

version.
Sound card Required for online video help.
Internet 
connection

Required for:
• Product activation and registration
• Machine file export
• Periodic software updates
• Access to news, community, product blog, tutorials, and product documentation
• During installation, to download Windows features.

Component Minimum Recommended

http://help.wilcom.com
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2 Check the Windows version, the CPU and the amount of RAM.

Check hard disk space

BE EmbroideryStudio occupies up to 5 GB of hard disk space, depending 
on options installed. CorelDRAW® Graphics Suite also takes up an 
additional 3 GB. However, you need additional free space for your 
applications to run smoothly. Check that your hard disk has enough space 
to run BE EmbroideryStudio effectively. After installation you will need 40 
GB free or 10% of your total hard drive space, whichever is the greater 
amount.

To check your hard disk space...
1 Go to This PC in File Explorer and right-click the Local Disk (C:) to 

open the popup menu.
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2 Select Properties to open the Properties dialog.

3 Go to the General tab. This tab shows the hard-disk capacity as well 
as any free space.
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Check display settings

Some controls may be hidden on the user interface if you run your 
monitor at low resolutions. The physical size of your monitor will have a 
bearing on the optimum screen resolution. Larger fonts will exacerbate 
the problem.

To check your display settings...
1 Go to MS Windows® Settings and open the Display tab.

2 If you experience visibility issues, try adjusting both screen resolution 
and font size. For example, a resolution of 1920 x 1080 with a font size 
of 100% or 125% should be acceptable.

Power plan

For best performance make sure your PC is set to high performance 
power plan.
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Software licensing

With BE EmbroideryStudio 2025, all users have a Wilcom User 
Account. The software still needs to be installed on a computer but the 
license is mobile which makes usage more flexible. Whenever you log in, 
BE EmbroideryStudio will load the appropriate software level and 
registered add-on Elements.

Your Wilcom User Account is also required to provide access to:
 Personalized Wilcom support geared to your product level and 

registered add-on Elements.
 Live and recorded online training (as it becomes available)
 Information about product updates, events and special offers.

Licensing models for Wilcom products

Wilcom offers multiple licensing models to accommodate different user 
needs. These models define how users access and manage their Wilcom 
‘apps’ or applications, such as Truesizer, Estimator and 
BE EmbroideryStudio.

Perpetual licensing
This is a one-time purchase model available for BE EmbroideryStudio. 
With this model:
 Users own and can use the software indefinitely.
 Licenses are linked to a specific user or device and can be transferred 

if needed.
 Includes automatic minor updates and support, for the life of the 

current version. 

Sign in or create a 
new account

https://wilcom.com/embroiderystudio/elements
https://wilcom.com/embroiderystudio/elements
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 Users must purchase major version updates. Generally, those which 
contain new features.

Network licensing (Enterprise)
Network licensing allows multiple users to access a shared license within 
an organization. With this model:
 Typically used by large production facilities needing centralized license 

management.
 Requires a license server and network dongle to distribute access.
 Each licensing model offers different benefits depending on the user’s 

needs, budget, and software usage patterns.

Managing your Wilcom Account

Wilcom User Account is a cloud-based service designed to enable 
registered Wilcom Account holders to manage multiple licenses and users 
of various Wilcom ‘apps’ (applications) under a single account. From the 
top of the Wilcom website you can access your account via the dropdown 
menu...

Supported apps
Wilcom ‘apps’ currently supported by the service include...

Click to access
profile

Truesizer A Wilcom app that allows users to view, resize, and 
convert embroidery design files without altering stitch 
quality. It is often used for previewing and basic 
modifications.

Estimator A Wilcom app that calculates the estimated stitch count 
and cost of an embroidery design before actual production.

BE EmbroideryStudio Wilcom’s flagship embroidery digitizing software, designed 
for professional embroidery design creation, editing, and 
production management. (Versions previous to 
EmbroideryStudio Digital Edition are not supported at this 
time.)
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Active BE EmbroideryStudio sessions
Each licensed copy of BE EmbroideryStudio is for a single user. You may 
install it on multiple computers but only one active session can be used 
at one time. In the Sign-in dialog, tick ‘Keep me signed in’. This means 
you will not have to enter your Wilcom User Account details each time 
you start the software.

Caution: Simply uninstalling the software does not release the license. 
Select File > Sign Out and Exit before uninstalling.

Key features
Wilcom Account Management allows for greater flexibility, enabling 
organizations to purchase and manage multiple licenses, add members, 
and assign or unassign licenses as necessary. Key functionalities include…

Installation & registration

There are various scenarios you may encounter when installing or 
upgrading BE EmbroideryStudio software.
In every case, you will need to sign in or register a Wilcom User 
Account. Registration simply requires a username, an email address, 
and a password of your choosing. Registration is linked to your email 
account.

Multiple user 
management

Add and manage multiple users within a single 
organization account.

License management Purchase, assign, and manage multiple licenses of 
various Wilcom applications.

Billing management View and manage subscriptions and payments for 
licenses.

User security Implement two-step verification within the organization for 
added security.

Reporting Analyze usage for Truesizer and Estimator and monitor 
login activity for all apps, across all users and licenses.

Stay signed in
while offline
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Custom assets

BE EmbroideryStudio allows you to create files or ‘assets’ of various kinds 
during normal use. The most important of these are of course actual 
embroidery designs. There are other assets you may create such as 
design templates, custom motifs and borders. These assets are 
preserved from installation to installation, whether installing a new 
version of BE EmbroideryStudio or an update patch. If you want to move 
your BE EmbroideryStudio to another PC, you will need to manually 
transfer any custom assets you have created or received from third 
parties. See Asset Management for details.

Caution: When installing new or updated assets, such as design 
templates, custom motifs and borders, or keyboard design collections, 
the installation procedure will not overwrite existing assets of the same 
name. If you do want to install new assets, remove or back up the old 
ones before updating your current installation.

Product installation

BE EmbroideryStudio is supplied as a downloadable product only. If you 
are installing on an operating system (OS) that is in a supported 
language, the installation process will run in that language.

To install the product...
1 Ensure your computer meets the system requirements.
2 Close all open applications.

Note: When you install the software, you will be prompted to reboot 
your PC to complete the installation. Make sure you save any files and 
close all applications beforehand.

3 Run the installation by double-clicking the installation file. 
4 Follow the onscreen instructions. You will be prompted to choose:
 where the software will be installed on your PC (default location 

recommended)
 which components to install – i.e. additional languages. English is 

the default.
 which installed version you wish to merge user-defined settings 

with.
Upon successful installation of the software and any additional 
Windows files, the Installation Complete screen appears.

5 Click Finish. The computer will reboot and the software can be used.
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Note: If you encounter problems with the installation, please contact 
Wilcom Support.

Register an account & sign in

Product registration is required to validate the software. Also, by 
registering you will have access to:
 Wilcom support
 Live and recorded online training (as it becomes available)
 Information about product updates, events and special offers.
Sign in and registration is essentially the same process. In both cases you 
will be presented with a Sign In screen. You register a Wilcom User 
Account whether or not you purchase. If you decide not to purchase, 
your registration remains and will be reactivated if you chose to purchase 
at a later date.

To register an account...
1 Go to the Wilcom website. From any page, you will have the option to 

sign in.

2 Click the Sign In button at the top of the screen. Alternatively, when 
you first run the software, you will encounter the same sign-in 
screen...

Sign in or create a 
new account

https://help.wilcom.com/
https://workspace.wilcom.com
https://wilcom.com/
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Note: If you are already registered, simply enter your email and 
password. Your BE EmbroideryStudio account is registered to your 
email address.

3 Click the Create New Account button to access the registration form.

4 Enter a few personal details together with your email address.
5 Enter a password you can easily memorize. Keep a written copy in 

case you forget.
6 Click Next to access the second page.

Registration linked 
to email account

Enter personal 
details
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7 Enter your country of residence and a mobile phone number. Your are 
advised to read the Terms & Conditions and Privacy Policy. ‘Tips 
and offers’ are optional.

8 Click Create Account. You will receive confirmation via email.

9 Once received, click Verify Email to confirm receipt of the email.

To sign in for the first time...
1 Return to the Sign In screen, enter your email and password, and 

click Sign In.

Click to create 
account

Enter mobile 
phone number
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The first time you sign in, you will be prompted to verify your mobile 
phone number.

2 Click the Send Code button. Check you mobile phone. The following 
screen will appear.

3 Click Verify. 

Enter sign-in 
details

Click to sign 
in

Click to receive 
one-time verifcation 
code

Enter the one-time 
verifcation code
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Run the software

Once you have rebooted your PC following installation, you can run the 
software.

To run the software...
1 Double-click the icon on the desktop to start the software for the first 

time. If you are not already signed in via the website, you will 
encounter the same sign-in screen...

2 When prompted, enter your BE EmbroideryStudio email and password 
in the fields provided.

3 Click OK and the software will connect to our activation server and the 
software will open.

Run BE EmbroideryStudio in other languages

If you want to install and run a specific language on an English OS, you 
will need to select it from the available languages during installation. The 
software will then need to be ‘switched’ to the additional installed 
language from the BE EmbroideryStudio program group before it can be 
run in that language.

Enter sign-in 
details

Click to 
sign in
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Uninstall the software

If for any reason you need to uninstall BE EmbroideryStudio, make sure 
you do so via the MS Windows® Apps > Installed apps dialog. Select 
a Wilcom application from the list – BE EmbroideryStudio (main 
application), Wilcom PDF Printer, and/or Wilcom Shell Extension.

Caution: Simply uninstalling the software does not release the license. 
Select File > Sign Out and Exit before uninstalling. Also...

Switch to other 
languages

Choose Wilcom 
application to uninstall
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 If you remove Wilcom PDF Printer without uninstalling the main app, 
you will be unable to print a PDF from BE EmbroideryStudio.

 Similarly, if you remove Wilcom Shell Extension for any reason, no 
thumbnails/design info will be displayed in File Explorer or 
Design Library.

Integration with CorelDRAW®

The CorelDRAW® Graphics Suite is a 
professional vector graphics design application 
used for creating illustrations, logos, and 
complex designs. It is widely used in various 
industries, including embroidery, because of its 
precise design capabilities. CorelDRAW® is 
integrated with BE EmbroideryStudio, allowing 
users to seamlessly convert vector graphics 
into embroidery designs.

CorelDRAW as part of 
BE EmbroideryStudio
 Certain BE EmbroideryStudio product levels – ES Designing and 

ES Decorating – include a CorelDRAW® license as part of the package.
 Integration is currently only available with certain levels of 

CorelDRAW®. For more information, see FAQs on the 
BE EmbroideryStudio website.

 BE EmbroideryStudio only supports the MS Windows® version of 
CorelDRAW®.

 CorelDRAW® may be installed together with Windows .NET 
Framework. To ensure that CorelDRAW® uses the correct version of 
.NET, make sure you install it when prompted to do so. It can take up 
to 20 minutes or more to install on some computers.

How CorelDRAW enhances BE EmbroideryStudio
 You will be prompted to link upon launching BE EmbroideryStudio.

https://wilcom.zohodesk.com/portal/en/kb/articles/which-version-of-coreldraw-integrates-with-embroidery-studio-digital-edition
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 The integration allows for a seamless workflow, making it easy to 
adjust designs before digitizing them into embroidery stitches.

 Users can import, edit, and convert vector graphics from CorelDRAW® 
into embroidery files.

 The built-in CorelDRAW Graphics window includes CorelDRAW® 
drawing tools which offer many techniques for drafting outlines and 
shapes on screen. Vector objects can be converted to embroidery 
designs. For a full description of the tools, refer to the online help 
available from the Graphics mode Help menu.

 Some CorelDRAW® functions may not be available in CorelDRAW 
Graphics. 

Licensing & activation
 If an BE EmbroideryStudio product level includes CorelDRAW®, the 

License Details page in the Wilcom Account Management 
System displays:
 The CorelDRAW Key (a unique activation code).
 A download link to install CorelDRAW®.

 Users need to activate CorelDRAW® separately using the provided 
key.

 CorelDRAW® follows its own licensing terms but remains linked to the 
BE EmbroideryStudio license.

 If the BE EmbroideryStudio license is a subscription, access to 
CorelDRAW® is tied to the subscription period.

 If the BE EmbroideryStudio license is perpetual, CorelDRAW® remains 
available as long as the license is valid.

CorelDRAW® registration
 CorelDRAW® needs to be registered separately before it can be used 

by BE EmbroideryStudio. 
 Registration also provides access to the latest CorelDRAW® updates.
 CorelDRAW® and its sister product, Corel PHOTO-PAINT® can also be 

run as standalone applications. CorelDRAW® features ‘best-of-breed’ 
bitmap-to-vector tracing, enhanced illustration capabilities, 
photo-editing together with a library of professional clipart images.

CorelDRAW® content
CorelDRAW® Standard Membership provides access to content – clipart, 
fonts, stock photos, templates, and much more.
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Device connections

You will need to connect peripheral devices for use with 
BE EmbroideryStudio. These may include digitizing tablets, printers, 
appliqué cutters, scanners and embroidery machines. Different devices 
are set up in different ways – some in MS Windows®, via the Control 
Panel, others within BE EmbroideryStudio itself.

Tip: The number of available ports limits the number of devices you can 
connect. If additional ports are required, you can add them. Multi-port 
serial cards can also be used. See a PC technician about your 
requirements.

Machine connection

BE EmbroideryStudio supports many sets of machine model. Most 
machines can read USB memory sticks. These are convenient portable 
memory devices which can hold large amounts of data.
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Tip: Some customers want to connect their embroidery software directly 
to machine. If your embroidery machine can be seen as an external drive 
in File Explorer, you may be able to send designs directly.

Related topics...
 Hardware Setup (Reference Manual)
 Sending designs to machine (Reference Manual)
 Exporting designs for machine (Reference Manual)
 Machine Formats (Reference Manual)
 Wireless Machine Connection with EmbroideryConnect (Reference 

Manual)

EmbroideryConnect networking

Wilcom’s EmbroideryConnect capability allows you to wirelessly 
transfer embroidery designs from BE EmbroideryStudio to USB-enabled 
embroidery machines. Machine files are automatically generated and 
sent via a standard WiFi network to an EmbroideryConnect device 
plugged into a compatible machine. Design transfers are securely 
encrypted. The concept behind the EmbroideryConnect network is 
described by the following diagram…
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Quickly and easily send, scan, and queue your embroidery designs for 
production. EmbroideryHub software is included with the 
EmbroideryConnect Element. 
Wirelessly manage and transfer 
embroidery designs from 
EmbroideryHub to any 
EmbroideryConnect WiFi device 
connected to your embroidery 
machines. Features include:
 Simple integration with your 

existing WiFi network.
 Color-coded LED light 

notifications.
 Barcode reader for fast design 

loading.

Related topics...
 Wireless Machine Connection with EmbroideryConnect (Reference 

Manual)

Embroidery machine 1

Embroidery machine 2

Embroidery machine ‘n’

Operator ‘pulls’
barcoded design to

embroidery machine
from design queue

EmbroideryHub converts 
design to machine file for 

target machine

ES User 1

WiFi Router

Ethernet LAN

ES User ‘n’

Designer sends design to named 
embroidery machine OR to 
EmbroideryHub design queue
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Scanner setup

BE EmbroideryStudio supports WIA-compatible scanners. Some 
scanners will not work with BE EmbroideryStudio because they require 
their own scanner software. If this is the case with your scanner, use your 
scanner software for scanning, save the image to your hard drive, then 
load the image into BE EmbroideryStudio.

Related topics...
 Setting up scanners (Reference Manual)

Connecting digitizing tablets

You can use a digitizing tablet and puck with BE EmbroideryStudio as an 
alternative to digitizing directly on-screen. To use a tablet, you place an 
enlargement drawing on the active area, and use the puck to mark 
reference points.

Related topics...
 Connecting digitizing tablets (Reference Manual)

Digitizing tablet with 
pressure sensitivity and 
pen tilt sensitivity
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Configuring embroidery libraries

Design Library is a design management tool. Use it to browse design 
and artwork files stored on your PC or local network. Design Library 
capabilities make it fast and practical for daily commercial use, avoiding 
the need to switch to and from File Explorer. It recognizes all file 
formats used by BE EmbroideryStudio. It also makes it easy to search, 
sort and browse all embroidery designs on your network. 
If you are already familiar with File Explorer, the Design Library 
interface will be quite intuitive to you. You may, however, need to make 
a few adjustments to folder options for recommended embroidery design 
settings. The steps below are based on Windows 10 settings.

Activate embroidery libraries in File Explorer

Embroidery libraries may not automatically appear in Windows 10. If you 
do not see your them in File Explorer, follow the steps below.

To activate embroidery libraries in File Explorer...
1 Go to File Explorer and select This PC.
2 Right-click the empty navigation pane to invoke the popup menu as 

shown.

3 Alternatively, click the Navigation pane button to open the dropdown 
menu.

Select ‘This PC’

Choose ‘Show 
Libraries’
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4 Select Show libraries. Embroidery libraries are added to File 
Explorer.

Note: If you want to display embroidery libraries in the Save As 
dialog, you need to activate them in the same way.

Related topics...
 Design library layout
 Viewing designs in network folders

Configure design thumbnails

In some Windows 10/11 installations, embroidery design thumbnails may 
not automatically appear. If so, follow the steps below.

To configure design thumbnails...
 Start the File Explorer program from the Windows taskbar.

Activate ‘Show 
libraries’

Select 
‘This PC’

Embroidery 
libraries now visible
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 Select the Embroidery folder.

Note: Embroidery libraries do not automatically appear in some 
installations of Windows 10/11.

 Go to File Explorer > View > Options and select Change folder 
and search options.

 The Folder Options dialog opens.

Open File
Explorer

Select Embroidery
folder

Select ‘Change folder and
search options’
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 Go to the View tab. Several Windows default settings are not ideal for 
embroidery. Recommended settings include:

 Click Apply to Folders to apply settings to the Embroidery folders. 
If your File Explorer settings are properly configured, thumbnail 
images will appear as expected in the Design Library:

Setting Reason

Always show icons, 
never thumbnails

So thumbnail images of embroidery designs will 
show, not the program icon.

Display file icon on 
thumbnails

So program icons do not display in the corner of 
design thumbnails.

Hide extensions for 
known file types

So you can see the different types of embroidery 
design files – EMB, DST, JEF, etc.

Show preview handlers 
in preview pane

So you can see a preview of the embroidery 
design in the preview pane.

Apply settings to
all folders
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Tip: In addition to the Design Library, these settings affect how 
thumbnails display in File Explorer and other Windows applications.

Related topics...
 Viewing designs in network folders
 Opening designs from Design Library

Fast searching on shared network drives

For networks with multiple computers reading and writing EMB or 
machine format designs, you may want to set up a dedicated PC as a 
repository for all design files. Connect any folders on the repository to 
each ‘client’ PC via Design Library. Design Library relies on Windows 
indexing to ensure fast searching. 

To set up searching on shared network drives...
 For the Windows file server, make sure you have the Windows Search 

service running. You should have the latest Windows Server installed 
to enable fast-search indexing. You will also need some version of 
BE EmbroideryStudio installed.

 Add the design folder to be shared with the indexing function. Go to 
Control Panel > Indexing Options > Modify and select the correct 
path.
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 Install BE EmbroideryStudio so that the Shell Extension is registered. 
This allows the server to index additional embroidery file properties.

 Once the server has finished indexing the folder, then, for every PC 
using the file server, add the design folder to Design Library. See 
above.

Related topics...
 Viewing designs in network folders

Add design folder 
as indexed location
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OBJECT-BASED EMBROIDERY

Embroidery design in 
BE EmbroideryStudio consists of turning 
basic artwork shapes into embroidery 
objects. BE EmbroideryStudio allows 
you to create embroidery objects with 
artwork as backdrops or by directly 
converting digital artwork. You can take 
a mixed mode approach as well, doing 
the bulk of the design by means of 
automatic conversion, followed by 
touch-ups and edits using the suite of 
BE EmbroideryStudio digitizing tools.
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Introduction to BE EmbroideryStudio

Embroidery design with BE EmbroideryStudio consists of turning basic 
artwork shapes into embroidery designs. BE EmbroideryStudio gives you 
the flexibility of creating embroidery objects using artwork as backdrops, 
or of directly converting digital artwork. You can take a mixed-mode 
approach as well, doing the bulk of the design by means of automatic 
conversion, followed by touch-ups and edits using the suite of 
BE EmbroideryStudio embroidery digitizing tools.

Artwork & designs

High quality embroidery starts with good design and forward planning.

Artwork

Electronic artwork in both bitmap and vector formats can be inserted, 
pasted or scanned into BE EmbroideryStudio for use as digitizing 
templates or ‘backdrops’. Likely sources include:
 Internet and CD clipart libraries
 Business cards, post cards and wrapping paper
 Samples in the Design Library
 Books of embroidery patterns
 Children’s story books
 Printed table cloths or tea towels
 Original artwork – e.g. children’s drawings.
Unless you are an experienced digitizer, do not use complicated artwork. 
Also, be sure to check the copyright of any images you have not created 
yourself. If unsure, contact the relevant supplier to seek their permission.

Good design

Keep the following points in mind when digitizing your design and 
assessing the final output:
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The stitched-out design should also have the following characteristics:
 Design looks good – shapes, colors, balance
 Shapes are filled with appropriate fill and outline stitches
 Details are clearly defined
 Stitches are neat, smooth and even
 Stitches angles follow design shapes
 Lettering is clear and easy to read
 The design stitches out efficiently on the machine
 Shapes are stitched correctly – no unwanted gaps
 The fabric has not puckered around the stitched areas
 The design is free of loose ends.

Tip: Good design is enhanced by the use of correct backing, tension and 
a good quality embroidery machine. 

Sample designs & artwork

BE EmbroideryStudio contains hundreds of ready-to-stitch designs, 
including attractive ornaments, samples and digitizing backdrops. Design 
files (EMB files) and images (BMP, JPG, and WMF files) can be found in 
your Embroidery and Picture libraries.

Details are clearly
defined

Shapes are filled with 
appropriate fill and 
outline stitches

Stitches are angled to 
match shapes

Design looks good—
shapes, colors, balance
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The most valuable thing you can do when starting out is to spend some 
time exploring these designs and getting to know what’s available. 
BE EmbroideryStudio includes its own Design Library design 
management application to view and manage your embroidery designs. 
Alternatively, explore design folders using File Explorer. See also 
Design Management.

Navigate folder
structure via

navigation tree or
address bar
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Caution: Included artwork (clipart) and embroidery designs can only be 
used for personal use – i.e. they cannot be commercially sold in any form. 
Changing the medium – i.e. clipart to embroidery or embroidery to clipart 
– does not remove copyright protection.

CorelDRAW resources

CorelDRAW® Graphics Suite is bundled as standard with some product 
models. CorelDRAW® Standard Membership also provides access to 
content – clipart, fonts, stock photos, templates, and much more.

Get familiar with the many CorelDRAW® resources available to you. 
Many can be adapted for use with embroidery design, either as digitizing 
backdrops or direct conversion.

Caution: Included artwork (clipart) and embroidery designs can only be 
used for personal use – i.e. they cannot be commercially sold in any form.

Embroidery creation techniques

Depending on your level of product, there are two fundamental design 
modes in BE EmbroideryStudio:

CorelDRAW 
Graphics

This mode allows you to create or edit graphic designs 
using the CorelDRAW® Graphics Suite toolset.

Wilcom 
Workspace

This mode allows you to create and edit embroidery 
designs using an embroidery digitizing toolset.
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Note: For a full description of the CorelDRAW® Graphics Suite tools, 
refer to the electronic User Guide available via the MS Windows® Start 
> Programs group. Alternatively, use the online help available from the 
Help menu.

Using electronic artwork
There are two broad categories of artwork file, both of which can be 
imported into BE EmbroideryStudio for use as digitizing backdrops – 
vector and bitmap. CorelDRAW Graphics supports the automatic and 
semi-automatic digitizing of both bitmap images and vector graphics. The 
quality of the resulting embroidery greatly depends on the type and 
quality of the original artwork.

Preparing images for digitizing
Generally speaking, vector graphics preserve the picture quality when 
resized, whereas bitmap images cause problems of pixelation and image 
degradation when enlarged or scaled down. In order to make bitmap 
images more suitable for automatic digitizing, BE EmbroideryStudio 
provides image processing capabilities. See Digitizing with Bitmaps 
(Reference Manual).
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Digitizing shapes manually
You trace shapes and lines over electronic artwork using various digitizing 
on ‘input’ methods. Using a bitmap image in this way is like using an 
enlargement drawing on a digitizing tablet, except that everything is 
done on screen. See Embroidery digitizing (Reference Manual).

Converting artwork to embroidery
BE EmbroideryStudio lets you convert vector objects directly to 
embroidery objects. In fact, entire vector designs can be converted to 
embroidery. You can modify these designs as you wish. You can also 
convert embroidery to vector graphics. See Convert objects with 
CorelDRAW Graphics (Reference Manual).

Tip: CorelDRAW® Graphics Suite lets you trace bitmaps to convert them 
to fully editable and scalable vector graphics. You can trace scanned 
sketches, artwork, digital photos, and logos and easily integrate them 
into your designs.
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Object-based embroidery

In BE EmbroideryStudio, you build designs from basic shapes or 
‘embroidery objects’. They are called ‘objects’ because they are discrete 
entities which can be manipulated independently of each other. These are 
like ordinary vector objects in that they have certain defining 
characteristics or ‘properties’ such as color, size, position, and so on. 
They also have properties unique to embroidery such as stitch type and 
density.

Note: In BE EmbroideryStudio, vector and embroidery objects are in fact 
inter-convertible since they share many of the same characteristics. See 
also Convert objects with CorelDRAW Graphics (Reference Manual).

Design shapes and stitching sequence
The embroidery objects comprising a design form a stitching sequence. 
Before creating an embroidery design, it is good practice to analyze and 
plan shapes and stitching sequence in advance. Shapes need to be clearly 
defined to make them easy to embroider. The best ones have relatively 
constant width, with smooth edges, no sharp turns and no small, 
protruding details. Outlines and details should always be stitched last.

If you are digitizing manually, objects are stitched out in the order they 
were created. In other words, the digitizing sequence defines the 
stitching sequence. If you have converted an electronic design, 
BE EmbroideryStudio uses automatic sequencing to create the optimum 
stitching sequence. Auto-sequencing attempts to generate embroidery 
designs which are economical to produce, with minimal down time, and 
accurate registration of textures and colors.

Mixed-mode approach
If you take a mixed-mode approach, you may do the bulk of the design 
by means of automatic conversion, and touch-ups and edits using the 
suite of BE EmbroideryStudio embroidery digitizing tools. In addition, 
you can always manually adjust the stitching sequence to improve the 

1

2

3

4

5
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stitchout, for example, to minimize color changes. See also Automatic 
digitizing (Reference Manual).

Object viewing and selection

BE EmbroideryStudio provides many viewing modes to make it easier to 
work with your designs. View a design at actual size or zoom in for more 
detail. Pan a design instead of scrolling, or quickly change between one 
view and the last. Show or hide outlines, stitches themselves, or view 
designs in TrueView™.

Understanding stitching sequence
When working with embroidery designs, you can check the stitching 
sequence by ‘traveling’ through it by means of color blocks, embroidery 
objects, or even stitch-by-stitch. Alternatively, simulate the actual 
embroidery design stitchout on screen. You can also preview designs in 
different colors on different backgrounds by selecting from predefined 
colorways. See Viewing stitching sequence for details.

Selecting embroidery objects
BE EmbroideryStudio provides various ways 
to select embroidery objects. Modify the 
design as a whole or select individual 
objects for more precise modification. The 
Color-Object List provides an easy way to 
select objects and colors in a design and 
access their properties. Use it also to group 
and ungroup, lock and unlock, and show 
and hide objects. See Selecting objects for 
details.

Digitizing embroidery shapes

In addition to the automated and semi-automated techniques 
BE EmbroideryStudio provides for creating embroidery designs, it also 
contains a suite of manual digitizing tools. These are similar to graphics 
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tools except that the end result are embroidery rather than vector 
objects. It is important to be familiar with manual digitizing methods in 
order to fully understand the process, the types of objects created, and 
the problems associated with embroidery digitizing.

Digitizing simple & complex shapes
There are tools for digitizing filled shapes with turning stitches and fixed 
stitch angles, with or without holes. There are also tools for creating 
columns and borders of fixed or varying width. See Embroidery digitizing 
(Reference Manual).

Digitizing outlines & details
BE EmbroideryStudio provides tools for creating outline stitching of 
varying thicknesses and styles. They are typically used to add outlines 
and details to designs. There are tools for creating simple run stitching 
as well as decorative outlines using predefined motifs. Backstitch is an 
older-style, adaptable stitch which can be used for delicate outlines. 
Stemstitch is thicker and can be used to mimic hand-sewn embroidery. 
Occasionally you may even need to digitize individual stitches. See 
Digitizing outlines & details (Reference Manual).

Stitch types
The most important property of all embroidery objects is their stitch type. 
The software uses object outlines and the associated stitch type to 
generate stitches. Whenever you reshape, transform or scale an object, 
stitches are automatically regenerated. See Stitch Types (Reference 
Manual).

Outlines

Details

Free-form 
shapes

Columns
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Threads & colorways
When digitizing, you select thread colors for objects from the color 
palette. This contains a selection of colors tailored to each design or color 
scheme. The particular ‘colorway’ represents the actual thread colors in 
which a design will be stitched. You can define multiple color schemes and 
switch between them. See Colorways (Reference Manual). 

For each colorway you define, you can select colors from commercial 
thread charts or define your own. Search for particular threads by specific 
code. Automatic thread color matching helps you locate thread colors 
based on closest match across one or several thread charts. You can also 
match thread colors from imported graphics – vector or bitmap.

Design backgrounds
BE EmbroideryStudio also lets you set the background color, fabric, or 
product of the current colorway for more realistic previews and 
presentations. The background is saved with the colorway. See Fabric & 
product backgrounds (Reference Manual).
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Properties, fabrics, styles & templates
Object properties are stored with each object whenever you save a 
design. These properties determine how stitches will be regenerated 
whenever you reshape, transform or scale an object or entire design.

Default properties are stored with the design template and form the basis 
of all new designs. These may be overridden by fabric settings which are 
automatically adjusted to suit different fabric types. These in turn may 
be overridden by individual property settings determined by the digitizer. 
See Object Properties (Reference Manual).

Underlays & pull compensation
Embroidery stitches pull fabric inward where needles penetrate. This can 
cause fabric to pucker, stitch bunching, and/or unsightly gaps to appear 
in the embroidery. BE EmbroideryStudio includes many techniques for 
achieving smooth, even placement of stitches, and the elimination of 
gaps in designs.
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For an object to sew out correctly, it must have correct stitch spacing, 
sufficient pull compensation, together with a suitable underlay for the 
particular combination of cover stitch type, object type, object shape, 
and fabric. See Embroidery Reinforcement (Reference Manual).

Embroidery connectors
Connectors link objects in a design. 
They can be run stitches or jumps. 
Travel runs are typically used to 
connect segments within filled 
objects. You can use automatic 
settings to generate connectors, trims 
and tie-offs, or add them manually. 
You can change connector settings for 
a whole design or selected objects. If 
you prefer to add tie-offs and trims as 
you digitize, you can turn off 
automatic connectors altogether.
BE EmbroideryStudio also allows you 
to automatically connect first and last 
stitches of a design. This makes it easy to position the needle before 
stitching, and reduces the chance of it hitting the frame. See Embroidery 
Connectors (Reference Manual).

Automatic digitizing

Depending on your product level, BE EmbroideryStudio offers a variety of 
complementary tools and techniques for automatically digitizing suitably 
prepared artwork.

Auto-tracing bitmap artwork
Use Auto Trace To Vectors to create vector outlines from bitmap 
images. You can then convert these to embroidery objects using a variety 
of input methods. Auto Trace To Vectors can find holes in shapes – 
both inside and outside boundaries are detected. See Auto-tracing 
bitmap artwork (Reference Manual).
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Auto-digitizing image shapes
Auto-Digitizing tools provide everything necessary to digitize shapes in 
bitmap images and vector graphics automatically without using manual 
digitizing methods. See Auto-digitize individual shapes (Reference 
Manual).

Auto-digitizing entire images
Smart Design automatically converts whole bitmap images to fully 
digitized embroidery. See Auto-digitize entire designs (Reference 
Manual).

Turning satin

Tatami fill
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Auto-digitizing photographs
Use Color PhotoStitch or Photo Flash to create embroidery from 
photographs and other images. While Photo Flash designs consist of 
rows of single-color satin stitching, Color PhotoStitch produces 
variegated stitching using multiple thread colors. The overall effect is like 
multi-colored stippling. See Auto-Digitizing with Photos (Reference 
Manual).

Modifying designs

After digitizing a design, you can modify it as a whole, edit individual 
objects or even individual stitches.

Combining & resequencing objects
BE EmbroideryStudio provides various techniques for combining and 
sequencing objects. You can add to designs by duplicating and copying 
objects. Combine designs. Resequence objects in designs to minimize 
color changes and optimize production.
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The stitching sequence naturally occurs in the order in which an 
embroidery design is digitized or assembled. When converting a graphic 
design to an embroidery design, BE EmbroideryStudio decides the 
stitching sequence according to its own internal logic. Either way, you 
may, for reasons of aesthetics or production efficiency, want to adjust it. 
The Color-Object List displays a sequential list of objects grouped by 
object and color. It provides an easy way to group, cut, copy and paste, 
and resequence selected objects and color blocks. BE EmbroideryStudio 
also allows you to create ‘branched objects’. Like-objects are thereby 
resequenced, connectors minimized, components grouped, and stitches 
regenerated. Underlay can be applied to all. See Combining Objects 
(Reference Manual).

Arranging, scaling & transforming objects
You can change the position, size and orientation of objects in a design 
by moving, scaling and transforming them. Group objects together to 
apply universal changes, or lock them to avoid unintentional 
modification. Modify objects directly on screen or via their object 
properties. Access commonly used functions via the Color-Object List. 
See Transforming Objects (Reference Manual).
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Reshaping and converting objects
BE EmbroideryStudio offers a number of techniques for reshaping 
embroidery objects, all with the one tool. Sometimes you may need to 
cut, split or break up complex or compound objects in order to fine-tune 
them. Various tools are available for this purpose. As well as reshaping 
object outlines, you can add and adjust stitch angles, a property unique 
to embroidery objects. You can also change the entry and exit points of 
individual objects which is important if you are digitizing manually or 
resequencing embroidery objects. See Reshaping & Splitting Objects 
(Reference Manual).

Optimizing stitch quality
When it comes to embroidery production, the current stitch density may 
not be perfect for certain fabrics or threads. Or you may want to make 
production cheaper by reducing overall stitch count. After scaling 
operations, for example, designs may contain small stitches which can 
damage fabric and cause thread or needle breakage. Sharp corners may 
cause stitch bunching which can create hard spots in the embroidery and 
damage fabric or needle. Embroidery machines have a maximum 
possible stitch length which is determined by the physical frame 
movement. If long Satin stitches exceed this, they are broken into 
smaller stitches. BE EmbroideryStudio helps you resolve these issues 
with a number of specialized techniques for optimizing stitching quality 
for different design types and production requirements. See Stitch 
Quality (Reference Manual).
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Editing stitches & machine functions
BE EmbroideryStudio automatically generates stitches from design 
outlines and properties. This means you can scale, transform, and 
reshape native designs without compromising stitch density or quality.
However, BE EmbroideryStudio also lets you 
edit individual stitches. You may need to do 
this, for example, when working with ‘stitch’ 
files which do not contain outline data. Like 
stitches, machine functions are inserted 
automatically whenever you digitize objects 
and specify object properties. They are stored 
with the embroidery object and updated 
whenever it is modified. However, 
BE EmbroideryStudio also lets you manually 
insert machine functions and modify them. 
This flexibility allows you to adapt designs to almost any machine 
requirement. See Stitches & Machine Functions (Reference Manual).

Advanced digitizing

BE EmbroideryStudio provides specialized productivity features as well 
as special effects and digitizing techniques.

Productivity techniques
Specialized digitizing features help to save digitizing time. 
BE EmbroideryStudio provides special input tools for circles, stars, and 
rings, as well as methods for creating repeated or ‘backtracked’ outlines. 
Remove underlying layers of stitching in overlapping objects to reduce 
stitch counts and prevent a build-up of stitches.

BE EmbroideryStudio also provides tools for quickly creating outlines 
based on existing filled shapes, and vice versa. Add decorative borders 
such as rectangles, ovals, and shields to designs or selected objects using 
the Borders library. See Productivity Techniques (Reference Manual).
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Motif runs & fills
Motifs are predefined design elements, such as hearts, leaves or border 
patterns. They generally consist of one or more simple objects, and are 
stored in a special motif set. The BE EmbroideryStudio Motif tools allow 
you to use motifs to create ornamental runs and textured fills. Use the 
ones provided with the software or create your own. Motifs can be scaled, 
rotated and mirrored in the same way as other objects. You can even use 
them to create interesting three dimensional effects. See Motif Stitching 
(Reference Manual).

Embroidery lettering

Create top-quality lettering quickly and simply. BE EmbroideryStudio 
provides a large range of scalable closest-join font styles and multi-color 
and fancy fonts to choose from.

Creating embroidery lettering
Create high-quality embroidery lettering quickly and simply. 
BE EmbroideryStudio provides a large range of scalable fonts to choose 
from. Add embroidery lettering directly to designs or convert from 
CorelDRAW Graphics. Apply formatting just like a word processor, 
including italics, bolding, and right/left justification. Change values for 
the whole text or individual letters. See Creating Embroidery Lettering for 
details.
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Editing embroidery lettering
BE EmbroideryStudio gives you interactive and precise numeric control 
over many settings affecting lettering objects. Adjust both individual 
letters and lettering objects as a whole. Apply horizontal, vertical, and 
curved baselines. Modify baseline type, length, radius and angle, as well 
as position. You can even define the rotation angle of letters relative to 
the baseline or the design itself. See Editing Embroidery Lettering for 
details.

Advanced lettering techniques
Add special characters and symbols to 
your lettering. By default, lettering 
objects are filled with Satin stitch. Apply 
other basic fill stitch types as with all 
embroidery objects.
Specify the sequence in which letters are 
stitched to minimize registration 
problems. The automatic kerning feature 
improves lettering appearance and 
legibility by fine-tuning spacings between 
character pairs.
Alternatively, fine-tune letter spacing 
according to the number of characters per object. This is particularly 
useful with Asian fonts. Lettering appearance and quality can be 
improved with the correct underlay. See Advanced Embroidery Lettering 
for details.
Apply Lettering Art effects to make letters bulge or arch, stretch or 
compress. Many styles are available from the Lettering Art gallery. You 
can fine-tune preset shapes as preferred. Edit lettering text in envelopes 
the same way as normal lettering. See Creating special effects with 
lettering art for details.
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Team lettering
The Team Names feature lets you create designs with multiple names. 
For example, you can use the same logo with different names for sports 
teams or corporate uniforms, without having to create multiple copies of 
the same design. Names are stored in lists that can be accessed from any 
design. You can add to these lists, or remove names at any time.

Depending on how you want to stitch out, you can choose to save and 
stitch names and designs separately, or together. See Team Names 
(Reference Manual).

Monograms
A monogram is a design composed of one 
or more letters, typically the initials of a 
name, used as an identifying mark. The 
Monogramming feature offers a simple 
way to create personalized monograms 
using a selection of predefined monogram 
styles, border shapes and ornaments, 
together with a set of tools to help you 
place these elements in creative and 
decorative ways. See Monogramming 
(Reference Manual).

Custom fonts
Turn any TrueType font installed on your system into an embroidery font. 
The automatic kerning feature improves lettering appearance and 
legibility by fine-tuning spacings between character pairs. Sometimes 
you find that you want to reshape a letter to improve its appearance, 
perhaps to suit a particular lettering height. BE EmbroideryStudio lets 
you save the letter as an alternative version. In fact you can save 
multiple versions of the same letter within the same font. You can even 
create your own custom fonts or modify an existing font for special 
applications. Even merge letters from two or more fonts. See Custom 
Lettering (Reference Manual).
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Mixed decoration

BE EmbroideryStudio provides support for various multi-decoration 
techniques, including print.

Appliqué digitizing
Automatically create all the stitching you need 
for appliqué using the Appliqué tool. Up to four 
layers of stitching – guide runs, cutting lines, 
tack stitches and cover stitches – can be 
generated for any appliqué object, depending on 
current settings. You can also extract appliqué 
shapes from a design to output to a cutter or 
separate file. See Appliqué Embroidery 
(Reference Manual).

Bling digitizing
Bling refers to decorative objects placed on garments or templates, either 
on their own or in combination with other design elements. Bling is 
supplied in varying sizes, shapes, colors and materials. It goes under 
various names such as diamante, rhinestones, eyelets, ribbons, charms, 
crystals, glitz, nailheads, studs, etc.
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BE EmbroideryStudio lets you create bling and embroidery 
multi-decoration designs with the Bling toolset. This tool lets you create 
and visualize bling embellishments in combination with other decorative 
elements. See Bling Digitizing (Reference Manual).

Multi-decoration export
The Multi-Decoration File Export (MDFE) capability allows you to 
export the different file formats involved in a multi-decoration design 
production with a single command option. The system recognizes 
whether a design element is embroidery, graphics, appliqué, or bling. It 
displays each element in an export dialog with a list of corresponding file 
types to choose from. See Exporting multi-decoration files (Reference 
Manual).

Files, machines, & design processing

Design processing and encoding involve all the important, back-end 
operations of embroidery design and manufacture. This is where you 
actually output your designs to machine, disk, printer, cutter, and so on. 
For this, you will need an understanding of embroidery file types as well 
as different machine formats. Depending on your setup, you will also 



   I n t r o d u c t i o n  t o  B E E m b r o i d e r y S t u d i o 52

need an understanding of traditional storage media such as embroidery 
disks.

Printing designs
From the same design file, you can output a production worksheet for the 
embroidery machine operator. Designers frequently want to distribute 
their designs for viewing in real colors, in TrueView™ or otherwise, with 
or without fabric or product backgrounds. BE EmbroideryStudio allows 
you to customize information in the format you require for production 
worksheets and/or approval sheets. You can specify the data to print, 
graphics to include, zoom factor, and general options such as company 
name. You can use a color printer or plotter to produce your worksheets. 
See Design Reports (Reference Manual).

Outputting designs
You can output embroidery designs for actual stitchout in a variety of 
ways – sending directly to machine for stitching, or saving to specific 
machine formats and/or to embroidery disk. See Embroidery Output 
(Reference Manual).
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Reading files of different formats
By default BE EmbroideryStudio saves to its native file format, EMB. This 
format contains all information necessary both for stitching a design and 
for later modification. When opening designs created or saved in other 
formats, BE EmbroideryStudio converts them internally to EMB format. 
They can then be modified using the full range of BE EmbroideryStudio 
features. Depending on the file type, you may need to provide additional 
information to assist BE EmbroideryStudio in the conversion process. See 
Machine Files (Reference Manual).
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Hooping designs
Devices made from wood, 
plastic, or steel, hoops are used 
to tightly grip fabric and 
stabilizer between an inner and 
outer ring. Designed to hold 
fabric taut against the machine 
bed for embroidering, they 
attach to the machine’s frame. 
Fabrics must be hooped before 
stitching out on the machine. 
BE EmbroideryStudio allows you 
to select from a wide range of 
standard factory-supplied 
hoops. If you are using a hoop 
which does not appear in the hoop library, you can define your own from 
scratch or based on a standard hoop. See Design Hooping (Reference 
Manual).

Machine formats
Different embroidery machines speak different languages. They have 
their own control commands for the various machine functions. Before 
you can stitch a design, it must be in a format which can be understood 
by the embroidery machine. When you select a machine format, 
BE EmbroideryStudio uses it to translate digitized designs into a specific 
machine-readable form. If required, you can customize machine formats 
to meet specific machine requirements. See Machine Formats (Reference 
Manual).
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Hardware & software setup

In order to work with your particular equipment, BE EmbroideryStudio 
needs to be properly configured. You may also want to configure the 
software to your particular design requirements.

Setting up hardware
You will need to connect peripheral devices for use with 
BE EmbroideryStudio. These may include digitizing tablets, plotters, 
printers, appliqué cutters, scanners and embroidery machines. Different 
devices are set up in different ways – some in MS Windows®, via the 
Control Panel, others within BE EmbroideryStudio itself. See Hardware 
Setup (Reference Manual).
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Changing system settings
BE EmbroideryStudio lets you adjust various system settings controlling 
the appearance of designs on screen, display of design information, the 
behavior of the design window, and other settings. See System Settings 
(Reference Manual).

Managing designs with Design Library

BE EmbroideryStudio comes equipped with its own built-in 
Design Library for managing your embroidery designs across your 
entire local network. Use it to browse design and artwork files stored on 
your local PC or company network. Design Library capabilities make it 
fast and practical for daily commercial use, avoiding the need to switch 
to and from File Explorer. It recognizes all file formats used by 
BE EmbroideryStudio. It also makes it easy to search, sort and browse 
all embroidery designs on your network.
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In a nutshell, Design Library lets you:
 Search for designs – including artwork files – anywhere on your local 

hard drive, network drives, or external devices such as USB or ZIP 
drive.

 Preview design information in the preview pane.
 Search for designs by various means, including known design 

information.
 Create an organizing structure for easy categorization.
 Batch-convert selected design files to all commercial embroidery 

formats such as DST, EXP, SEW, and others.
 Print selected designs or send them to embroidery machine for 

stitchout.
 Use Design Library to handle job orders.
Find embroidery designs anywhere on your hard drive or external storage 
device and, optionally, add them to your embroidery library. This section 
describes how to open and view designs in Design Library as well as 
adjusting viewing settings. It also covers browsing for and accessing 
designs in folders. See Design Management for details.

Note: Design Library helps you manage designs in folders. It is not a 
multi-user database for company-wide design management. For this type 
of requirement, refer to the DesignWorkflow User Manual.
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Basic Procedures

BE EmbroideryStudio is an MS Windows®-based product incorporating 
many of the conventions with which most PC users are already familiar. 
BE EmbroideryStudio integrates with CorelDRAW® Graphics Suite into a 
single application, allowing users to create, not just embroidery, but true, 
multi-decoration designs.

Operating modes

Open BE EmbroideryStudio using the desktop icon or the MS Windows® 
Start menu. The application has one workspace or ‘design window’ but 
you interact with it in different operating modes. These can be accessed 
via the Modes toolbar.

The main modes you’ll be accessing are:

Switch between 
operating modes



B E E m b r o i d e r y S t u d i o  |  Q u i c k  S t a r t  G u i d e 59

Caution: You need to calibrate your monitor so that designs at 1:1 scale 
appear at real size. Do this when you first install BE EmbroideryStudio or 
whenever you change your monitor. See Calibrating the monitor 
(Reference Manual).

Wilcom Workspace window

When you open BE EmbroideryStudio, it appears by default in Wilcom 
Workspace window with a new, blank design displayed. This mode 
allows you to create and edit embroidery objects using the embroidery 
digitizing toolset. The screen image below shows the more prominent 
toolbars in BE EmbroideryStudio. Depending on your product level, you 
will have access to some or all of these options.

Mode Function

Wilcom 
Workspace

This mode allows you to create and edit embroidery 
objects using an embroidery digitizing toolset.

CorelDRAW 
Graphics

This mode allows you to create and edit vector objects 
using the CorelDRAW® Graphics Suite toolset.

Design Library This mode allows you to manage designs and job orders.

Use Mode > Wilcom Workspace to digitize and edit embroidery designs. 
Display embroidery as well as artwork. View designs realistically in 3D 
simulation.
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Use this mode when you want to create embroidery from digitizing 
‘backdrops’. Various types of image file can be loaded in 
BE EmbroideryStudio. Wilcom Workspace also offers a graphical 
representation of what the final embroidery will look like. Use 
TrueView™ together with a background fabric to see how your design 
will look when stitched out. Some of the more prominent Wilcom 
Workspace interface elements include:

Menu bar

Status / Prompt bars

Mode tools

Standard tools

Object properties
docker

Color tools

Docker tabs

Design window

View tools

Toolbox

‘Floating’ toolbar

Stitch Effects tools

Stitch Types tools

Graphic style and
traditional input

methods

Design tabs

Element Description

Menu bar This contains the application menus such as File, Edit, View, etc.
Mode toolbar This contains tools and icons which are visible in both Wilcom 

Workspace and CorelDRAW Graphics.
Standard 
toolbar

This contains commonly used tools and commands which are 
specific to and only visible in Wilcom Workspace.

View toolbar This contains commands for viewing embroidery designs – e.g. 
as design outlines, by stitches, by machine functions, as they will 
stitch out on the fabric – either separately or in combination. 

Stitch Types 
toolbars

This contains tools which determine the stitch types which can 
be applied to embroidery objects, including Satin, Tatami, Motif 
Fill, etc. 
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 Customize the design window by showing or hiding the grid, changing 
the grid dimensions, as well as showing and hiding toolbars. 

 Dock or ‘float’ toolbars and dockers in any configuration that suits. 
Toolbars are dockable left, right, top and bottom, and can be ‘floated’ 
anywhere in the design window.

  BE EmbroideryStudio allows you the choice of large or small button 
icons with or without text names.

Related topics...
 Access object properties
 Display grids, rulers & guides
 Menus & Toolbars

Design tabs
BE EmbroideryStudio allows you to switch between open designs by 
means of design tabs. This also makes it easy to copy/paste between 
designs, including drag and drop operations. 

Stitch Effects 
toolbar

This contains tools for modifying or improving stitch quality, 
including applying automatic underlay to selected objects. 

Toolboxes Depending on the product model, there are up to three 
‘toolboxes’ – Toolbox, Graphics Digitizing, and Traditional 
Digitizing. Between them, toolboxes contain all the embroidery 
digitizing/editing tools specific to and visible only in Wilcom 
Workspace. 

Color toolbar This contains the embroidery color palette which is specific to 
and visible only in Wilcom Workspace. 

Status / Prompt 
bars

These contain current status information and prompts which are 
visible only in Wilcom Workspace. See below.

Docker Wilcom Workspace includes ‘dockers’ – Object Properties, 
Color-Object List, Color Palette Editor, and others. These stay 
open as long as you need them. 

Design Window This contains the main work area where you create and edit 
embroidery objects as well as graphics objects when you switch 
to CorelDRAW Graphics.

Element Description
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Related topics...
 Set up multiple views
 Menus & Toolbars

Status & Prompt bars
The Status and Prompt bars at the bottom of the Wilcom Workspace 
design window provides continuous display of current cursor position 
status as well as instructions for use of selected tools.

Information includes:

Design tabs

Stitch type and 
current settingsStitch count

Coordinates of current
needle position

Status Bar
Prompt Bar

Length and angle of 
current stitch

Current object
Selected auto

fabric

Current machine function Current hoop

Item Details

Prompt Guides you through use of selected functions.
Stitch count Total number of stitches in design.
Design size Width and height.
Coordinates Coordinates of current needle position (X/Y), and length (L) and 

angle (A) of current stitch. 
Current fabric Fabric settings take into account the type of fabric you are stitching 

on.
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CorelDRAW Graphics window

CorelDRAW Graphics window includes the entire suite of CorelDRAW® 
Graphics Suite drawing tools. This mode allows you to create and edit 
vector graphics using the CorelDRAW Graphics toolset which offers 
many sophisticated techniques for drafting outlines and shapes onscreen.

In addition to the CorelDRAW® Graphics Suite toolset, CorelDRAW 
Graphics provides capabilities to convert vectors and vector text directly 
to embroidery objects. Imported vector graphics or created text can be 
converted directly to embroidery designs. You can use CorelDRAW 
Graphics to insert or paste third-party vector graphics such as clipart for 
use in embroidery designs. Alternatively, insert, paste or scan bitmap 
artwork for use as digitizing templates or ‘backdrops’. Here are some of 
the prominent CorelDRAW Graphics interface elements.

Use Mode > CorelDRAW Graphics to import, edit or create vector artwork 
as a backdrop for embroidery digitizing, manual or automatic.

In Graphics mode, click Mode > Show Embroidery to show or hide 
embroidery components.

Menu bar

Status bar

Toolbox

Mode toolbar
Standard toolbar

Properties bar

Design window

Docker
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For a detailed description of the CorelDRAW® Graphics Suite interface, 
refer to the electronic User Guide available via the MS Windows® Start 
> Programs group. Alternatively, use the online help available from the 
Help menu.

Note: CorelDRAW® needs to be registered before it can be used by 
BE EmbroideryStudio. Registration provides CorelDRAW® Standard 
Membership which gives you access to content – clipart, fonts, stock 
photos, templates – via Corel CONNECT. It also gives you access to the 
latest CorelDRAW® updates.

Design library

Design Library is a design or job order management tool. Use it to 
browse design and artwork files stored on your local PC or company 
network. Design Library capabilities make it fast and practical for daily 
commercial use, avoiding the need to switch to and from File Explorer. 
It recognizes all file formats used by BE EmbroideryStudio.

Element Description

Menu bar This contains application menus such as File, Edit, View, etc.
Mode toolbar This contains the universal tools and icons which are visible in 

both Wilcom Workspace and CorelDRAW Graphics windows.
Standard toolbar This contains commonly used tools and commands which are 

specific to and only visible in CorelDRAW Graphics.
Properties bar This contains the commands and controls that relate to the 

active tool in the Toolbox or active object in the design window 
in CorelDRAW Graphics.

Toolbox This contains the drawing/editing tools specific to and visible 
only in CorelDRAW Graphics.

Design window This contains the main work area where you create and edit 
graphics objects as well as embroidery objects when you switch 
to Wilcom Workspace.

Color palette This contains the graphics color palette which is specific to and 
only visible in CorelDRAW Graphics.

Docker In CorelDRAW Graphics, this contains graphics-specific 
dockers.

Status bar This contains current status information visible only in the 
CorelDRAW Graphics.

Click Mode > Design Library to open a window from which to search and 
manage designs and job orders.
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Design Library is installed with sample designs in EMB format. These 
show various stitching techniques and effects, including 
‘multi-decoration’ and multiple colorways. When starting out as a new 
user, make sure to spend time exploring these designs.

Toolbars & dockers

The BE EmbroideryStudio design window provides ‘dockers’ for key 
functions. Wilcom Workspace has docking panes for Color-Object 
List, Object Properties, Overview Window, and so on. All panes are 
dockable on either side of the design window.

Access toolbars

Toolbars provide quick and easy access to most BE EmbroideryStudio 
commands. Show or hide them at your convenience. As you get more 
familiar with the system, you may prefer menu and keyboard commands. 

To access toolbars...
 Select Window > Toolbars or right-click the docking area at the top 

or left of the design window. The Toolbars menu opens.
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 Click to activate one or many.

Work with dockers

In Wilcom Workspace mode, there are three important dockers:

Access dockers via the Docker toolbar or Window menu. They can be 
docked on either side of the screen.

Select toolbars 
to display

Use Docker > Color-Object List to view and sequence design objects.

Use Docker > Object Properties to preset properties or adjust properties of 
selected objects.

Use Docker > Colorway Editor to assign thread colors to color palette and 
define colorways.

Docker Description

Object 
Properties

The most important is the Object Properties docker. Use it 
together with the Property Bar to access properties of selected 
embroidery objects. 

Color-Object 
List

The Color-Object List offers an easy way to selectively view and 
resequence color blocks and objects. 

Colorway 
Editor

When you create a new design, it includes a single default 
colorway called ‘Colorway 1’. The Colorway Editor allows you to 
edit default colors, add extra color slots as required, and set up 
additional colorways.
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All dockers can be fixed or minimized. Dockers may also be ‘floated’ by 
dragging the caption bar to the design window or double-clicking it when 
‘pinned’ in place. Dockers can be ‘nested’ to increase available 
workspace. When nested, tabs for each docker appear down the side. 

Toggle Auto Hide next to the X close button. Docking panes 
automatically retract when not in use. By hovering the mouse over the 
tab, a minimized docker will ‘fly out’, allowing you to access its functions. 

Access dockers via 
menu or toolbar

Hover docker over 
title bar of another

Click tab to 
view docker

Click and drag tab 
to float docker
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Related topics...
 Access object properties
 View selected color blocks

Access object properties

The most important docker is Object Properties. Use it together with 
the Property Bar to access the properties of selected embroidery 
objects.

To access object properties...
 Open the Object Properties docker by any of the following means:
 Click the Object Properties toggle.
 Double-click an object in the design window.
 Right-click an object and select from the popup menu.
 Right-click an object in the Color-Object List and select from the 

popup menu.

Enable/disable
auto-hide

Close 
docker

Double-click title bar to
return to docked state

Use Docker > Object Properties to set properties of selected objects.
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 Select a tab to access the properties to adjust. 
 Adjust general properties – width, height, position – by means of the 

Property Bar. Press Enter to apply. Press Esc to discard changes.

Tip: You can specify units of measurement when entering values into 
a measurement control.

Related topics...
 Set measurement units

Embroidery machine formats

Different embroidery machines speak different languages. They have 
their own control commands for the various machine functions. When 
you create a design, you need to select a format corresponding to the 
embroidery machine you intend to use. BE EmbroideryStudio uses the 
format to translate digitized designs into a specific machine-readable 
form. You don’t, however, need to change a design’s ‘native machine 
format’ in order to output to a different machine. If a selected machine 
format does not support a particular function in the design, it is simply 
ignored on output.

Object Properties 
tabs

Adjust settings as 
required

Click to close

Droplist

Adjust position and size 
settings. Press Enter to 
apply.
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To select a machine format...
1 Select Design > Select Machine Format.

2 Select the required machine format from the list.

Note: You can change the machine format itself if machine values do 
not correspond precisely to your particular machine. Or you can create 
a new format based on a selected one.

Embroidery file formats

Embroidery designs are saved in one of two formats – ‘design’ (outline) 
or ‘machine’ (stitch) file format.

Note: For details of the formats supported by BE EmbroideryStudio, see 
Embroidery file formats (Reference Manual).

Design files

Design files, also known as ‘all-in-one’ files, are high-level formats which 
contain object outlines, object properties and stitch data. When you open 
a design file in the software, corresponding stitch types, digitizing 
methods and effects are applied.

Select
machine

format
Click to adjust 
settings

Click to create 
new format
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Design files can be scaled, transformed and reshaped without affecting 
stitch density or quality. After modification, you can choose to save your 
design to EMB format, or to a different format altogether.

Note: Some design files, such as Wilcom INP and Gunold PCH, contain 
incomplete information. Old format ESD designs are somewhere between 
a design file and a machine file. They contain stitch data, information 
about selected stitch types, densities, and machine functions. They do 
not, however, contain information about shapes and lines. ESD files 
require object/outline recognition if you want to perform object editing in 
BE EmbroideryStudio.

Machine files

Different embroidery machines understand different languages. Each has 
its own control commands for the various machine functions. Before you 
can stitch a design, it must be in a format which can be interpreted by 
the machine. Machine or ‘stitch’ files are low-level formats for direct use 
by embroidery machines. They contain only stitch coordinates and 
machine functions. They are generally created on-the-fly when sending 
designs to machine. Or they are converted when saving to disk or 
memory stick.

Manual objects
When they are read into BE EmbroideryStudio, machine files do not 
contain object information such as outlines or stitch types, but present 
the design as a collection of stitch blocks called ‘manual objects’. Manual 
objects are created wherever machine functions – e.g. color changes or 
trims – are detected in the design. They have only general and connector 

Embroidery objects with
outlines and stitch

properties
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properties. Manual objects, in turn, consist of individual stitches, called 
‘manual stitches’.

File sources

While embroidery files are broadly classified as ‘design’ (outline) or 
‘machine’ (stitch), BE EmbroideryStudio internally tags files as belonging 
to one of four types – native design (A), imported outlines (B), processed 
stitches (C), or imported stitches (D).

Native EMB designs as well as ART and JAN files are all ‘Grade A’ 
embroidery formats read and written by BE EmbroideryStudio. They are 
called ‘Grade A’ because they contain a complete set of design 
information in a single file – object outlines, properties, stitches, thread 
colors, thumbnail image, and comments. There are three other grades of 
embroidery file. It goes without saying that only Grade A files provide 
100% perfect scaling and transformation. 

Note: For information about the source of a design file, refer to the 
Design Information docker.

Manual objects with no
outlines and manual

stitches only

Grade Description

A Pure embroidery file created in BE EmbroideryStudio or similar 
software. These files contain objects, outlines and stitches.

B
Designs read from an outline format such as GNC and saved in ART / 
EMB / JAN format. Such designs cannot be read directly by 
BE EmbroideryStudio but once converted, they are treated as Grade B 
designs.

C Designs read from machine files – EXP, DST, PES, etc – where stitches 
have been converted to objects.

D Designs read from machine files where stitches have NOT been 
converted to objects.
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Related topics...
 View design details in BE EmbroideryStudio

Working with design files

BE EmbroideryStudio handles all commercial and home stitch file 
formats. In fact native EMB files are read and written by leading home 
embroidery systems. 

Whenever you start BE EmbroideryStudio, a new file – Design1 – is 
automatically created. By default, Design1 is based on the NORMAL 
template. Templates contain preset styles, default settings or objects, to 
make digitizing quicker and easier. BE EmbroideryStudio provides a set 
of optimized fabric settings that take into account the type of fabric you 
are stitching on.

Open designs

BE EmbroideryStudio opens a comprehensive range of both ‘design’ and 
‘machine’ files.

To open a design...
1 Click the Open Design icon.

Use Standard > Open Design to open an existing design.

Use Standard > Open Recent Designs to open a design from a list of 
recently opened designs.
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2 Navigate to the design folder. The dialog filter defaults to ‘Wilcom 
All-in-One’ designs which displays all native EMB design files. Adjust 
the filter as required...

3 Select a design or designs.
 To select a range, hold down Shift then select first and last.
 To select multiple items, hold down Ctrl and click.

Tip: For more information about a selected file, right-click and select 
Properties from the popup menu. 

4 For file types other than EMB or ESD, click Options and adjust 
recognition options as preferred.

5 Click Open.
6 Optionally, select Design > Auto Fabric to apply preferred fabric 

settings.

Filter Files

All-in-one design 
files

All design files supported by BE EmbroideryStudio 
including JAN and ART.

All machine files Filter by machine file format only. No design files.
All embroidery files All supported ‘design’ and ‘machine’ files.

Supported design
and machine files
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7 Whenever you want to work on a recently opened design, use the 
Open Recent Designs for quick access.

8 If the Backup Copy option is active, a backup copy of the current 
design file is automatically created in its previously saved form. 
Access the backup folder via the File > Open Backup Design 
command.

Tip: You can also open designs from proprietary embroidery disks, or 
read them from paper tape.

Related topics...
 Viewing design information

Create designs from templates

Templates are special files used to store styles, default properties, as well 
as fabric settings. Although the NORMAL template settings are suitable 
for a range of fabrics, selecting an auto fabric further adjusts settings.

Choose a 
fabric type

Tick to
activate

Quickly access 
any recently 
opened designs

Use Standard > New Design to start a blank design based on the currently 
selected template. Hold down Shift and click to open New from Template 
dialog.
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To create a design based on a template...
1 Select File > New from Template or, holding down the Shift key, 

click New Design. The New from Template dialog opens.

2 Select a template from the droplist. When you create a file based on 
a template, its settings are copied to the new design.

3 If you want, additionally, to use fabric settings, tick the checkbox. 
From the droplist, choose a fabric type nearest the one you intend to 
work with.

4 Optionally, choose a background to match the selected auto fabric.
5 Choose a target machine from the droplist. You normally decide which 

machine format to use before you start. However, formats can be 
changed at any time.

Tip: You can customize or add formats to suit the target machine.
6 Click OK to accept. A blank design opens in the design window based 

on the selected template. Settings will apply to all newly created 
embroidery objects. Any selected fabric is displayed in the Status Bar. 

Tip: The New from Template option is activated by default. Turn it 
off if you prefer work without predefined fabric settings.

Choose a template

Activate auto fabrics 
and choose a target 
fabric

Set background 
color and swatch

Choose a target 
machine format

Save as
default
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Save & close designs

The Save Design option allows you to save a design to the latest native 
EMB ‘all-in-one’ format. To save designs to previous formats, choose File 
> Save As.

Native EMB files contain a complete set of design information in a single 
‘all-in-one’ file – object outlines and properties, actual stitches and 
machine functions, thread colors, a picture icon, summary information, 
and more. Even the original design bitmap image can be included in EMB 
format. Only native EMB files provide 100% perfect scaling and 
transformation. BE EmbroideryStudio lets you save designs in various 
native EMB formats. This can be important if your suppliers or clients use 
previous versions of Wilcom software.

Caution: If a design feature is not available in the selected file type, it 
will be converted. For example, Flexi Split stitching may be changed to 
plain tatami. If the design contains a bitmap using a color depth 
unsupported by the selected file type, it will be removed from the 
resulting file.

Closing designs
To close designs, use the commands in the File menu to close open 
designs individually or all together. Alternatively, use the design tabs to 
close open designs.

Use Standard > Save Design to save the current design. Right-click to open 
the Save As dialog.

Choose an output 
file format
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Design thumbnail display
Design thumbnails reflect display settings at the time of saving. When a 
design is saved, the design thumbnail is generated using all visible 
objects as well as the current design background. If you have bitmap or 
vector display turned on, these too appear in the thumbnail. 

Related topics...
 View embroidery components

Send designs as email attachments

Design tabs – click 
X to close

Close current or 
all open designs

Use Standard > Open Design to send a design as an email attachment.
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You can attach designs to emails from the design window or via the Open 
Design dialog.

To send designs as email attachments...
 With the design open in the design window, select File > Send via 

Email.
 Alternatively, click the Open Design icon. Select the file to send, then 

right-click it. The popup menu appears. Select Send To > Mail 
Recipient.
Your default email system is launched and a new email created with 
the design file attached.

 Enter mailing details and send.
 Optionally, to output a design as a bitmap, select File > Capture 

Design Bitmap.

Select Send To 
> Mail 
Recipient

Select output 
option
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Selecting objects

BE EmbroideryStudio provides various 
ways to select embroidery objects. It 
supports point & click, selection marquee 
and multiple object selection. The 
Color-Object List provides an easy way to 
select objects and colors and access their 
properties.

Tip: Depending on your background, you 
can change display colors for unsewn 
stitches, selected objects, object outline, 
grid and guides. See also Change display 
colors.

Select objects with selection tools

Use selection tools to select individual objects as well as groups or ranges 
of objects.

To select objects...
 The simplest way to select an object is to point and click with the 

Select tool activated. Selection handles appear around selected 
objects.

Use Select > Select to select individual objects as well as groups or ranges 
of objects.

Use Select > Freehand Select to select object at current by drawing a 
freehand line. 

Click Select > Polygon Select to select objects with a selection marquee.

Click Select > Polyline Select to draw a line through the object to select.
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 To select multiple items, hold down Ctrl as you click. To select a range, 
hold down Shift as you click. 

 Alternatively, drag a selection marquee around the objects you want 
to select.

 Where you have a mixture of objects – outline, closed-fill, open-fill – 
click through holes or gaps to select objects beneath.

 Alternatively, use the Freehand Select tool to draw a freeline around 
the object/s you want to select. Press Enter to close.

 Alternatively, use the Polygon Select tool to mark reference points 
around the object/s you want to select. Press Enter to close.

Click first object Hold down Ctrl and 
click another object

Ctrl + Hold down Shift and 
click last object

Shift +

OR

Drag a selection marquee 
around objects to select

Draw a freeline 
around object/s to 
select
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 Or use Polyline Select to mark two or more reference points to 
create a line touching all objects you want to select.

 To select an object which is sitting behind another filled object, hold 
down the 2 key and click until the underlying object is selected.

 To select all objects, select Edit > Select All or press Ctrl+A. 
Selection handles appear around the entire design.

 Deselect objects by any of the following means:
 To remove an object from a selection, hold down Ctrl and click.
 To deselect all, click an empty area of the background or a different 

object.
 Alternatively, press Esc or X to deselect all or select Edit > 

Deselect All.

Tip: BE EmbroideryStudio also provides a method for you to select 
individual objects within grouped objects. See Select objects within 
groups (Reference Manual).

Select objects with Color-Object List

The Color-Object List offers an easy way to select objects and 
selectively view them. It is synchronized with the design window, 
dynamically updating whenever you edit.

Mark reference 
points around 
object/s to select

Mark two 
reference points

Use Docker > Color-Object List to toggle the Color-Object List on/off. Use 
it to view and sequence objects in a design.
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To select objects by Color-Object List...
1 Click the Color-Object List icon to open the docker. A separate icon 

for each color block and each object in the design appears in order of 
stitching.

2 Click a ‘node’ to open or close a color block and see its components.

3 Click an icon to select a color block and/or individual objects.
 To select a range of items, hold down Shift as you click.
 To select multiple items, hold down Ctrl as you click.

Total objects in 
design

Total color block 
count

Object icon

Click to open/close
all color block nodes

Click to open/close
individual color block

node

Blue border appears
around selected

objects

Right-click any object or 
color block, and Select 
All



   B a s i c  P r o ce d u r e s 84

 To select all items, right-click and choose Select All from the popup 
menu.

 To deselect, click away from the design.

Note: You can also use the Color-Object List to group and lock 
objects as well as cut, copy and paste, resequence, and branch 
objects. See Combining Objects (Reference Manual).

Measurements

BE EmbroideryStudio provides a set of grid lines to help accurately align 
or size embroidery objects.

Display grids, rulers & guides

Use grid lines to help accurately align or size embroidery objects. Default 
grid spacing is 10mm x 10mm. Invoke rulers to accurately position and 
scale objects. The unit of measurement – mm or inches – defaults to the 
regional settings in the MS Windows® Control Panel.

To display grids, rulers and guides...
 Click the Show Grid icon or press Shift+G. Right-click for settings. 

You can change grid spacing, select a reference point and turn Snap 
to Grid on or off in the Options dialog.

 Click the Show Rulers & Guides icon or press Ctrl+R.

Click View > Show Grid to show or hide the grid. Right-click for settings.

Click View > Show Rulers and Guides to show or hide rulers and guides. 
Right-click for settings.

Drag the ruler zero point to reset a new ruler zero point.

Show Grid
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 Reset the ruler zero point by clicking and dragging the button in the 
top left-hand corner of the ruler.

 To create a guide, click either ruler – horizontal or vertical – and 
click-and-drag it into position. Multiple guides can be created and just 
as easily removed.

 For more accurate positioning of guides, double-click the yellow 
handle. In the Guide Position dialog, enter a precise distance from 
zero point and click OK.

 To remove a guide, drag the yellow guide handle off the design 
window.

 Optionally, turn on the Snap to... feature via the Options dialog.

Click-and-drag to reset
ruler zero point

Click-and-drag to
reposition guides

Click ruler to create
new guide

Drag guide off
ruler to remove

Enter precise offset 
from zero point
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 You can also change the color of grid and guidelines via the 
Background & Display Colors dialog.

Related topics...
 Change display colors

Set measurement units

The first time you run BE EmbroideryStudio, the measurement system 
will default to whatever the operating system is using. However, you can 
change measurement units from within BE EmbroideryStudio. 

Note: Technically, when you select ‘U.S.’, you will get the imperial 
measurement system – inches, feet, and yards. Inch rulers are displayed 
in 1/16, 1/8, ¼, ½, and 1" divisions. The grid size can be set in decimal 
inches.

Ripple-on effects
Changing the measurement system will change the units used by most 
controls.

Select to
display grid

Select to snap
design points

to grid

Show rulers
and guides

Select desired
measurement unit
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Relevant fields also appear in the selected unit of measurement – e.g. 
Design Information docker as well as Production Worksheet.

There are, however, exceptions to this rule: 
 Stitch List: this used to be displayed in inches for U.S. systems. But 

these are stitch lengths, so must always be in mm.
 Stitch length and density controls remain in mm regardless of 

measurement system. These controls reflect the machine functions as 
industrial machines are always in millimeters.

Specify measurement units on-the-fly
Alternatively, you can specify units of measurement when typing values 
into a measurement control. BE EmbroideryStudio automatically 
converts the value. 

Measurement 
units display

Selected 
measurement unit 
displayed

Stitch length and 
density controls remain 
in mm
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For example, if a US customer orders lettering in inches – say ¾" – and 
the digitizing is to be done in metric, you can enter ‘3/4in’ or ‘3/4 in’ into 
the Lettering Height field and it is automatically converted to 
19.05mm.

Note: BE EmbroideryStudio supports both proper and improper fractions 
– e.g. ‘1 1/3’ as well as ‘4/3’. It does not, however, support mixed units 
– e.g. 1’3". Nor does it display values as fractions after they are entered, 
only during.

Supported units
Supported units include:
 millimeters, mm 
 inches, in
 feet, ft
 yards, yd 
 centimeters, cm 
 meters, m 

Tip: BE EmbroideryStudio also allows entering units in text form, both 
English and the language the software is currently running in.

Related topics...
 View design details in BE EmbroideryStudio

Measure distances on screen

Measure the distance between two points on screen using the Measure 
command. View measurements in the Status bar or tooltip.
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Tip: For more accurate results, zoom in before you measure. The 
measurement is always the actual size, and is not affected by the zoom 
factor.

To measure a distance on screen...
1 Select View > Measure or press M and click the start point.
2 Move the pointer to the end point and hold the mouse still. If 

activated, length and angle measurements appear in a tooltip.

The following information displays in the Status Bar:
 Position coordinates of the end point (X=, Y=)
 Length of the measured line (L=)
 Angle of the line relative to the horizontal (A=).

Measurements are shown in millimeters or inches according to 
selection.

3 Press Esc again to exit the command.

Measurements 
appear as tooltip
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Viewing Designs

BE EmbroideryStudio provides many viewing features to make it easier 
to work with your design. Use zoom and pan functions to study design 
details. Toggle between ‘artistic’ and ‘technical’ views. You can also 
preview designs in different colors on different fabrics by means of 
‘colorways’.

BE EmbroideryStudio provides design information in various forms. 
Approval and production sheets provide essential information such as 
design previews, size, color sequence information and any special 
instructions.

Viewing design components

BE EmbroideryStudio provides many viewing modes to make it easier to 
work with your design. View a design at actual size or zoom in for more 
details. Pan across instead of scrolling, or quickly change between 
current and previous views.

Note: You need to calibrate your monitor so that designs at 1:1 scale 
appear at real size. Do this when you first install BE EmbroideryStudio or 
whenever you change your monitor. Go to Setup > Calibrate Screen.

View embroidery components

When you open an embroidery design in BE EmbroideryStudio, toggles 
on the View toolbar allow you to alternate between ‘artistic’ and 
‘technical’ views. Use TrueView for presentation purposes. You can 
include it on approval sheets, or capture it as a bitmap to send via email 
or publish to a website.
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Use these toggles, singly or in combination, to focus on design details. 
For example, view design outlines, stitches, needle points, or even 
machine functions such as trims and tie-offs. You can also turn on 
connectors in stitch view. How you use the view options will depend 
largely on whether you are editing a design or checking for production 
readiness. 

Note: Design thumbnails reflect display settings at the time of saving. 
When a design is saved, the design thumbnail is generated using all 
visible objects as well as the current design background. If you have 
bitmap or vector display turned on, these too appear in the thumbnail. 
See also Save & close designs.

Shortcut keys
Available shortcut keys include:

TrueView Toggle between stitch view and TrueView™. T

Show Stitches Toggle embroidery stitching display. S

Show Outlines Toggle object outlines. L

Show Needle 
Points

Toggle needle points to select stitches for 
editing. . (period)

Design viewing toggles

Hover cursor for 
tooltips
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Tip: Depending on the design background, you can change display colors 
for selected objects, unsewn stitches, etc.

Related topics...
 Change display colors

View graphical components

Apart from embroidery, EMB designs may include other components such 
as bitmap images, vector graphics, appliqué fabrics, product backdrops, 
and rhinestones or ‘bling’. These can also be turned on or off as desired.

Show 
Connectors

Toggle connecting stitches to help position entry 
and exit points. V+C

Show Functions Toggle display of machine functions such as 
trims and tie-offs. V+F

Use View > Show Bitmaps to show and hide bitmap images. Right-click to 
set image display options.

Use View > Show Vectors to show and hide vector graphics. Right-click to 
set image display options.

Use View > Dim Artwork to dim graphic backdrops to show stitches more 
clearly for digitizing.

Use View > Show Appliqué Fabric to toggle the appliqué fabric display 
on/off.

Use View > Show Bling to toggle bling display on/off.

Use View > Show Functions to visualize any sequin or beading 
components present in the design.



B E E m b r o i d e r y S t u d i o  |  Q u i c k  S t a r t  G u i d e 93

 Toggle the Show Bitmaps and/or Show Vectors icons to selectively 
view both vector and bitmap images.

 Click Dim Artwork to dim the onscreen image to view stitches more 
clearly when digitizing. The command applies both to bitmap and 
vector graphics.

 To lock an image in place, select and press K.
 Click the Show Appliqué Fabric icon to toggle display of appliqué 

fabric on/off.

View graphic elements,
including product images

Vector graphic together 
with bitmap image
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 Use Show Bling to visualize any bling components present in a 
design.

 Use Show Functions to visualize any sequin components present in 
the design.

 Similarly, beading can be viewed while Show Functions is toggled on.

Appliqué 
fabric On

Appliqué 
fabric Off

Bling components in 
TrueView

Sequins in 
TrueView

Sequins 
turned off
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Tip: Depending on view options set in the Options dialog, images 
display in full color, or dimmed. 

Related topics...

Zoom & pan designs

Zoom tools allow you to magnify your view of the design by zooming in 
on individual stitches or details. The easiest way to zoom is via mouse 
wheel. This defaults to 1.25x increments. Zoom behavior can be modified 
by holding down Alt, Ctrl, and Shift keys while rotating the wheel. 
Settings can be adjusted in the Options > Scroll tab. See also Scroll 
options (Reference Manual).
Zoom tools are also available from the View menu and Zoom toolbar. 
Experiment with the available options.

Beading in 
TrueView

Beading 
turned off

Click Zoom > Zoom to invoke zoom mode. Zoom in or out via left and right 
mouse clicks, or drag a selection marquee to view design detail.

Click Zoom > Zoom 1:1 to display a design at actual size.

Use Zoom > Zoom In/Out 1.25x to zoom in or out for greater or lesser 
detail.

Click Zoom > Zoom to Fit to display the whole design in the design window.

Click Zoom > Zoom to Selected to magnify only selected objects.

Select Zoom > Zoom Factor from the droplist or key in a zoom factor 
and press Enter.
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Use shortcuts keys as indicated in the menus. For instance, to zoom in 
on a section of design, select View > Zoom or press B, and drag a 
marquee around the zoom area. To display the whole design, select View 
> Zoom to Fit or press 0.

 To display stitches at a particular scale, select a zoom scale from the 
droplist or key in a zoom factor and press Enter. Alternatively, select 
View > Zoom Factor (or press F). In the Zoom Factor dialog, enter 

Zoom tools available 
from menu and toolbar

Drag selection marquee 
around area to zoom
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a scale as a fraction of the actual size, where ‘1’ = ‘100%’, ‘1.5’ = 
‘150%’, etc.

 To pan across a design, select View > Pan or press P and use the 
‘grabbing hand’ tool.

Set up multiple views

BE EmbroideryStudio gives you multiple views of the same design. It also 
allows you to switch between open designs by means of design tabs. This 
also makes it easy to copy/paste between designs, including drag and 
drop operations.

To set up multiple views...
 Use the Window menu commands to set up groups of tabs as 

preferred.

Enter scale as
fraction of actual

size

Click and drag to pan 
across design
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 Set up vertical or horizontal tabbed groups.

 To create multiple views of a single window, use the Window > Split 
Window command. Adjust view settings for each pane.

Use commands to 
set up tab groups
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 Use the Remove Tiling command to return the design window to 
normal display mode.

Tip: After certain operations you may need to refresh the screen for a 
clearer display. Select View > Refresh Screen or press R.

Work with the Overview Window

Use the Overview Window to view a thumbnail of the design. Use it to 
pan and zoom the design when working at high zoom factors. Set view 
settings independently to the design window.

Double-click to 
remove split bars

Use Docker > Overview Window to toggle window display on/off. Use it to 
view a thumbnail of the design.
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 To zoom in or out, click the Zoom button at the bottom of the window 
and drag a selection marquee around the area to zoom.

 To pan across the design, click and drag the zoom box.

 To change the view settings for the Overview Window, click it to 
make it the active window.

Click for
zoom box

Drag selection 
marquee around 
area to zoom

Drag zoom box
to pan across

design
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Related topics...
 View embroidery components

Viewing objects & color blocks

BE EmbroideryStudio provides many techniques for selectively hiding or 
viewing embroidery objects or color blocks. 

The Color-Object List offers an easy way to selectively view color blocks 
and embroidery objects. This is useful when re-sequencing. 

View selected objects

BE EmbroideryStudio provides many techniques for hiding or showing 
selected embroidery objects in the design window.

Click inside window to 
change view settings

Use Select > Select to select individual objects as well as groups or ranges 
of objects.

Use Docker > Color-Object List to toggle the Color-Object List display on 
and off. Use to view and sequence objects in a design.
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To view selected objects...
 Select the objects you want to view.

 Press Shift+S. All other objects are hidden. They can be revealed 
again via the Color-Object List popup menu.

 To temporarily hide other objects, select the object you want to view 
and click and hold the Locate button.

Select objects to 
view

Select to unhide
objects

All other objects
hidden
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 To display the selected object full-screen, press Shift+0 (zero).
 To return to the previous view, select View > Previous View or 

press V.
 To re-display the entire design, press Esc followed by Shift+S.
 To redraw the screen, select View > Refresh Screen or press R.
 To toggle options for selective display of embroidery objects, select the 

Options icon in the Standard toolbar, or select Setup > Options > 
View Design tab.

Options include:

Option Function

No change The display remains the same as before.
Show whole 
design

All embroidery objects in the design are visible.

Show selected 
objects

Only objects that are currently selected are visible.

Show unselected 
objects

The reverse of the above option. Only objects that are 
currently ‘unselected’ are visible.

Select object/s to
view

Click and hold to
isolate selected

blocks

Select viewing 
options
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Related topics...
 Selecting objects

View selected color blocks

A color block corresponds to a color stop in the design. It may contain a 
single object or group of like-objects – e.g. ‘ropes’. Or it may be 
comprised of different objects of like-color – e.g. ‘ropes and birds’. The 
Color-Object List offers an easy way to selectively view color blocks and 
embroidery objects. The View by Color function also lets you view 
objects by color. The Colorway Editor provides another method for 
selective viewing of color blocks.

To view selected color blocks...
 Click the Color-Object List icon. The Color-Object List can be 

docked to the either side of the design window, or floated in any 
position.

 Click the switch to view the list by color block.

Hide whole design All embroidery objects in the design are hidden.

Option Function

Use Docker > Color-Object List to toggle the Color-Object List display on 
and off. Use to view and sequence objects in a design.

Use Color > Colorway Editor to assign thread colors to color blocks in the 
design.
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 Select a color block or blocks and click Locate and hold.

 Selectively hide or ‘unhide’ selected color blocks and embroidery 
objects using popup menu commands.

Total color blocks, 
objects and 
stitches in design

Click to toggle
color blocks

Select color 
block/s to view

Click and hold to isolate
selected blocks
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 Alternatively, to isolate a color block in the design window, click and 
hold it in the Color toolbar. First press Esc to deselect all objects.

 Alternatively, select View > View by Color. Select the colors you 
want to view. This function will not work with grouped objects.

Use commands to 
selectively hide or 
show color blocks 
and objects

Click and hold with no 
objects selected
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 Alternatively, click the Colorway Editor. Select a color block and click 
Locate and hold.

 To reveal all hidden objects press Esc followed by press Shift+S or 
select View > View all Colors.

Related topics...
 Selecting objects
 View selected color blocks

Select color 
blocks to view

Select color
block

Click and hold to 
locate selected 
color block
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Viewing stitching sequence

When checking embroidery designs, you will want to understand the 
stitching sequence in order to ensure efficient stitchout on the machine. 
‘Travel’ through designs by color block, embroidery object, or even 
stitch-by-stitch. Alternatively, simulate the stitchout on screen.

Tip: Depending on your design background, you can change display 
colors for unsewn stitches. See Change display colors for details.

Simulate design stitchouts

Stitch Player is an important tool in BE EmbroideryStudio. It lets you 
simulate the actual embroidery design stitchout on screen. Because 
Stitch Player emulates the movements of the embroidery machine, you 
are able to make decisions about how to optimize your design in order to 
lessen the load on the machine. This is important if you intend to make 
multiple stitchouts.

To simulate the design stitchout...
 Choose a design view to visualize your design. Stitch Player can be 

run with or without TrueView™.
 Click Stitch Player or press Shift+R. 

Use View > Stitch Player to simulate embroidery design stitchout on 
screen.

Adjust redraw 
speed

Set starting point

Use video controls to
run stitch player

Set design to pause at 
color changes, stops 
or trims
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 Use the slider bar to move the starting point.
 Use the controls to stitch forwards or backwards through the design. 

Typical ‘media player’ buttons are available for play, pause, rewind 
operations.

 Use the Auto Pause control to set stop points – by color change, stop, 
or trim.

 To redraw a section of design, specify a start and end stitch using the 
tabs.

 Use Auto Scroll when running Stitch Player at high zoom factors.

Tip: Depending on your background, you can change display colors for 
unsewn stitches, selected objects, object outline, grid and guides.

Related topics...
 Change display colors

Travel through designs

It is useful to be able to view the stitching sequence color-by-color, 
object-by-object, or even stitch-by-stitch. The Travel toolbar provides all 
tools required to do so. Travel forwards or backwards with any button by 
right or left mouse-clicks. Traveling can be initiated from any stitch in the 
design. The current needle position is marked by a white cross or ‘needle 

Toggle Auto Scroll to 
view at high zoom 
factors

Set stitch range to redraw section of design
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position marker’. The current stitch number is displayed in the Status 
Bar.

To travel through a design...
 Turn off TrueView™ and press the Esc to ensure no object is 

selected. 

 Travel to the start of the design by clicking the Start/End Design icon 
or pressing the Home key.

 Use the Travel by Stitch functions to travel forwards or backwards 
through the stitching sequence. Use left or right mouse-clicks or arrow 
keys – l or r, t or b. Alternatively, to travel by 1000 stitches, press 
Shift + Num+ or Shift + Num-.

 To travel by color, click/right-click Travel by Color. This is useful if you 
need to locate a specific color change in order to insert an object or 
delete it from the stitching sequence.

 To travel by object, click/right-click Travel by Object. Alternatively, 
press Tab or Shift+Tab. 

 To travel by machine function, click/right-click the Travel by 
Function tool. Alternatively, press Ctrl+Page Up or Ctrl+Page 
Down. The needle point will stop at every jump, trim, and color 
change in the design.

 It is sometimes easier to use Travel by Trim to travel by trim 
functions alone – e.g. when checking for unnecessary trims. 

Use ‘travel’ tools to move 
through every component 
of a design

Travel to previous stitch Travel to next stitch
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Alternatively, press Ctrl + Left Arrow or Ctrl + Right Arrow. Turn 
on Show Connectors and Show Functions to view while traveling.

Tip: While traveling through a design or editing stitches, click the 
Select Current icon or press Shift+0 to select the object associated 
with the current cursor position. 

Related topics...
 View selected color blocks

Select objects while traveling

Traveling is usually associated with checking the stitching sequence. You 
can select objects as you ‘travel’ through a design using the Ctrl key. 

To select objects while traveling...
 Click the Select icon.

Travel by trims with 
connectors and 
functions showing

Click Select > Select together with the Ctrl key to select objects as you 
travel through a design.

Left/right-click Travel > Travel by Object to travel to previous or next object.

Click Select > Select Current to select the object associated with the 
current cursor position.
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 Use the Travel by Object tool or Tab and Shift+Tab buttons to 
travel forwards or backwards by object. See Travel through designs for 
details.

 Click the Select Current icon or press Shift+0 to select the object 
associated with the current cursor position.

 Hold down the Ctrl key to select an object as you travel through it.

Viewing colorways

A ‘colorway’ is a color scheme or palette of thread colors. It may also 
include a background color, fabric sample, or a product image. In 
BE EmbroideryStudio, you can define multiple colorways for the one 
design. This means you can stitch out the same design in different colors 
on different fabrics. You can also print multiple colorways, icons of color 
blocks, and design backgrounds with the production worksheet.

Switch colorways

In BE EmbroideryStudio, you can preview the same design in different 
colors on different fabrics.

Press Shift 
+Tab keys

Press Tab key

Use Color > Current Colorway dropdown to select a new color 
scheme for design.

Use Color > Colorway Editor to assign thread colors to slots in the color 
palette.
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To switch colorways...
 Open a design with multiple colorways.

 Select a colorway from the droplist.

 Alternatively, use the Colorway Editor to toggle between colorways.

Select 
colorway

Select colorway

Double-click to edit 
background or 
product image
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Related topics...
 Change backgrounds

Change backgrounds

BE EmbroideryStudio lets you set the background color, fabric, or product 
of each colorway for more realistic previews and presentations.

To change backgrounds...
1 Open the design and select a colorway. 

2 Use View > Show Product to toggle on or off any product image that 
may be included in the colorway.

Click Color > Background & Display Colors split arrow to change the 
background color of the current colorway.

Use Color > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.

Click View > Show Product to toggle product image on/off. Right-click to 
open the Product Visualizer docker.

Select a 
colorway
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3 Click the droplist next to the Background & Display Colors icon.
 Change color via the Background Color popout menu.

 If your colorway includes a background fabric, change color via the 
Fabric Color popout menu.

4 If your colorway includes an article or product, open the Product 
Visualizer droplist and change color via the Product Color popout 
menu.

Tip: Click Background & Display Colors or Product Visualizer 
icons to preset any of these options.

Change display colors

Click arrow to invoke popup menu

Select background 
color

Change fabric 
colors

Change product
color

Use Color > Background & Display Colors (or Colorway Editor docker) to 
change design background presets for the current colorway.
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In addition to background color or fabric, display colors for borer holes, 
selected and ‘unsewn’ stitches, object outlines and grid are part of the 
colorway definition. Change them if the default display color is not visible 
against the current colorway. The Background & Display Colors dialog 
includes a Display Colors panel.

Adjust colors as required for:

Display item Description

Selected Selected objects or stitches.
Unsewn Unsewn stitches as they appear when traveling through the 

design.
Object outline Object outlines as they appear when Show Outlines is 

activated. See View embroidery components for details.
Needle points Change needle point display color according to current 

background. See also View embroidery components.
Grid Depending on the colorway, you may need to adjust grid 

display colors in order to view them against the background 
color. See also Measurements.

Guides Depending on the colorway, you may need to adjust guide 
display colors in order to view them against the background 
color. See also Measurements.

Borer Borer points. These are machine functions which only appear 
when Show Functions is activated. See View embroidery 
components for details.

Function symbols Symbols such as trims and tie-offs as they appear in stitch 
view. Use in conjunction with the Show Functions toggle. See 
Types of connectors (Reference Manual).

Select preferred 
display color

Function symbols
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Display colors are saved with the colorway. You can save the colorway as 
an EMT template file for use in future designs.

Related topics...
 View embroidery components

Viewing design repeats

Many customers make traditional garments such as sarees which employ 
continuous and sometimes overlapping designs. It is important to be able 
to see these designs together with their repeats. The Show Repeats 
function displays repeating designs, including sequins, in both TrueView 
and stitch view. You can view a design, even while digitizing, with any 
number of repeats. The number can be a whole number or fractional.

Black needle points
against white

background

Use View > Show Repeats to toggle design repeats display. Right-click for 
settings.
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Note: It is important that the artwork you use is properly sized and in 
the correct horizontal position. Always check the position of your artwork 
before starting to digitize. 

To view design repeats...
1 Set your units of measurement as required. 

Note: Stitch length and density controls remain in mm regardless of 
measurement system. These controls reflect the machine functions as 
industrial machines are always in millimeters.

2 The first time you use the feature, right-click the Show Repeats tool 
or press shortcut W to access the Repeats dialog.

3 Select the Show Repeats checkbox to activate the feature.

Vertical
distance,

user-defined

Horizontal distance, user-defined or 
automatically calculated

Enter required number 
of vertical repeats

Enter distance 
between vertical 
repeats

Enter required number of
horizontal repeats

Enter distance
between horizontal

repeats

Select Show Repeats
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4 Set the distance between horizontal repeats. This will always be 
expressed in millimeters. Depending on the template, different 
options are available:

5 Enter the number of horizontal repeats. Repeats are balanced around 
the source design. This means that whole designs are displayed only 
for odd integer (1, 3, 5) numbers of repeats.

 Click OK to apply.

Usage tips...
 Vertical distance is not constrained by needle or head distance. 

Vertical distance will be a function of design height. Set vertical 
distance and number of repeats as preferred.

 To help distinguish the source design from repeat patterns, Use the 
Colors option to display repeats in different colors. Enter a color offset 
to indicate where you want to start the first repeat color. Let’s say you 
have a 4-color design using palette colors 1, 2, 3, 4. If you set color 
offset to 5, repeat colors will display as 5, 6, 7, 8.

 Use the Show Repeats icon to toggle design repeats on or off.

Option Function

Design 
repeat

This option is only available with the Schiffli template. Repeat 
distance is fixed. This is typically a factor – x1, x2, x3, etc – of 
needle distance. See Schiffli Supplement for details.

Other When selected, you need to manually enter a repeat distance in 
mm. This is typically used when doing continuous design work on 
multihead machines. The figure will generally correspond to the 
distance between machine heads – e.g. 135 mm – or factors 
thereof.

Repeat Effect

1.0 The original design only is displayed.
1.2 • The original design is displayed, plus

• 0.1 of the design on either side of the original.
2.0 • The original design is displayed, plus

• 0.5 of the design to either side of the original.
The repeat pattern looks like this: ][][.

2.9 • The original design is displayed, plus
• 0.95 of the design to either side of the original.

3.0 • the original design is displayed, plus
• a complete copy of the design to either side of the original.
The repeat pattern looks like this: [][][].
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Related topics...
 Set measurement units

Viewing design information

You can obtain design information in a variety of ways and formats – 
before opening the EMB file via File Explorer and from the Design 
Information docker. See also Preview design reports.

View design details in BE EmbroideryStudio

You can check design details via the Design Information docker. This 
is always advisable prior to design approval or stitchout. The opening tab 
contains information about design height, width, stitch count, colors, and 
so on. On other tabs, summary and order information may be provided 
by the digitizer or sales team. The information is printed with approval 
sheets and production worksheets. Choose a file and select Design > 
Design Information.

Source
design

Use Docker > Design Information to view and modify design details prior to 
design approval or stitchout.
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View design details in File Explorer

Even without opening EMB files, you can check software version number 
and other design details via File Explorer. This same dialog can be 
accessed from within the Open dialog in BE EmbroideryStudio as well as 
the Design Library.

To view design details in File Explorer...
 In File Explorer, right-click an EMB file and select Properties from 

the popup menu. 
The Properties dialog displays with an EMB tab. View general file 
information, such as file size and modification dates, together with 
design information such as stitch count, number of stops and color 
changes, as well as machine format. 

Use tabs to view other design 
information, including orders 
and machine runtime 
estimates

Provide descriptive 
name as preferred
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 The Custom tab shares information with the Design Information > 
Summary docker in BE EmbroideryStudio. 

Preview design reports

Approval sheets and production worksheets contain all or some of the 
design details contained in the Design Information docker. Approval 
sheets are intended for customers, not production staff. Customers can 
see what they are ordering and approve accordingly. Production 
worksheets are intended for production staff. All production-related 
information, such as bobbin length, design size, garment fabric, etc, is 
provided.

To preview a design report...
 Click the Print Preview icon.

Dedicated EMB
properties tab

Use Custom tab to 
provide additional 
file information

Click Standard > Print Preview to preview the production worksheet on 
screen.
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 To change paper orientation, click Landscape or Portrait. Large 
designs may be displayed over a number of pages.

 To change included information and set printing/plotting preferences, 
click Options. Here you can choose the report type – e.g. Approval 
sheet.

 To print the design, choose an option:

 To close the preview, click Close.

Click Close to return to 
design window

Choose a
print option

Order 
details

Modify report 
options

Option Function

Print Now Send the design report to your local printer.
Save as PDF Save the report as a PDF document. You are prompted to 

save to the hard drive or network location.
Send PDF via 
Email

Send the report – usually an approval sheet – as a PDF 
attachment to your local email client.
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Design Management

Design Library is a design management tool. Use it to browse design 
and artwork files stored on your PC or local network. Design Library 
capabilities make it fast and practical for daily commercial use, avoiding 
the need to switch to and from File Explorer. It recognizes all file 
formats used by BE EmbroideryStudio. It also makes it easy to search, 
sort and browse all embroidery designs on your network.

If you are already familiar with File Explorer, the interface will be quite 
intuitive to you. But there are some differences. Design Library is a 
‘virtual library’ in that any designs on your system can be located and 
displayed within the navigation pane. Any folder containing embroidery 
designs which resides on your hard disk, external storage device, or local 
network can be included in the navigation pane. In a nutshell, 
Design Library lets you:
 Search for designs – including artwork files – anywhere on your local 

hard drive, network drives, or external devices such as USB or ZIP 
drive.

 Search by various means, including summary information such as 
design title, subject, authors, tags, etc. Order information can also be 
associated with any supported design file.

 Preview design information in the preview pane or Design 
Information docker.
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 Create an organizing structure for easy categorization. Add to or 
remove design folders from your ‘virtual library’.

 Record and manage quotes, orders, and approvals.
 Batch-convert selected design files to all commercial embroidery 

formats such as DST, EXP, SEW, and others.
 Print selected designs or send them for stitchout to embroidery 

machine or to folders which machines can access for stitching.
 Use Design Library to handle quotes, orders, and approvals.

Caution: Included artwork (clipart) and embroidery designs can only be 
used for personal use – i.e. they cannot be commercially sold in any form. 
Changing the medium – i.e. clipart to embroidery or embroidery to clipart 
– does not remove copyright protection.

Note: CorelDRAW® needs to be registered before it can be used by 
BE EmbroideryStudio. Registration gives you access to the latest 
CorelDRAW® updates. It also provides CorelDRAW® Standard 
Membership which gives you access to content – clipart, fonts, stock 
photos, templates – via Corel CONNECT.

Design library layout

The Design Library is accessed from the Mode toolbar.

Switch between Design Library 
and Wilcom Workspace
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The library has five main components – toolbars, navigation pane, design 
display area, details pane, and Design Information docker. The 
appearance will differ somewhat depending on your operating system.

Library components are summarized as follows...

Navigation pane

Design display
area

Details pane

View
(Design Library)

Manage Designs

Component Function

Navigation pane The navigation pane in the Design Library is not an exact 
duplicate of your File Explorer folder structure. It is selective in 
that it only contains folders relevant to embroidery design and 
multi-decoration. Select and add any folder on your PC or 
network to view supported file types.

Design display 
area

The design display area shows any designs in selected folders 
corresponding to the filter selected or search criteria entered in 
the View (Design Library) toolbar. 
• Use the toolbar to filter the design display.
• Right-click selected designs to access a popup menu. Use it 

to cut, copy and delete without leaving the software.
• Use it also to zip designs and folders.

Details pane When a design is selected, summary information is displayed in 
the preview pane.

Design 
Information 
docker

Check design details via this docker. This is always advisable 
prior to design approval or stitchout. Summary and order 
information may be provided by the digitizer or sales team. This 
information can be printed with approval sheets and production 
worksheets.

Toolbars
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Viewing designs in network folders

Navigating to design folders with Design Library is similar to browsing 
with File Explorer. Your access to design folders on your local network 
is only limited by access rights determined by your System Administrator. 
View any supported file type residing in design folders. Designs can be 
searched, sorted, grouped, and browsed by customer or order. Click the 
Design Library icon on the Mode toolbar. Design Library opens in its 
own window.

Mode Switch to Wilcom Workspace to digitize and edit embroidery 
designs.

Manage designs Open selected or recent designs, cut, copy and paste them, 
convert them, print them, or output them to any connected 
embroidery machine or data media.

View 
(Design Library)

Search or sort the entire embroidery library or any chosen 
folders on any criteria selected. Find and manage folders 
containing designs.

Component Function

Click Mode > Design Library to open the Design Library window from which 
to search and catalogue designs as well as quotes, orders, and approvals.

Use View > Layout to toggle navigation pane, details pane, and/or preview 
pane display.

Toggle panels
on/off

Navigation
pane
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Design Library is ‘virtual’ in the sense that any designs on your system 
can be located and displayed within the library. This folder acts as a 
container which appears in File Explorer amongst your other Windows 
libraries. 

You can add folders both in File Explorer and in the Design Library 
itself. The initial folder structure is created by your installation. However, 
any folders on your local network which contain embroidery designs or 
artwork can potentially be included and viewed in Design Library.

Tip: Like File Explorer, the Design Library display can be refreshed 
with a simple F5 keypress.

Change design display

Embroidery library
appears amongst
Windows libraries

Navigate folder
structure via

navigation tree or
address bar

Use View > Change View to select thumbnails only, thumbnails with 
stitching details, or summary information only.
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Use the Manage Designs toolbar to control display of the navigation 
pane as well as thumbnail appearance. Use the Change View droplist to 
display designs in the preferred format.

Tip: The Design Library display can be refreshed with a simple F5 
keypress, the same as File Explorer.

View design details

Default detail columns vary by file type and are controlled by 
MS Windows®. Design Library, however, provides additional columns 
for data derived from embroidery files. These may include design status, 
customer, order date, etc. Such details are primarily intended for use with 
EMB but can also apply to other embroidery formats.

Display designs
as icons or lists

Use View > Reset Detail Columns to reset the columns displayed in details 
view to the default layout.
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When viewing design lists in Details view, columns can be arranged in 
any order and with a variety of criteria. Sometimes Windows will reset 
detail columns to Windows defaults, even for EMB files. To return to the 
default layout, simply click the Reset Detail Columns button. 

Group & sort designs

Various mechanisms are available for you to sort and group design 
listings...

The Group and Sort by droplists also provide a convenient mechanism 
for managing orders...

Embroidery
data listed by

default

Click column
headers in list

view

Use droplists and
toggles to sort
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View zipped designs

View designs in zipped folders. The limitation is that the contents of 
zipped folders cannot be viewed as thumbnail images.

Opening designs from Design Library

Embroidery files fall into two broad categories – ‘design files’ and 
‘machine files’. Design files are ones you open and modify in Wilcom 
Workspace. Machine files are generally ones you send to machine for 
production. There is some inter-convertibility between the two formats.

Group and sort by
same or mixed

criteria

Access zipped
folders
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Filter designs

You can filter your embroidery library between file categories – design 
files, machine files, or all.

The Design Library can filter:
 All Wilcom-supported design files: EMB, ART, JAN
 All machine formats such as DST, EXP, JEF, etc.
 All artwork files read by BE EmbroideryStudio, both vector and bitmap

Open design files

Design files, also known as ‘all-in-one’ or ‘outline’ files, are high-level 
formats which contain object outlines, object properties and stitch data. 
When you open a design file in the software, corresponding stitch types, 
digitizing methods and effects are applied. Design files can be scaled, 

Filter designs 
by file type

Use Manage Designs > Open Selected to open design(s) selected in the 
embroidery library.
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transformed and reshaped without affecting stitch density or quality. 
After modification, you can save to any supported file format.

Using the Design Library, you have the option of opening one or more 
selected designs in their own design tabs. Simply select a design or 
designs by holding down Ctrl as you click, and then click Open Selected.

Caution: Be careful not to open too many designs simultaneously. 
Potentially you could select all designs in the library and click Open 
Selected. This operation cannot be stopped and may result in the 
computer running out of memory.

Open machine files

Different embroidery machines speak different languages. Each has its 
own commands for the various machine functions. Machine files, also 
known as ‘stitch files’, are low-level formats for direct use by machines. 
They contain information about the position, length and color of each 
stitch. When they are read into BE EmbroideryStudio, machine files do 
not contain object information such as outlines or stitch types, but 
present the design as a collection of stitch blocks called ‘manual objects’.

Select single or
multiple designs for

opening
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While machine files are generally not suited to modification, the software 
can ‘recognize’ object outlines, stitch types and spacing from stitch data 
with some success. By default, machine files are converted to outlines 
and objects upon opening. These ‘recognized’ designs can be scaled with 
stitches recalculated for the new outlines. Processing is effective for most 
stitch designs but cannot produce the same level of quality as original 
outlines and may not handle some fancy stitches.

Open graphic files

Artwork can be opened in BE EmbroideryStudio in both vector and 
bitmap (raster) formats via Design Library. Samples of both file types 
are installed with BE EmbroideryStudio in the Pictures library shown 
below.

Extended support for CDR files
Design Library provides extended support for Corel CDR files. This 
includes:

Manual objects with no
outlines and manual

stitches only

Filter by 
graphic file
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 Right-click to access Windows operations – Open, Open With – 
directly into CorelDRAW Graphics. Or double-click to open a selected 
CDR file using the default template.

 Drag-and-drop from File Explorer into CorelDRAW Graphics.
 Drag-and-drop into Wilcom Workspace.
 Drag-and-drop into standalone CorelDRAW® Graphics Suite.

Note: For details of supported image file formats, refer to the 
CorelDRAW® Graphics Suite electronic User Guide. This is available via 
the MS Windows® Start > Programs group or the Help menu.

Open new files from existing

Instead of opening the original designs, you can use New from 
Selected. The only difference for practical purposes is that this 
command creates a copy which opens in a new design tab, thus 
preserving the original design file. Left-clicking uses the default template. 
Right-clicking allows you to select a different template from the dialog. 
Selection is remembered and used the next time the command is 
invoked.

Use Manage Designs > New from Selected to create new designs based 
on designs selected in Design Library.

Choose a
template

Activate auto fabrics and
choose a target fabric

Set background 
color and swatch

Choose a target 
machine format

Save as default
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The New from Selected command can also be used to open graphics 
files, including Corel CDR. With CDR, a new file is opened in 
BE EmbroideryStudio before switching to CorelDRAW Graphics.

Tip: If you want to open one design into another, an Import 
Embroidery function is available in Wilcom Workspace. Combine 
designs or design elements into a single design layout.

Outputting selected designs

Send designs to machine for stitching via Connection Manager. Create 
hard copy reports of a selected designs using a printer or plotter. Report 
types may include production worksheets, appliqué patterns, color films, 
as well as catalogs and lists of selected designs.

Convert designs

By default BE EmbroideryStudio saves designs to its native EMB format. 
This contains all information necessary both for stitching a design and for 
later modification. The Design Library conversion function allows you to 
batch-convert to and from all EMB and other supported design file types. 
It also batch-converts many machine file formats such as DST, EXP, SEW. 

To convert designs...
1 Select the file(s) to be converted and click the Convert Selected 

Designs icon. The dialog lists all machine file formats supports by the 
software.

Use Manage Designs > Convert Selected Designs to convert the design 
selected in the embroidery library into different machine file types.

Use View (Design Library) > Exports to view the export status of the current 
session. Conversion to older formats or machine file is performed as a 
background task.
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2 Select the file types you want to convert to.
3 Click Browse to locate a destination folder for the converted designs.
4 Click Convert to start the conversion. The converted designs will be 

stored in the nominated folder.

Tip: The Exports docker automatically opens when a design is 
converted to machine file or saved as an earlier EMB design file. This 
shows you the export status of the current session. Machine file export 
is performed as a background task.

Send designs to machine

BE EmbroideryStudio supports various machine models. Some can be 
connected by cable directly to your PC via USB port. Others require files 
to be placed in a specific network location or ‘watching folder’. Older-style 
machines do not support direct connection but they do read ATA PC cards 

Select machine 
file formats to 
convert

Select target 
folder

Use Manage Designs > Send to Connection Manager to stitch out the 
design selected in Embroidery Library.
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and/or USB memory sticks. Connection Manager provides a method of 
connection to machines that appear as removable media or make use of 
third-party connection software. Once set up in BE EmbroideryStudio, a 
single click is sufficient to send the design to machine.

Note: You can only send one design at a time via Connection Manager.

Print selected designs

You can print worksheets for selected designs, and include thumbnails of 
each in the worksheet. Unlike Print Designs, this option can provide 
design and sewing information.

To print selected designs...
1 Sort the designs to be printed using Sort.
2 Select a design and click the Print Selected icon. The Print Design 

dialog opens.
3 To customize the printout, click Options.

4 Set design report options to include the information you want in the 
format you require.

Use Manage Designs > Print Selected to print designs selected in the 
embroidery library.
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5 The Worksheet type panel provides options for further 
customization. 

6 Click OK and ensure correct printer settings in the MS Windows® 
Print Setup dialog. The dialog and the settings available vary from 
printer to printer. See your printer manual for details.

Option Function

Approval sheet This is intended for the customer, not production staff. 
Customers can see what they are ordering and approve 
accordingly. 

Production 
worksheet

This is intended for production staff. All production-related 
information, such as bobbin length, design size, garment 
fabric, etc, is provided.

Production 
summary

This provides two summary tables of the design and 
associated colorways – a Colorway Summary together with a 
Design Summary. 

Appliqué 
patterns

This shows appliqué patterns – cutter information – isolated 
from the design. These can be used as a guide to cutting out 
fabric pieces. They also show which appliqué pieces are to be 
included.

Color film Provides a list of colors in the design, together with color and 
stitch information for each color layer. This helps the machine 
operator to see each stitch color in order of stitchout.
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TUTORIALS

This section provides fully 
worked sample designs 
demonstrating some of the key 
features of the software. The 
samples assume familiarity 
with basic techniques such as 
zooming and viewing designs.
Download the tutorial files from 
the online help landing page 
and copy to your embroidery 
library.

Tip: For more details, see the 
topics in the Reference Manual 
by clicking the links. Ensure the 
Reference Manual and 
Quick Start Guide are present 
in the same folder.

https://docs.wilcom.com/be-embroiderystudio/27/en/index.htm
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Design Editing

In this worked example we take a ready-made logo and incorporate it 
into a design for stitchout on both polo shirt and cap. The design involves 
some additional lettering. We also need to scale it for stitchout on two 
different fabrics.

This tutorial explains many techniques and procedures you will use time 
and again in your embroidery work. Topics covered include setting up 
projects, importing and scaling designs, assigning and sequencing colors, 
adjusting object properties, and checking connections. Also covered are 
adding lettering, finalizing designs, and adapting designs for other 
purposes.

Note: Download the tutorial files from the online help landing page and 
copy to your embroidery library. To view the sample ‘Mexican 
Peppers.EMB’ file, navigate to the Tutorials > Editing folder.

https://docs.wilcom.com/be-embroiderystudio/27/en/index.htm
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Set up the project

The first step in this and all projects is to specify, optionally, the fabric, 
the machine, and the artwork you want to use. BE EmbroideryStudio 
provides a set of optimized settings to take account of the target fabric. 
It also allows you to select from a wide range of standard 
factory-supplied hoops.

Choose fabric, backdrop and machine format

Open BE EmbroideryStudio from the desktop icon or Windows Start 
menu. From the Home screen, click New from Template or, holding 
down the Shift key, click New Design. Here we choose ‘Jersey’. Select 
a suitable machine format – e.g. Brother – and click OK.

Copy tutorial files 
to your embroidery 
library

Use Standard > New Design to start a blank design based on the currently 
selected template. Hold down Shift and click to open New from Template 
dialog.

Use Color > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.
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Open the Product Visualizer and choose a product backdrop – in this 
case, Polos > Mens > Short Sleeves. 

From the Settings tab, adjust article size and set the color to black. 
Optionally, use the ‘smart tape’ to measure shoulder width and set size 
to suit.

Activate auto fabrics 
and choose a target 
fabric

Set background 
color or swatch

Choose a target 
machine format

Select article

Set article size
and color



   D e s i g n  E d i t i n g 144

Related topics...
 Create designs from templates
 Fabric & product backgrounds (Reference Manual)
 Visualize products (Reference Manual)

Set up hoop list

BE EmbroideryStudio lets you select from a wide range of 
factory-supplied hoops. Configure the My Hoops list to include your 
available hoops. The list can contain commercial brands as well as 
custom-defined hoops. Set up your hoop list via Setup > My Hoops. 

Adjust 
article size

Adjust 
article color

Click Hoop > Show Hoop to turn hoop display on or off. Right-click to 
change hoop settings.
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Related topics...
 Hoop lists (Reference Manual)
 Custom hoops (Reference Manual)

Import & scale the design

For the purposes of this sample we use a prepared design. In the ‘real 
world’, this might be supplied by a client or outsourced to a third-party 
supplier. Depending on digitizing quality, you may need to adjust for 
smooth stitchout.

Import embroidery

Choose your 
hoops

Click Standard > Import Embroidery to import embroidery design file into 
current design.
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Import the embroidery file from your local drive with the Import 
Embroidery command. You’ll find it on the Standard toolbar or File 
menu. To view the sample ‘Mexican Peppers.EMB’ file, navigate to the 
Tutorials > Editing folder.

Tip: If BE EmbroideryStudio detects that a fabric already applies, it will 
update design settings according to the current fabric. Otherwise, it will 
leave the settings alone. To make sure that the correct fabric applies, 
select the whole design – Ctrl+A – and go to Design > Auto Fabric.

Related topics...
 Insert designs (Reference Manual)

Measure & scale the design

In this example, we are creating a left chest design. Maximum size should 
be approximately 4.25" or 108 mm square, including lettering. Select all 
objects – Ctrl+A – and check the Property Bar. Ensuring the aspect 
ratio is locked, set the width to about 65 mm.

Insert project
file

Navigate to the
Editing folder
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Note: The first time you run BE EmbroideryStudio, the measurement 
system will default to whatever the operating system is using. However, 
you can change measurement units from within BE EmbroideryStudio. 

Related topics...
 Measurements

Assign & sequence colors

First we need to set up the color palette with threads we intend to use for 
stitchout. At the same time, we sequence colors to minimize changes on 
the machine.

Assign thread colors

Our imported design contains five colors. Currently they are not assigned 
to actual threads. Our first task is to assign the threads we intend to use. 
Click Remove Unused Colors in the Color toolbar. Open the Threads 
docker. Here we choose ‘Royal’ as the thread chart. Assign threads to 

Aspect ratio 
locked

Change width 
to 65 mm

Use Color > Remove Unused Colors to remove all unused colors from the 
color palette.

Use Color > Threads to search for and match threads from different charts, 
and assign for use.

Use Threads > Assign Thread to assign selected thread to the highlighted 
color in the current colorway.

Use Threads > Match All to match threads from the current chart/s to all 
color slots in the current colorway.
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color slots automatically using the Assign Thread or Match All buttons. 
Or scroll through the list to choose preferred thread colors. 

Related topics...
 Assign thread colors (Reference Manual)

Resequence colors & objects

Now we look at color sequencing because we want to minimize changes 
on the machine. The Color-Object List provides an easy way to select 
objects and access their properties. Notice that colors in this design are 
stitched twice, in the same order objects were digitized. We use the 
Color-Object List to resequence color blocks and objects within the list. 

Click ‘Remove
Unused Colors’

Click to assign color 
to selected color slot

Select thread 
chart/s to use

Click to select
thread chart/s

Use Docker > Color-Object List to resequence objects.
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Related topics...
 Sequence with the Color-Object List (Reference Manual)

Adjust object settings

Now we look at objects in the design a little more closely in order to check 
and optimize their settings.

Adjust stitch type & angles

Because we’ve scaled down the design, we can change the fill to satin 
stitch for a nicer finish. To hide the outlines, right-click in the 
Color-Object List and select Hide from the popup menu.

Drag and drop to 
minimize color 
changes

Use Select > Select to select individual objects as well as groups or ranges 
of objects.

Use Docker > Color-Object List to toggle the Color-Object List display on 
and off. Use to view and sequence objects in a design.

Use Fills > Satin to apply satin stitch to new or selected narrow columns 
and shapes. Right-click for settings.

Use Reshape Tools > Reshape to reshape selected objects, edit stitch 
angles, and adjust entry/exit points.

Use Reshape Views > Show Stitch Angles to toggle on/off stitch angles for 
selected objects.
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Holding down the Ctrl key, select the four chillies and click the Satin 
icon. Then, with the aid of the Reshape tool, adjust stitch angles for nice, 
even turning stitches.

Related topics...
 Adjusting stitch angles (Reference Manual)

Adjust satin settings

Hide outlines

Change to
Satin fill

Adjust stitch 
angles

Use Docker > Object Properties to set properties of selected objects.
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Whenever you apply satin fill to a shape, Auto split is on by default. 
Where satin stitches become too long, they are split. Too many splits can 
spoil the effect. Try adjusting auto-split length – e.g. 8 mm – to achieve 
a glossier look.

Related topics...
 Split satin stitches (Reference Manual)

Check underlay & pull compensation

For an object to sew out correctly, it must have correct stitch spacing, 
sufficient pull compensation and a suitable underlay. Select all peppers 
and open Object Properties. Check both Pull Comp and Underlay 
tabs. Give the peppers an edge run underlay combined with, say, zigzag. 
Pull compensation should be set to about 0.2 mm according to fabric 
settings.

Use Reshape Tools > Reshape to reshape selected objects, edit stitch 
angles, and adjust entry/exit points.

Adjust Auto
split length

Use Docker > Object Properties to set properties of selected objects.
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Related topics...
 Stabilizing with underlays (Reference Manual)
 Pull compensation (Reference Manual)

Check object overlaps

First we do a little forensic work to check object overlaps. Adjoining 
objects need to include a few millimeters of overlap in addition to pull 
compensation. This ties objects together and prevents gaps from 
forming.

Combined edge run
and zigzag underlay

Check pull
compensation settings

Check underlay
settings

Use Docker > Color-Object List to toggle the Color-Object List display on 
and off. Use to view and sequence objects in a design.

Use Reshape Tools > Reshape to reshape selected objects, edit stitch 
angles, and adjust entry/exit points.

Use Reshape Views > Show Reshape Nodes to toggle on/off reshape 
nodes for selected objects.
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Select the first object in the Color-Object List and click the Reshape 
tool. Toggle on Reshape Nodes and toggle off other control points. Now 
use Tab and Shift+Tab keys to cycle through the objects. Study outlines 
where they overlap. Reshape where necessary. For instance, the stem of 
the red chilli does not have sufficient overlap. With Reshape, we create 
a little more overlap all around.

Related topics...
 Reshaping objects (Reference Manual)

Check connections

It’s important to check connections between objects to make sure they 
will stitch out in the most efficient way, without unnecessary trims, and 
without leaving connecting stitches exposed. At the same time, you want 
to ensure than no unsightly gaps appear in the final embroidery.

Connect same-color objects

Drag control
points to

enlarge overlap Overlap 
created

Use Docker > Color-Object List to toggle the Color-Object List display on 
and off. Use to view and sequence objects in a design.

Left/right-click Travel > Travel by Trim to travel to previous or next trim 
function.

Click View > Show Connectors to show or hide the connectors.

Click View > Show Functions to show or hide the function symbols.
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Where objects are separated by too large a gap, trims and tie-offs 
appear. Where consecutive objects share the same color, you can join 
them with a ‘travel run’ for more efficient stitchout. Click Show 
Connectors to toggle on connecting stitches. Here we see a trim 
between consecutive objects. This can be turned into a travel run which 
will be hidden beneath the outline.

Select the preceding object and apply Run type ‘after object’ in the 
Object Properties > Connectors tab. 

Tip: Use the Travel by Trim tool to jump between trims for easy 
inspection.

Related topics...
 Viewing objects & color blocks
 Viewing stitching sequence
 Embroidery Connectors (Reference Manual)

Check for visible connectors

Select object

Trim

Choose ‘After 
Object’

Choose ‘Run’

Run created

Use Reshape Tools > Reshape to reshape selected objects, edit stitch 
angles, and adjust entry/exit points.

Use Reshape Views > Show Entry/Exit Points to toggle on/off entry/exit 
points for selected objects – respectively, green diamond and red cross 
markers.
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Unhide outlines and check for visible travel runs. We may be able to 
conceal these by adjusting entry and exit points.

Select an object and click the Reshape tool. In the Reshape Views 
toolbar, toggle on entry/exit points and toggle off other control points.

Adjust entry and exit points to hide travel runs beneath outline stitching.

Tip: The Closest Join feature automatically connects consecutive 
objects by finding the nearest points, so you don’t have to worry about 
where to start or end. But sometimes the closest join may not always be 
the best solution when hiding travel runs beneath cover stitches.

Visible connectors
– exit points need

adjusting

Relocate end point to
create closer join

Connectors will be 
hidden beneath 
outline stitching
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Related topics...
 Adjust entry/exit points (Reference Manual)
 Apply closest join (Reference Manual)

Add the lettering

Now we add lettering to the logo – the words ‘Cuatro Hermanos’, meaning 
‘four brothers’ in Spanish, and below, the words ‘Mexican Taqueria’.

Add color
 

First we add a lettering color. Click the Add Color icon and assign a 
yellow thread – e.g. Yellow Gold – to the new slot.

Related topics...
 Assign thread colors (Reference Manual)

Add large lettering

Use Color > Add Color to add a new color slot to the color palette.

Use Color > Threads to search for and match threads from different charts, 
and assign for use.

Color slot added and
thread assigned

Click to
assign

Use Toolbox > Lettering to add lettering directly on screen.
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Choosing the newly added color, we create the text ‘CUATRO HERMANOS’ 
using TrueType font – e.g. ‘Lucida Handwriting’ – with an ‘Arc CW’ 
baseline. Adjust width to 85%. Digitize the arc. The TrueType letters are 
directly converted to embroidery lettering. 

Tip: You can use the TTF Conversion button to convert an entire TTF 
font for use as an embroidery font. 

Related topics...
 Convert letters on-the-fly (Reference Manual)
 Convert TrueType fonts (Reference Manual)

Add small lettering

For the words ‘MEXICAN TAQUERIA’, we choose embroidery font ‘Small 
Block2’ and set the height to 5 mm. Choose ‘Free Line’ baseline.

Use Reshape Tools > Reshape to reshape selected objects, edit stitch 
angles, and adjust entry/exit points.

Select TT 
font

Choose 
‘Arc CW’

Adjust 
width
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Related topics...
 Creating embroidery lettering (Reference Manual)

Adjust individual letters

Now we fine-tune the letter ‘C’ for a more personalized look. We scale the 
‘C’ and adjust its position with the Reshape tool. Rotate the letter to fit. 
Adjust spacing between letters by dragging the diamond control point. 

Remove overlaps by adjusting control points.

Choose ‘Small 
Block2’

Choose ‘Free 
Line’

Set to 5 mm

Use Reshape Tools > Reshape to reshape selected objects, edit stitch 
angles, and adjust entry/exit points.

Letter scaled 
and rotate

Use diamond control 
point to position letter
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Fine-tune letter kerning along the baseline. Move each by dragging the 
diamond control point. Hold down Ctrl to move letters freely. 

Related topics...
 Adjusting individual letters (Reference Manual)
 Reposition letters (Reference Manual)

Finalize the design

Our design is complete. All that remains are a few adjustments and a 
preview of the final stitchout.

Adjust overlaps

Fine-tune letter 
positioning
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Check stitching sequence

Do a final check of the stitching sequence. If necessary, use the Travel 
tools to study the trim sequence again. Use Stitch Player to simulate 
the stitchout. 

Related topics...
 Simulate design stitchouts

Visualize finished product

Turn on Show Product to see the product you have chosen. Check the 
whole appearance by clicking the Zoom to Product icon. 

Use View > Stitch Player to simulate embroidery design stitchout on 
screen.

Click View > Show Product to toggle product image on/off. Right-click to 
open the Product Visualizer docker.

Use Zoom > Zoom to Product to view the entire product in the design 
window.
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Related topics...
 Visualize products (Reference Manual)

Set start & end points for whole design

It’s easy to forget, but you should always set a design start and end point 
prior to stitchout. Access the dialog by right-clicking the Auto Start & 
End icon or via Design > Auto Start & End. Adjust settings as needed.

Use View > Auto Start & End to toggle the Auto Start and End function 
on/off according to the current settings. Right-click to adjust settings.

Design set to start
and end here

Set auto start / 
end point
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Related topics...
 Start & end points (Reference Manual)

Select hoop

We have already added hoops to our My Hoops list. Click Auto Hoop to 
auto-select a suitable hoop for the design. Or choose your preferred hoop 
from the droplist. Use Zoom to Hoop to check. 

Related topics...
 Design Hooping (Reference Manual)

Create production worksheet

Open the Print Options dialog. Click Options to select the items to 
include on your worksheet, including the hoop.

Click Hoop > Auto Hoop to prompt the system to select a suitable hoop 
automatically.

Click Zoom > Zoom To Hoop to view entire hoop in the design window. 

Choose hoop to 
comfortably 
accomodate 
design

Click Standard > Print Preview to preview the production worksheet on 
screen.
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Tip: Compare your design with the ‘Editing - Mexican Taqueria - 
Chest.EMB’ sample design in the Tutorials > Editing folder.

Related topics...
 Print reports (Reference Manual)

Create the cap design

Part of our brief involves adapting the design for stitchout on a cap. This 
means re-sizing and changing the target fabric. Because of the way caps 
are stitched, it also means adjusting letter stitch sequencing.

Save design & change fabrics

Save a copy of the design for caps. Here we call it ‘Mexican Taqueria - 
Cap.EMB’. Change the fabric type via Design > Auto Fabric. Choose 
‘Pure Cotton’. 

Select items to 
include

Use Standard > Save Design to save the current design. Right-click to open 
the Save As dialog.
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Related topics...
 Working with fabrics (Reference Manual)

Resize design

Resize the design to fit the front of a cap. Select all objects and set the 
height to 55 mm in the Property Bar. Make sure the aspect ratio is 
locked.
 

Related topics...
 Scaling objects (Reference Manual)

Change letter stitching sequence

You can specify the sequence in which letters are stitched in order to 
minimize registration problems on caps or difficult fabrics. For example, 
the Center-out option is especially useful when stitching on caps. 
Double-click the lettering objects to access Object Properties. Click the 
Sequence button. In the Letter Sequence dialog, choose the 
Center-out option with the Closest Join stitch method. 

Choose pure 
cotton

Change height 
to 55 mm

Aspect ratio 
locked



B E E m b r o i d e r y S t u d i o  |  Q u i c k  S t a r t  G u i d e 165

Related topics...
 Adjust letter sequencing (Reference Manual)

Visualize finished product

Open the Product Visualizer. This time, we choose a cap as our product 
backdrop. Select black. Scale to fit – e.g. 120%. Check the appearance 
using Zoom to Product.

Click Sequence

Choose ‘Closest join’Choose ‘Center-out’

Use Color > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.

Click View > Show Product to toggle current product display. Right-click for 
Product Visualizer settings.

Use Zoom > Zoom to Product to view the entire product in the design 
window.
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Related topics...
 Visualize products (Reference Manual)

Set the start point for the cap

Having set the letter sequence to sew from the center out, we need the 
design to start at the center. In order to align the cap on the machine, 
set the start and end point to the lower-center, as shown. Align the 
needle on the machine where the needle position marker (white cross) 
appears.

Choose cap

Choose 
‘Headwear’

Use View > Auto Start & End to toggle the Auto Start & End function on/off 
according to the current settings. Right-click to adjust settings.
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Related topics...
 Start & end points (Reference Manual)

Create worksheet

Again use Auto Hoop to select a suitable hoop. Optionally, create a 
worksheet for your cap design.

Design set to start 
and end here

Set auto start / 
end point

Click Hoop > Auto Hoop to prompt the system to select a suitable hoop 
automatically.

Click Zoom > Zoom To Hoop to view entire hoop in the design window. 

Click Standard > Print Preview to preview the production worksheet on 
screen.
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Tip: Compare your design with the ‘Editing - Mexican Taqueria - 
Cap.EMB’ sample design in the Tutorials > Editing folder.

Related topics...
 Design Hooping (Reference Manual)
 Print reports (Reference Manual)
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Mixed Decoration

In this worked example, we explore the support BE EmbroideryStudio 
provides for mixed decoration. Here we combine three decoration types 
– digital print, embroidery, and bling – to create a mixed or 
‘multi-decoration’ design. It will be applied to the front of a black T-shirt 
intended for attendees at a dance conference in New York. 

This design is to be printed on digital printer, stitched on embroidery 
machine, and to have bling applied as a final step. Printed and sewn 
sections of the design need to be perfectly aligned.

Note: Download the tutorial files from the online help landing page and 
copy to your embroidery library. To view the sample 
‘Dance_Conference_T-Shirt.EMB’ file, navigate to the Tutorials > 
Mixed-Decoration folder.

https://docs.wilcom.com/be-embroiderystudio/27/en/index.htm
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Set up the project

The first step in this and all projects is to specify the fabric, machine, and 
artwork you wish to use. BE EmbroideryStudio provides optimized 
settings the software will use to adjust for the type of fabric you are 
stitching on.

To set up the project...
1 Open BE EmbroideryStudio from the desktop icon or Windows Start 

menu. From the Home screen, click New from Template or, holding 
down the Shift key, click New Design.

Copy tutorial files 
to your embroidery 
library

Use Standard > New to start a blank design based on the currently selected 
template. Hold down Shift and click to open New from Template dialog.

Use Color > Product Visualizer to choose a garment or product backdrop 
on which to position your decoration.
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2 From the list, choose ‘Jersey’ for the fabric.
3 Select a suitable machine format – e.g. Brother – and click OK.

Predefined settings for the selected fabric will apply to all embroidery 
objects created in the design. The selected fabric is displayed in the 
Status Bar.

4 Open the Product Visualizer and choose ‘T-Shirts > Mens > T-Shirt 
short sleeves (front)’. From the Settings tab, set the color to black. 

Activate auto fabrics 
and choose a target 
fabric

Set background color 
and swatch

Choose a target 
machine format
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5 We want to start building this project in the CorelDRAW® 
Graphics Suite graphics suite so we choose CorelDRAW Graphics.

Related topics...
 Operating modes
 Create designs from templates
 Fabric & product backgrounds (Reference Manual)
 Visualize products (Reference Manual)

Select article

Set article size 
and color

Switch between 
operating modes
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Import & place design elements

Once we’ve switched to CorelDRAW Graphics, we start building our 
design by importing original artwork provided by the client.

To import and place the design elements...
1 Select Import from the Standard toolbar or File menu.

2 Navigate to the Tutorials > Mixed-Decoration folder.
3 Select the ‘Dance_Conference_Artwork.EPS’ file and click Import. 

Since the artwork is provided as an EPS file, you are prompted to 
import text as pure text or as vector curves.

4 Choose ‘Curves’ and click OK.
5 Press Enter to center the imported artwork on screen.

Click Standard > Import Embroidery to import embroidery design file into 
current design.

Select artwork
to import

Navigate to the
Mixed-Decoration

folder

Import text as
curves
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6 Check the size of the artwork in the Object(s) Size fields in the 
Graphics Property bar. It should approximate 256 x 414 mm.

Convert text to embroidery

We’re now ready to convert the artwork text to embroidery. Since we are 
treating the lettering as ‘curves’ rather than ‘text’, we will be converting 
to normal embroidery rather than lettering objects.

To convert design to embroidery...
1 Ungroup the artwork.

Note size of 
artwork

Use Mode > Convert Graphics to Embroidery to convert selected graphics 
to embroidery and switch to Wilcom Workspace.

Use Mode > Tag Fill as Turning Satin to tag narrow shapes for conversion 
to turning stitching. 

Use View > Show Vectors to show and hide vector graphics. Right-click to 
set image display options.

Click View > Show Product to toggle product image on/off. Right-click to 
open the Product Visualizer docker.

Click Zoom > Zoom to invoke zoom mode – zoom in or out via left and right 
mouse clicks.
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2 Holding down the Shift key, select the letters of the word ‘DANCE’ on 
screen. Alternatively, holding down the Ctrl key, select the curves in 
the Object Manager.

3 Toggle on Tag Fill as Turning Satin and click Convert Graphics to 
Embroidery.
BE EmbroideryStudio switches to Embroidery mode and 
automatically converts all selected objects to embroidery. 

4 Toggle off Show Vectors and Show Product, and zoom in for a 
closer look. 

Ungroup objects

Hold down Ctrl key and click
to select multiple items
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Tip: The stitch quality of direct conversion is generally good. You can 
use the Reshape tool to fine-tune overlaps – e.g. on the letter ‘D’.

5 Optionally, select all objects and turn off Auto split in Object 
Properties.

Related topics...
 Zoom & pan designs
 Convert objects with CorelDRAW Graphics (Reference Manual)

Add text to design

We add the rest of the text using a native embroidery font.

To add text to the design...
1 Toggle on Show Vectors. 
2 In the Color-Object List select the artwork icon, right-click, and 

select Lock or press K.

Fine-tune overlap

Auto split off

Use View > Show Vectors to show and hide vector graphics. Right-click to 
set image display options.

Use Toolbox > Lettering to add lettering directly on screen.

Use Reshape Tools > Reshape to reshape selected objects, edit stitch 
angles, and adjust entry/exit points.
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3 Select white from the color palette. 
4 Right-click the Lettering icon. The Object Properties > Special > 

Lettering dialog opens. 

5 Type ‘CONFERENCE NEW YORK’ in the text entry panel. 
6 Select Lazer from the dropdown list and set Height to 6mm. 
7 Click Create Text and click within the design window to create the 

text on screen.
8 Drag text into position.

Lock artwork in 
position

Enter text 
here

Choose ‘Lazer’ 
alphabet

Set height to 
6mm

Click to create text
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9 Use the Reshape tool to adjust lettering size, spacing, and kerning to 
match the artwork. 

Related topics...
 Create lettering with object properties (Reference Manual)
 Reposition letters (Reference Manual)

Convert outlines to bling

In this step, we convert our dancing figure outline using the Bling tool. 
This tool allows you to create input to two bling processes: hot-fix 
template production or direct-to-garment. 

To convert outlines to bling...
1 Click Bling Palette Editor.
2 Choose a round ss12 bling style.

3 Choose a grayish color from the droplist and click OK. This will 
represent the transparent ‘crystals’ we will be using during production.

4 Locate the dance figure outline in the Color-Object List, right-click 
and unlock.

Adjust text to match 
original artwork

Use Bling > Bling Palette Editor to select bling shapes from a library.

Use Bling > Bling Run Auto to create a string of rhinestones along a 
digitized line according to current settings.

Choose ss12
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5 Right-click the object in the design window, and select Convert > 
Convert to Bling Run. Alternatively, click the Bling Run Auto icon 
on the Bling toolbar.

6 Double-click the bling object to check its properties. Note that the 
bling count is 89. Note too that spacing is set to 1.0mm by default. 
This is the minimum necessary for template cutting machines.

Related topics...
 Bling Digitizing (Reference Manual)

Visualize finished product

Convert to
bling run

Bling count

Bling spacing

Click View > Show Product to toggle product image on/off. Right-click to 
open the Product Visualizer docker.
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BE EmbroideryStudio lets you to choose a garment or product template 
on which to position your decoration. This assists in displaying location, 
size and overall appearance, for visualization of concepts and approval 
purposes.

To visualize the finished product...
1 In the Color-Object List, select the black background, frame, vectors 

comprising ‘DANCE’ and ‘CONFERENCE NEW YORK’, and delete them. 
Only the ribbon and dance figure remain.

2 Toggle on Show Product.
3 Press Ctrl+0 to zoom to product. The product image is centered in the 

design window at the selected scale. 

Select unwanted 
vector objects
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4 Select all objects and adjust their position over the product image.

Align embroidery & digital print

To ensure you get perfect alignment between embroidery and digital 
print, you need to tell BE EmbroideryStudio where to start sewing the 
embroidery part of the design. To do this, we choose a reference point on 
the print design which the embroidery machinist can use when aligning 
the needle. 

To align embroidery and digital print...
1 Right-click Auto Start & End.

Use View > Auto Start & End to toggle the Auto Start & End function on/off 
according to the current settings. Right-click to adjust settings.

Use View > TrueView™ to change between normal view and TrueView™.

Use View > Stitch Player to simulate embroidery design stitchout on 
screen.
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2 Choose Digitize start position and Return to start and click OK. 
BE EmbroideryStudio prompts you to click the point on screen where 
you want the design to start and finish.

3 Click the intersection of the ribbon. This manually sets the start and 
end point of the embroidery. During stitchout, the needle starts and 
ends at this point.

Related topics...
 Start & end points (Reference Manual)

Check stitching sequence

Return to 
digitized start 
point

Choose to
digitize start point

Click to set start and 
end at intersection 
of ribbon

Use View > Stitch Player to simulate embroidery design stitchout on 
screen.
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For production purposes, it’s always a good idea to check stitching 
sequence, and adjust entry and exit points for a smooth stitchout.

To check the stitching sequence...
1 Turn off TrueView™ and check the start and end points by traveling 

through using the Travel functions or Stitch Player tool. 

2 In the Color-Object List, select embroidery objects and hide 
everything else. Notice that the ‘DANCE’ stitching sequence starts with 
the letter ‘N’. Embroidery objects are created in the same sequence as 
the graphics file. This is not necessarily the best stitching order.

3 Click and drag the lettering objects into the stitching sequence. 
Because we have set the start point at the intersection of the ribbon, 
the nearest letter is ‘E’. So we will sequence backwards from ‘E’ to ‘D’ 
and finish with the ‘CONFERENCE NEW YORK’ lettering. 

Left/right-click Travel > Travel by Trim to travel to previous or next trim 
function.

Use Arrange > Apply Closest Join to (re-)apply closest join to objects after 
editing.

Check stitching 
sequence

Click and drag 
objects into correct 
stitching sequence
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4 Travel through the design again or run Stitch Player. You may notice 
some unnecessary travels between letters. This is because, following 
resequencing, entry/exit points of each object are no longer optimally 
placed.

5 Select all embroidery objects and click Apply Closest Join on the 
Arrange toolbar. 

6 Travel once more through the design or run Stitch Player to verify the 
stitching sequence.

Related topics...
 Viewing stitching sequence
 Sequencing embroidery objects (Reference Manual)
 Minimizing connectors (Reference Manual)

Send design to production

We now use the Export Multi-Decoration Files capability to export the 
file formats used in our multi-decoration design. The system recognizes 
whether a design element is embroidery, graphic, appliqué, or bling. It 

Objects resequenced 
for efficient stitchout
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displays each in an export dialog with a list of corresponding file types to 
choose from. 

To send the design to production...
1 Select File > Export Multi-Decoration Files.

2 Select Export Current Design and adjust options to suit:
 Select ‘PNG’ for digital print. The gradient effect is hard to achieve 

with screen print. The preset resolution is set to 300 DPI with a 
transparent background.

 For bling, you can choose AI format for semi-automatic machines. 
For any other cutting machines, you can save directly to CDR 
format.

 For embroidery, choose for example, ‘DST’. This is a popular stitch 
file format which can be read by Tajima style machines.

3 Choose the Export to option and specify a location – e.g. USB stick. 
All files will be output to that location.

Tip: For larger production environments, you may want to set specific 
network locations for each file type. You do this via the Locations 
button. 

4 Click the Export button to execute the multi-decoration file export. 
The system writes the selected multi-decoration components to the 
selected location/s.

Set export 
options
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5 Optionally, print out a production worksheet. You may choose to 
display the background product for positioning purposes. 

Tip: Compare your design with the ‘Dance_Conference_T-Shirt.EMB’ 
sample design in the Tutorials > Mixed-Decoration folder.

Related topics...
 Multi-Decoration Output (Reference Manual)
 Set export locations (Reference Manual)
 Customizing design reports (Reference Manual)
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QUICK REFERENCE

The BE EmbroideryStudio 
design window contains the 
pulldown menus and toolbars 
described in the following 
section. Some commands are 
available both as toolbar 
buttons and menu items. 
Some are exclusive to either 
category. The most commonly 
used commands are available 
as ‘keyboard shortcuts’. This 
section contains a complete 
summary of all commands 
available in the software. 

Tip: Standard MS Windows® 
Alt key shortcuts also apply. Use the Alt key with the letter underlined in 
the menu. To cancel an operation, press Esc twice.
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Menus & Toolbars

There are two fundamental design modes in 
BE EmbroideryStudio:

Wilcom Workspace
This mode allows you to create and edit 
embroidery objects using the embroidery 
digitizing toolset.

CorelDRAW Graphics
This mode allows you to create and edit 
vector objects using the CorelDRAW® 
Graphics Suite toolset. For a detailed 
description of the CorelDRAW Graphics 

interface, refer to the electronic User Guide 
available via the MS Windows® Start > 
Programs group. Alternatively, use the 
online help available from the Help menu.

BE EmbroideryStudio menus

The BE EmbroideryStudio design window 
menu bar contains the pulldown menus 

described below. Some commands are also 
available as toolbar buttons.

Menu bar

Status / Prompt bars

Mode tools

Standard tools

Object properties
docker

Color tools

Docker tabs

Design window

View tools

Toolbox
‘Floating’ toolbar

Stitch Effects tools

Stitch Types tools

Graphic style and
traditional input

methods

Design tabs
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Tip: Standard MS Windows® Alt key 
shortcuts apply. Use the Alt key with the 
letter underlined in the menu. To cancel an 
operation, press Esc twice.

File menu

New design Create new blank design based 
on a fabric or template.

New from 
template

Create new design from a 
template. 

Open design Open existing design. 

Open recent Most recently used files listed – 
select to open file.

Open backup 
design

Opens directly onto the backup 
folder for quick access to backup 
files in case of software failure.

Close Close current design window.

Close all Close all open design windows.

Save Save current design.

Save as Save current design with a 
different name, location or 
design file format.

Save as 
template

Save current design as a design 
template for future use.

Save as 
monogram 
template design

Save current design as a 
monogram template for future 
use with the Monogramming 
tool.

Save as 
teamname 
template design

Save current design as a 
teamname template for future 
use with the Team Names tool.

Export machine 
file

Convert current design to a 
machine format other than your 
selected machine.

Print Print the current design.

Print preview Show production worksheet / 
approval sheet. Print from 
preview window.

Import 
embroidery

Insert one design into another to 
create combined design. Color 
palettes are also combined. 
Colors with same RGB values 
are automatically identified as 
having the same thread color.

Import graphic Import artwork into current 
design as a backdrop for manual 
or automatic digitizing.

Scan graphic Scan images directly into 
BE EmbroideryStudio.

Export design 
as vector

Save design as vectors in EMF 
or WMF format.

Export 
multi-decoration 
files

Export mixed decoration design 
components as file formats for 
use by control software or 
machine.

Capture design 
bitmap

Save design image as bitmap 
exactly as it appears on screen.

Capture virtual 
decoration 
bitmap

Output high resolution digital 
print TrueView for ‘virtual 
embroidery’.

Send via email Send design as email 
attachment.

Export design 
properties

Output current design 
information and machine runtime 
settings to CSV file.

Send to 
Connection 
Manager

Connect to supported machines 
via proprietary machine 
software.

Send to 
Embroidery 
Connect

Send current design to named 
EmbroideryConnect device.

Queue design Send current design to 
EmbroideryConnect design 
queue to be ‘pulled’ from 
machine.

Send to 
appliqué cutter

Send appliqué shapes from 
design file to laser cutter.
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Edit menu

View menu

Send to bling 
cutter

Send vectors for any bling in a 
multi-decoration design to a 
supported cutting machine. 
Configure the machine via 
Setup.

Cross stitch Access Cross Stitch application.

Sign out and exit Exit BE EmbroideryStudio and 
sign out of Wilcom account.

Exit Close all open designs and exit 
BE EmbroideryStudio.

Undo Undo previous action.

Redo Redo previously undone action.

Cut Cut selection and place on 
Clipboard.

Copy Copy selection and place on 
Clipboard.

Paste Paste contents of Clipboard. 
Options available in Options > Edit 
tab.

Paste after 
selected

Override current defaults and 
paste directly after selected object 
in the stitching sequence.

Paste special 
>

Override current Paste setting and 
select from paste options available 
in Options > Edit tab.

Duplicate Duplicate selected objects within 
the design (rather than copy to 
clipboard).

Duplicate with 
offset

Duplicate an object with an offset. 
Adjust settings via the Options > 
Edit dialog.

Delete Delete selected objects.

Select / 
deselect all

Select or deselect all objects in a 
design.

Select by 
color / stitch 
type

Select all objects of the same color 
or same stitch type.

Close curve 
with straight 
line / curve 
line

Close an open outline with a 
straight or a curved line.

Reverse > Reverse stitch direction to control 
push-pull effect – affects Jagged 
Edge, Contour Stitch and E Stitch 
objects. Can also affect Tatami 
offsets, Flexi Split and Motif Run 
orientation.

Smooth 
curves

Apply curve ‘smoothing’ to both 
embroidery and vector objects.

Transform > Transform selected objects using a 
combination of reference points 
and numeric values. Rotate 
selected objects with the aid of 
reference points alone.

Envelope > Apply Bridge, Pennant, 
Perspective, and Diamond effects 
to lettering objects.

TrueView Toggle between normal (stitch) 
view and TrueView™.

Show >
Access same design viewing 
commands as available on View 
toolbar.

Flip sequins
Toggle between front and reverse 
sides of sequins in flip sequin 
designs.

Hoop Show/hide hoop.

Hoop 
template

Show/hide hoop template as an 
alternative to grid lines, in order to 
align design at correct location and 
orientation.

Show grid Show/hide grid.

Show rulers & 
guides Show/hide rulers and guides. 

Zoom > Zoom in to selected area of design.

Zoom 1:1 Show design at actual size.

Zoom factor Set precise viewing scale.
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Design menu

Object menu

Zoom in/out 
1.25x

Zoom in/out for greater or lesser 
detail.

Zoom in/out 
2x

Show design at twice/half current 
size.

Zoom to fit Show whole design in design 
window or just selected objects.

Zoom to 
selected

View selected objects in design 
window.

Zoom to 
product

View whole product backdrop in 
design window.

Zoom to hoop View whole hoop in design window. 

Pan Pan across current design.

Previous view Return to previous view.

Center at 
current stitch

Center design in design window at 
current stitch cursor position.

Measure Measure distance between two 
points on screen.

Stitch player Simulate embroidery design 
stitchout on screen.

View by color View embroidery objects by color – 
e.g. when resequencing objects.

View all 
colors

Show all colors after activating 
View by Color.

View by 
machine 
function >

View machine Chenille and Schiffli 
functions – Chain/Moss, 
Stepp/Blatt, etc.

Refresh 
screen Refresh screen display.

Design 
properties

Show design information – size, 
number of stitches, job order 
details, etc – and add comments for 
worksheets.

Select 
machine 
format

Select machine format 
corresponding to embroidery 
machine you intend to use.

Machine 
format 
settings

Define values to encode when 
outputting to a specific machine 
format.

Auto fabric Change current fabric type and 
associated settings.

Auto hoop Prompt system to select a suitable 
hoop from My Hoops list.

Background 
& display 
colors

Change background colors, fabric 
swatches, and display colors for 
current colorway.

Auto start & 
end

Access automatic design start/end 
settings.

Remove 
small stitches

Automatically remove unwanted 
small stitches.

Repeats
Use in combination with Show 
Repeats tool to define design 
repeat settings for continuous and 
overlapping designs.

Make 
properties 
current

Make properties of a selected 
object current for the design.

Apply current 
properties

Apply current settings to selected 
objects.

Apply favorite 
style

Assign up to 10 favorite styles via 
Manage Styles. Select object and 
click button to apply.

Apply style Apply predefined style to selected 
objects.

Use for 
Florentine / 
Liquid effect

Make guidelines for Florentine or 
Liquid effects.

Create motif Add individual motifs to a design. 
Save own motifs for future use.

Create 
program split

Turn embroidery or drawing objects 
into patterns for use in Program 
Split fills.

Create letter Access command used in custom 
fonts. See Custom Lettering 
(Reference Manual).

Create 
user-refined 
letter

Save a reshaped letter as a 
‘user-refined letter’. Only available 
when selected in Reshape mode.
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Arrange menu

Function menu

Stitch menu

Update 
kerning 
settings

Update kerning settings for 
contiguous pairs of selected letters 
of the same font. Only available 
when Automatic Kerning is in use. 

Create 
sequin shape

Define sequin shapes with custom 
hole position and size. Save to 
custom sequin library.

Create 
sequin fixing

Define custom fixing stitches to 
support multi-head sequin devices.

Set color Change color of consecutive 
objects of same color.

Group / 
Ungroup Group or ungroup selected objects.

Lock / Unlock 
all

Lock selected objects or unlock all 
objects in a design.

Branching Automatically sequence and group 
like embroidery objects. 

Apply closest 
join

Join selected objects at the closest 
point. Re-apply closest join after 
editing.

Break apart
Split branched objects – 
monograms, appliqués, lettering, 
etc – into components. Allows each 
to be edited individually.

Sequence > Resequence selected objects in 
order selected, or resequence 
objects by color to reduce color 
changes.

Align >

Same functions as the Arrange 
toolbar. See Arrange tools for 
details.

Space 
evenly >

Make same 
size >

Shaping > Same functions as the Shaping 
toolbar.

Remove 
overlaps

Remove the underlying layer of 
stitching in overlapping objects. 

Penetrations Toggle Penetrations function on/off. 
Engage needles or borers, or 
disengage to create jumps.

Borers Toggle Borers function on/off.

Insert Stop Insert Stop function at current stitch 
cursor position.

Insert Tie-off Insert a tie-off.

Insert Trim Insert a trim.

Insert Empty 
stitch Insert an empty stitch.

Insert Empty 
jump Insert an empty jump.

Insert 
function

Insert machine function at current 
stitch cursor position.

Clear 
function

Remove machine functions from 
current stitch cursor position.

Edit function Edit machine function at current 
stitch cursor position.

Generate 
stitches

Generate stitches for selected 
objects.

Stitch edit 
selection

Select a range of objects as you 
travel through the design.

Process 
stitches

Adjust stitch density of and/or scale 
whole or selected parts.

Recognize 
objects / 
outlines

Recognize new or revised object 
outlines after stitch editing – use 
with machine files opened without 
object/outline recognition. 

Split object Split object in two at current needle 
position. Use with Travel by Stitch 
functions.
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Graphics menu

Setup menu

Import 
graphic

Import artwork into current design 
as a backdrop for manual or 
automatic digitizing.

Instant smart 
design

Automatically create embroidery 
from imported artwork instantly.

Smart design Create whole embroidery designs 
directly from imported artwork.

Keep graphic 
objects

Retain original artwork during 
conversion.

Color 
matching 
method

Set color matching for auto 
digitizing. Add or match bitmap 
colors to palette, or match to thread 
colors in selected chart/s.

Crop bitmap Crop bitmap images to remove 
unnecessary detail and save 
processing time.

Remove crop Remove cropping area.

Finalize crop Turns a ‘virtual crop’ into a ‘hard 
crop’ by reducing an image to its 
new visible extents.

Prepare 
bitmap colors

Prepare bitmap images for 
automatic digitizing.

Edit using > Edit bitmaps using Paint, Corel 
PHOTO-PAINT, or Paint Shop Pro.

Turning satin 
object

Fill narrow column shapes with 
turning stitching.

Tatami fill 
object with 
holes

Fill large shapes with tatami 
stitching, preserving any holes

Tatami fill 
object

Fill large shapes with tatami 
stitching, ignoring any holes.

Centerline 
run object

Create centerlines in narrow 
shapes with Run stitching.

Outline run 
object

Create outlines around shapes with 
Run stitching.

Auto trace to 
vectors

Convert artwork to vector objects. 
These can be converted to 
embroidery objects.

Adjust bitmap Adjust image lightness and 
contrast.

Photo Flash Create whole embroidery designs 
directly from photographs.

Color 
PhotoStitch

Convert photographs and other 
bitmap artwork into multi-colored 
embroidery.

Reef 
PhotoStitch

Convert photographs into reef-like 
embroidery.

Add bitmap 
colors

Assign matching thread colors from 
selected chart/s to the current 
colorway.

Options Access current settings for object 
display.

Manage 
thread charts

Define your own thread charts. 
When you create a thread chart, 
you are creating a store of colors for 
future use.

Manage auto 
fabrics

Modify existing fabric definitions 
and create new ones. 

Manage 
styles

Define new styles for a template, 
either from scratch or based on an 
existing style or object.

My hoops Configure My Hoop list to include 
only hoops available for use.

Manage 
motifs

Manage your custom motif sets.

Manage 
user-refined 
letters

Adjust height range and other 
settings for custom ‘user-refined’ 
letters.

Manage 
sequin fixing

Rename or delete custom sequin 
fixings from the library. See also 
Object > Create Sequin Fixing.

Manage 
sequin shape

Rename or delete custom sequin 
shapes from the library. See also 
Object > Create Sequin Shape.

Manage 
alphabets

Modify custom alphabets by 
changing names, default letter 
spacings and join types.

Convert 
TrueType 
font

Convert a TrueType font to an 
embroidery font.
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Window menu

Help menu
BE EmbroideryStudio provides various ways 
to access information about the software 
and how to use it via the Help menu. 

BE EmbroideryStudio toolbars

The Wilcom Workspace contains the 
toolbars described below. Some tools are 
shortcuts to pulldown menu commands. 
Details of optional toolbars are provided in 
the onscreen documentation.

Note: Only the most commonly used 
toolbars are on by default.

Standard tools
The Standard toolbar contains commonly 
used tools and commands, specific to and 
only visible in Wilcom Workspace.

Calibrate 
screen

Set up your monitor. 

Connection 
Manager 
setup

Connect to machines that appear 
as removable media or make use of 
third-party connection software.

Tablet setup Set up digitizing tablet.

Scanner 
setup Set up Scanner.

Bling 
machine 
setup

Set up direct connection to CAMS 
automatic rhinestone placement 
machine.

Machine 
runtime setup

Set up multiple named machines for 
the purposes of runtime analysis.

New tab 
group...

Split the design window into a 
second tab group, either vertical or 
horizontal. Each tab group can 
contain multiple designs.

Move to tab 
group...

Move a current design to the other 
design tab. Can also be dragged to 
the other design group.

Remove tiling Remove tab groups and split 
windows and return to a single 
design window.

Split window Split design tab into multiple views 
of the same design.

Dockers > Show/hide dockers to optimize 
working area.

Toolbars > Show/hide toolbars to optimize 
working area.

Kiosk Lettering kiosk capability for cap 
and other embroidery for use at 
retail outlets where simple 
personalization of standard design 
layouts is required.

More 
windows

View more open windows.

New design Create new design file.

Open 
design Open embroidery design.

Open recent 
designs

Open design from list of 
recently opened designs.

Save design Save current design file.

Export 
machine file

Export current design to 
machine file for stitching.

Print Print current design using 
current print settings.
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Property bar
Adjust general properties – width, height, 
position – by means of the Property Bar. 
Changes to the values are applied by 
pressing Enter on the keyboard. They are 
discarded when you press Esc or click 
anywhere outside the fields. See Access 
object properties for details.

The Center All command can be used to 
center the whole design and hoop at the 
(0,0) position. This means you can 
reposition the hoop around the design after 
you have finished digitizing without the 
need for auto-centering. See Set automatic 
or fixed hoop positioning for details.

Status & Prompt bars
The Status and Prompt bars provide 
continuous display of current cursor position 
status as well as instructions for use of 
selected tools. See Operating modes for 
details.

View tools
Use the View tools to visualize your designs 
– e.g. as design outlines, by stitches, by 
machine functions, as they will stitch out on 
the fabric. Right-click to access settings. 
See also Viewing Designs.

Print 
preview

Preview production 
worksheet/approval sheet. 
Print from preview window.

Cut Cut selection and place on 
clipboard.

Copy Copy selection and place on 
clipboard.

Paste
Paste contents of clipboard. 
Options available in Options > 
Edit tab.

Undo Undo previous action.

Redo Redo previously undone 
action.

Import 
embroidery

Import embroidery design file 
into current design. 

Import 
graphic

Import artwork into current 
design as a backdrop for 
manual or automatic digitizing.

Export multi- 
decoration 
files

Export mixed decoration 
design components as file 
formats for use by control 
software or machine. 

Send to 
Connection 
Manager

Send current design to 
machine via proprietary 
machine software.

Send to 
Embroidery
Connect

Send current design to named 
EmbroideryConnect device.

Queue 
Design

Send current design to 
EmbroideryConnect design 
queue.

Send to 
appliqué 
cutter

Send appliqué shapes from 
current design to laser cutter. 

Send to 
bling cutter

Send bling shapes in current 
design to cutting machine. 
Configure machine via Setup 
menu.

Select zoom scale from droplist 
or key in zoom factor and press 
Enter.

Options
Access application options for 
design view, grid & guides, and 
other settings.

TrueView Toggle between stitch view and 
TrueView™.

Show 
stitches

Show/hide embroidery 
stitching.
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Zoom tools
Use the Zoom tools to magnify the design 
view by zooming in on individual stitches or 
details. See Zoom & pan designs for details.

Hoop tools
Use the Hoop tools to configure, select, and 
place both single and multiple hoopings. See 
Design Hooping for details.

Show 
outlines Show/hide object outlines.

Show 
needle 
points

Show/hide needle points.

Show 
connectors Show/hide connecting stitches.

Show 
functions

Show/hide machine function 
symbols.

Show 
repeats Show/hide design repeats.

Show 
bitmaps Show/hide bitmap images.

Show 
vectors Show/hide vector graphics.

Dim artwork
Dim graphic backdrops to 
display stitches more clearly 
when digitizing.

Show 
appliqué 
fabric

Show/hide appliqué fabrics.

Show 
product

Show/hide product backdrop. 
Right-click for Product 
Visualizer settings.

Show bling Show/hide bling (rhinestones).

Flip sequins
Toggle between front and 
reverse sides of sequins in flip 
sequin designs.

Show grid Show/hide grid.

Show rulers 
& guides Show/hide rulers & guides.

Change measurement units in 
BE EmbroideryStudio without 
changing system settings. 

Auto start & 
end

Set auto start and end points for 
whole design.

Stitch player Simulate embroidery design 
stitchout on screen.

Zoom
Zoom in/out with left/right mouse 
clicks, or drag selection marquee 
to view design detail.

Zoom 
1:1 Show design at actual size.

Zoom in/ 
out 1.25x

Zoom in/out for greater or lesser 
detail.

Select zoom scale from droplist or 
key in zoom factor and press Enter.

Zoom to 
fit 

Show whole design in design 
window.

Zoom to 
selected Magnify selected objects.

Zoom to 
product

Show whole product backdrop in 
design window.

Zoom to 
hoop

Show whole hoop in design 
window. 

Show hoop Show/hide current hoop. 
Right-click for settings.

My hoops Select new hoop from My 
Hoops list. Displays currently 
active hoop.

Hoop options
Configure hoop lists, change 
hoop position settings, and 
define custom hoops.
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Hooping Mode tools
BE EmbroideryStudio provides a dedicated 
Hooping Mode toolbar which allows you to 
specify multiple hoopings for large designs, 
both manually or automatically. See 
Multi-Hooping for details.

Mode tools
The Mode tools control interactions 
between Wilcom Workspace and 
CorelDRAW Graphics.

Auto hoop Prompt system to select a 
hoop from My Hoops list.

Rotate hoop 
left 15° Rotate hoop and hoop 

template, or selected hoops in 
hooping mode, in 15° 
increments to left or right.Rotate hoop 

right 15°

Rotate hoop by specified 
amount in degrees – positive 
or negative.

Hooping 
mode

Toggle on to access hooping 
toolset. Toggle off to access 
digitizing and editing toolset.

Select

Click or drag a selection 
marquee to select hoop or 
split line. Hold down <Ctrl> to 
select multiples. Click twice to 
activate rotation handles.

Reshape

Reshape selected 
mode-specific objects, edit 
stitch angles, and adjust 
entry/exit points. Right-click 
for settings.

Multi-Hooping 
Options

Change multi-hooping 
options in the Multi-Hooping 
tab of the Options dialog.

Auto Layout 
Hoops

Automatically 
add/rotate/delete hoops and 
split lines to cover the entire 
design.

Add Splitting 
Line

Digitize one or more guides in 
a multi-hoop layout to split 
objects between hoopings.

Preview 
Hoopings

View hooping thumbnails in 
Preview Hoopings docker. 
Click thumbnails to isolate 
hoopings.

Calculate 
Hoopings

Calculate hoopings resulting 
from current layout.

Add/Delete 
Hoop

Add or remove hoopings in a 
multi-hooping layout.

Home

Switch to Home screen to 
access My Wilcom account, 
access announcements, 
community forums, blogs, 
tutorials and other product 
information.

Wilcom 
Workspace

Switch to Wilcom Workspace 
to access access digitizing and 
editing toolset.

CorelDRAW 
Graphics

Switch to CorelDraw Graphics 
to access full graphic creation 
and editing toolset.

Design 
Library

Open Design Library to search 
for and catalogue designs as 
well as quotes, orders, and 
approvals.

Convert 
embroidery 
to graphics

Convert selected embroidery 
to vector graphics and switch 
to CorelDRAW Graphics.

Convert 
graphics to 
embroidery

Convert selected graphics to 
embroidery and switch to 
Wilcom Workspace.

Tag as 
appliqué

Convert selected vector 
lettering to appliqué with 
turning stitching.

Tag fill as 
turning satin

Convert selected narrow vector 
objects to turning satin.

Tag as Photo 
Flash

Convert photos to Photo Flash 
embroidery. 

Keep graphic 
objects

Retain original artwork during 
conversion.
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Docker tools
Use the Docker tools to toggle modeless 
dialogs (dockers) on or off. See also Work 
with dockers.

Color tools
The Color toolbar contains a palette specific 
to and only visible in Wilcom Workspace. 
See Thread selection for details.

Match to 
embroidery 
palette

Toggle thread-color matching 
for converted vector objects. 

Show 
embroidery

Toggle embroidery object 
display.

Virtual Decoration Quality: set 
the rendering quality of 
embroidery TrueView for a 
virtual decoration.

Design 
information

Show design information – 
size, number of stitches, job 
order details, etc – and add 
comments for worksheets.

Overview 
window

Show/hide Overview Window. 
Zoom and pan thumbnail of 
current design.

Object 
properties

Show/hide Object Properties 
docker. Preset properties or 
adjust for selected objects.

Color-object 
list

Show/hide Color-Object List. 
View and sequence design 
objects.

Colorway 
editor

Show/hide Colorway Editor. 
Assign thread colors to color 
palette and define multiple 
colorways.

Threads
Show/hide Threads docker. 
Find threads from different 
charts and change design 
colors.

Stitch list Show/hide Stitch List. View, 
filter and select stitches.

Team names
Show/hide Team Names 
docker. View and edit 
teamname lists.

Carving 
stamp

Show/hide Carving Stamp. 
Create needle penetrations 
using a ‘carving stamp’ as 
template.

Embroidery 
clipart

Show/hide Embroidery Clipart 
docker. Record and recover 
re-usable design elements.

Keyboard 
design 
collection

Show/hide Keyboard Design 
Collection docker. Create new 
or edit current collections.

Exports

Show/hide Exports docker. 
View export status of current 
session. Conversion to older 
formats or machine files 
performed as background 
task.

Switch between colorways. 
Define via Colorway Editor.

Colorway 
editor

Show/hide Colorway Editor. 
Assign thread colors to color 
palette and define multiple 
colorways.

Background 
& display 
colors

Change background colors, 
fabric swatches, and display 
colors for current colorway.

Product 
visualizer

Show/hide Product Visualizer. 
Set current product backdrop.

Current 
color Displays the current color.

Pick color Pick color from design and 
make current.

Apply 
current color

Apply current color to 
embroidery objects. 

Add color Add color slot to palette. Edit 
via Colorway Editor.

Remove 
color 

Remove last unused slot from 
color palette.
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Colorway Editor
The Colorway Editor contains tools for 
editing colorways.

Toolbox
The Toolbox contains embroidery 
digitizing/editing tools specific to and visible 
only in Wilcom Workspace. By default, the 
Toolbox docks vertically to the left of 
screen but can be floated, re-configured, 
and docked like any other toolbar.

Hide unused 
colors

Show/hide unused colors in 
color palette.

Remove 
unused 
colors

Remove unused colors from 
color palette.

Split palette 
color

Split selected color in two color 
slots. Used with multiple 
colorways.

Cycle used 
colors

Cycle through combinations of 
used colors. Left- or right-click. 

Color wheel Access Color Wheel to test 
combinations of related colors. 

Threads
Show/hide Threads docker. 
Find threads from different 
charts and change design 
colors.

Create 
colorway

Add new colorway to current 
design. 

Rename 
colorway Rename selected colorway. 

Delete 
colorway Delete selected colorway. 

Move left
Move selected colorway in 
Colorway Editor to right or left.

Move right

Background 
& display 
colors

Change background colors, 
fabric swatches, and display 
colors for current colorway.

Edit color Edit specification and color of 
selected color slot.

Show 
colorway 
details

Show selected colorway details.

Hide 
unused 
colors

Show/hide unused colors in 
color palette.

Select See Selection tools for details.

Reshape See Reshape tools for details.

Edit See Edit tools for details.

Lettering

Create embroidery lettering 
onscreen using embroidery 
fonts, keyboard design 
collections, or TrueType fonts. 
Right-click for settings.

Team 
names

Show/hide Team Names docker. 
View and edit teamname lists.

Monogram- 
ming

Show/hide Monogramming 
docker. Create monograms 
using predefined styles, border 
shapes and ornaments.

Laydown 
stitch

Generate light fills to flatten nap 
of fabrics like terry toweling as 
substrate for embroidery.

Simple 
offsets

Create precise offsets for closed 
embroidery or vector objects.

Outlines & 
offsets

Create outlines and offsets for 
closed embroidery or vector 
objects.

Open 
offsets

Create precise offsets for open 
embroidery or vector objects.

Add border Add predefined borders to 
designs or selected objects.

Color 
blending

Generate color blends, 
perspective and shading effects 
in selected objects.

Auto-
digitizing See Property bar for details.
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Selection tools
Use the Select tools to select embroidery 
objects in a variety of ways. See Selecting 
objects for details.

Reshape tools
Use the Reshape tools to reshape objects 
with control points as well as edit individual 
stitches. See Reshaping objects for details. 
See also Stitches & Machine Functions 
(Reference Manual).

Edit tools
Use the Edit tools for object editing 
operations. See Reshaping & Splitting 
Objects for details.

Envelope tools
Envelopes are typically applied to lettering 
objects, but they can also be applied to 
other types of embroidery object. See 
Applying envelopes for details.

Envelope See Envelope tools for details.

Arrange See Arrange tools for details.

Shaping See Shaping tools for details.

Select
Use with <Ctrl> or <Shift> keys to 
select groups or ranges of 
objects. Drag selection marquee 
to select multiple objects. 

Freehand 
select

Select objects by dragging 
freehand selection marquees.

Select 
current

Select object at current cursor 
position.

Polygon 
select

Select objects by digitizing a 
selection marquee around them.

Polyline 
select

Select objects by digitizing line 
through them.

Reshape 
object

Reshape selected objects, edit 
stitch angles, and adjust 
entry/exit points. 

Show 
reshape 
nodes

Show/hide reshape nodes for 
selected objects.

Show 
bézier 
handles

Show/hide Bézier handles for 
selected objects. (Activate in 
Options > Reshape.)

Show 
stitch 
angles

Show/hide stitch angles for 
selected objects.

Show 
entry/exit

Show/hide entry (green diamond) 
and exit (red cross) points for 
selected objects.

Stitch edit Select individual stitches for 
editing.

Keep last 
stitch Set last stitch in selected column 

(A/B) shapes.Omit last 
stitch

Break 
apart

Split branched (composite) 
objects – monograms, appliqués, 
lettering, etc – into components. 
Allows each to be edited 
individually.

Knife
Cut objects along a digitized line, 
preserving stitch settings and 
colors.

Automatic 
knife

Slice large objects into smaller 
ones with automatic overlaps.
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Arrange tools
Use the Arrange tools for moving, aligning 
and distributing objects, as well as grouping 
and locking operations. See Transforming 
Objects for details.

Traditional digitizing tools
The Traditional Digitizing toolset 
provides all the input methods embroidery 
digitizers are familiar with. Traditional 
digitizing methods divide into three main 
categories – ‘free shapes’, ‘column shapes’, 
and ‘outlines’. See also Embroidery 
digitizing.

Bridge envelope

Apply to lettering objects 
to make them bulge or 
arch, stretch or 
compress.

Pennant envelope

Perspective 
envelope

Diamond envelope

Delete envelope Delete envelopes from 
selected objects.

Group Group selected objects.

Ungroup Ungroup selected grouped 
objects.

Lock Lock selected objects.

Unlock all Unlock all locked objects in 
design.

Branching Automatically sequence and 
group like embroidery objects. 

Apply closest 
join

Join selected objects at closest 
point. Re-apply closest join 
after editing.

Break apart

Split branched (composite) 
objects – monograms, 
appliqués, lettering, etc – into 
components. Allows each to 
be edited individually.

Align left Left-align selected objects.

Align centers 
vertically

Vertically align centers of 
selected objects.

Align right Right-align selected objects.

Align top Align tops of selected objects.

Align centers 
horizontally

Horizontally align centers of 
selected objects.

Align bottom Align bottoms of selected 
objects.

Align centers Align selected objects through 
their centers. 

Space evenly 
across

Evenly distribute three or more 
selected objects horizontally.

Space evenly 
down

Evenly distribute three or more 
selected objects vertically.

Make same 
width

Scale selected object/s to 
same width as last-selected 
reference object.

Make same 
height

Scale selected object/s to 
same height as last-selected 
reference object.

Make same 
width & 
height

Scale selected object/s to 
same dimensions as 
last-selected reference object.

Outlines See Outline tools for details.

Backtrack Reinforce outlines, stitching in 
reverse direction to original.

Repeat
Duplicate outlines in same 
direction – normally used with 
closed shapes.

Column A Digitize columns of turning 
stitches of varying width.
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Outline tools
Use the Outline tools for digitizing 
embroidery outlines. See Digitizing outlines 
& details for details.

Manual stitch tools
The Manual tools are used for digitizing 
individual stitches. Manual objects have no 
outlines, only stitches. Stitch density does 

not change. See Digitize stitches (Reference 
Manual).

Graphics digitizing tools
Graphics Digitizing tools operate in a 
similar way to CorelDRAW® 
Graphics Suite or other graphics 
applications. Assign a stitch type to a 
digitized shape from Outline Stitch or Fill 
Stitch toolbars. See also Digitizing with 
graphical tools. See also Appliqué 
Embroidery (Reference Manual).

Column B
Digitize columns of turning 
stitches where opposing sides 
are different.

Column C Digitize columns or borders of 
fixed width.

Complex 
fill

Digitize filled shapes with a 
single stitch angle.

Complex 
turning

Digitize filled shapes with turning 
stitches.

Star Digitize star shapes with zigzag 
stitching.

Ring Digitize circles and oval-shaped 
rings.

Manual See Manual stitch tools for 
details.

Use motif
Add single motifs to design. 
Rotate, scale, or mirror into 
position.

Branching Automatically sequence and 
group like embroidery objects. 

Digitize 
run Place row of single or triple 

stitches along digitized line.
Triple run

Motif Run Place row of motifs along 
digitized line.

Backstitch Place row of backstitches along 
digitized line.

Stemstitch Place row of stemstitches along 
digitized line.

Manual Digitize single stitches. 

Triple 
manual

Digitize three stitch layers at a 
time.

Digitize 
open 
shape

Digitize open shapes with left 
and right mouse clicks for 
straight lines and curves. 

Digitize 
closed 
shape

Digitize closed shapes with left 
and right mouse clicks for 
straight lines and curves. 

Digitize 
column

Digitize column shapes of 
varying width, setting the stitch 
angle at each pair of points.

Rectangle
Digitize two corners of a 
rectangle, or press <Ctrl> for a 
perfect square. 

Ellipse
Digitize the center points plus 2 
size points for an ellipse or press 
<Enter> for a perfect circle.

Basic 
shapes

Digitize basic shapes. Press 
<Ctrl> to maintain proportions. 
Press <Shift> to center around 
starting point.

Freehand 
open 
shape

Click and hold to draw freehand 
open shapes. Adjust smoothing 
control for preferred result. 

Freehand 
closed 
shape

Click and hold to draw freehand 
closed shapes. Adjust smoothing 
control for preferred result. 
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Stitch angle tools
Add or remove stitch angles with the Stitch 
Angle tools. See Adjusting stitch angles for 
details.

Hole tools
Hole tools are used to cut as well as fill 
holes in embroidery objects. See Adding & 
filling holes (Reference Manual).

Appliqué tools
Appliqué tools are specialized for appliqué 
work. Use them to create appliqué objects, 
resequence objects for efficient stitchout, as 
well as generate partial cover stitching for 
overlapping appliqué. See Appliqué 
Embroidery (Reference Manual).

Auto-digitizing tools
Auto-Digitizing tools provide everything 
necessary to automatically digitize shapes in 
electronic artwork, both bitmap and vector, 
without using manual input methods. See 
Auto-digitize individual shapes for details.

Stitch 
angles See Stitch angle tools for details.

Holes See Hole tools for details.

Appliqué See Appliqué tools for details.

Stitch 
angles

Add stitch angles to selected 
objects. 

Remove 
stitch angles

Remove stitch angles from 
closed objects with turning 
stitches.

Add holes Cut holes in filled objects. 

No holes Remove hole/s from selected 
object.

Fill holes
Fill holes formed by existing 
boundaries. Choose an exact fit 
or offset. 

Appliqué

Digitize appliqué objects, with or 
without holes, with up to four 
layers of stitching – guide runs, 
cutting lines, tack stitches, and 
cover stitches.

Appliqué 
without 
holes

Digitize appliqué objects (without 
holes) with up to four layers of 
stitching – guide runs, cutting 
lines, tack stitches, and cover 
stitches. 

Combine 
appliqué

Break appliqué into component 
objects and recombine and 
resequence for efficient stitchout.

Partial 
appliqué

Create partial cover stitching for 
overlapping appliqué objects.

Remove 
overlaps

Remove underlying layers of 
stitching in overlapping objects 
using selected ‘cutter’ object(s). 
Right-click for settings.

Instant smart 
design

Automatically convert 
imported artwork to 
embroidery.

Smart design
Create whole embroidery 
designs from imported 
artwork.

Keep graphic 
objects

Retain original artwork during 
conversion.

Color 
matching 
method

Set color matching for auto 
digitizing. Add or match bitmap 
colors to palette, or match to 
thread colors in selected 
chart/s.

Crop bitmap
Crop artwork for use with 
auto-digitizing. Digitize points 
and press Enter to create 
cropping shape.
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Outline Stitch tools
The Outline Stitch toolbar provides a 
range of basic outline stitch types as well as 
those of a more decorative nature. These 
stitch types can be applied to open or closed 
shapes. Right-click to access stitch settings. 
See also Stitch Types.

Remove crop Click to remove cropping area.

Finalize crop
Make cropping permanent. 
Once finalized, cropping 
cannot be removed.

Prepare 
bitmap colors

Prepare artwork for automatic 
digitizing.

Turning satin 
object

Fill narrow column shapes with 
turning stitching.

Tatami fill 
object with 
holes

Fill large areas with tatami 
stitching, preserving any 
holes.

Tatami fill 
object

Fill large areas with tatami 
stitching, ignoring any holes.

Centerline 
run object

Create centerlines in narrow 
shapes with run stitching.

Outline run 
object

Create outlines around shapes 
with run stitching.

Auto trace to 
vectors

Convert artwork to vectors. 
These can be converted to 
embroidery.

Adjust 
bitmap

Adjust image lightness and 
contrast for auto-digitizing.

Photo Flash Create whole embroidery 
designs directly from photos.

Color 
PhotoStitch

Automatically convert 
grayscale or color photos to 
embroidery. 

Reef 
PhotoStitch

Automatically convert photos 
into reef-like embroidery.

Run Create outlines and details.

Sculpture 
run

Create alternating triple/single 
stitch runs for a hand-stitched 
look.

Triple run Create heavier triple stitch 
outlines and details.

Backstitch Create traditional backstitch 
outlines for delicate borders.

Stemstitch
Create traditional stemstitch 
outlines for decorative details 
such as stems and vines.

Motif run
Create ornamental craftstitch 
outlines. Choose from a motif 
library.

String Create craftstitch outlines for 
delicate borders.

Satin Create glossy satin borders or 
columns of even width.

Satin 
raised

Create layered satin borders or 
columns of even width for a 
raised surface.

Zigzag
Create borders or columns of 
even width for an open ‘sawtooth’ 
effect.

E stitch
Create borders or columns of 
even width for an open ‘comb’ 
effect.

Tatami
Create borders or columns of 
even width for different needle 
penetration patterns.

Program 
split

Create borders or columns of 
even width for decorative needle 
penetration patterns.

Square
Create borders or columns of 
even width for an open ‘toothed’ 
effect.

Coil
Create borders or columns of 
even width for an open ‘coil’ 
effect. 
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Fill Stitch tools
The Fill Stitch toolbar provides a range of 
basic fill stitch types as well as those of a 
more decorative nature. Apply to closed 
shapes. Right-click to access stitch settings. 
See also Stitch Types.

Stitch effect tools
Use the Stitch Effects tools for modifying 
or improving stitch quality, including 
applying automatic underlay to selected 
objects. Right-click for settings.

Contour
Create contoured stitching 
following borders or columns of 
even width. 

Vector 
outline

Create vector outlines without 
stitch properties.

Satin Create glossy satin fills for narrow 
shapes.

Satin 
raised

Create layered satin fills for a 
raised surface.

Zigzag Create zigzag fills for an open 
‘sawtooth’ effect.

E stitch Create an open ‘comb’ effect.

Tatami
Create solid stitching for large 
shapes with different needle 
penetration patterns.

Coil Create open coil fills.

Square Create open straight parallel fills.

Double 
square Create grid fills.

Island coil Create concentric rows of coil fills.

String Create string craftstitch fills.

Program 
split

Create solid decorative fills using 
needle penetrations to form tiled 
patterns.

Motif fill
Create decorative fills using 
embroidery motifs to form 
repeating patterns. Choose from a 
motif library.

Motif 
column

Place motifs along the center line 
of a column shape and resize to 
fit. Right-clicking for settings.

Cross 
stitch

Fill large areas with cross stitching 
on an invisible grid that applies to 
all design objects.

Contour Create curved fills where stitches 
follow contours of a shape.

Spiral Create spiral stitching radiating 
from the center of the object.

Maze
Create maze-like stitching which 
follows object contours for open 
fills.

Offset Create offset fill stitching in any 
closed shape.

Stipple
Create a stipple fill which 
meanders randomly within a 
shape.

Stipple 
backstitch

Create a stipple backstitch fill 
which meanders randomly within 
a shape.

Stipple 
stemstitch

Create a stipple stemstitch fill 
which meanders randomly within 
a shape.

Laydown
Generate a light fill to flatten the 
nap of textured fabrics like terry 
toweling for subsequent 
embroidery.

Vector fill Create vector fills without stitch 
properties.

Auto underlay Generate automatic underlay 
for selected objects.

Pull 
compensation

Apply to selected objects to 
compensate for fabric 
stretch. 
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Mirror-merge tools
Mirror Merge tools allow you to duplicate 
and transform selected embroidery objects, 
as well as merge them into a single object. 
See Mirroring objects for details.

Mirror Merge settings include...

Auto jump Preserve long stitches in new 
and selected objects. 

Shortening
Reduce stitch bunching in 
tight curves by shortening 
stitches along inside edge. 

Fractional 
spacing 

Even out stitch density along 
inside and outside edges. 

Mitre corners Create sharp mitre corners at 
intersections. 

Cap corners Create capped corners for 
fewer stitches. 

Lap corners Create ‘Tidori’ style corner 
stitching. 

Jagged edge
Create rough edges, shading 
effects, or imitate fur and 
other fluffy textures in 
selected objects. 

Trapunto
Force underlying travel runs 
to the edges of selected 
objects. Use with open 
stitching. 

User-defined 
split

Create custom split-line 
effects. 

Accordion 
spacing

Create perspective and 
shading effects with stitch 
spacing varying between 
dense and open fill. 

Flexi split
Create decorative split 
patterns following stitch 
angles and scaled according 
to object width. 

Radial fill

Create radial turning 
stitching with various stitch 
types including satin, tatami 
and program splits. Can be 
applied to ring shapes.

Florentine 
effect

Create custom curve-line 
stitching with a single 
guideline. 

Liquid effect Create custom curve-line 
stitching with twin guidelines. 

3D Warp Create 3D effects in selected 
motif fills. 

Hand Stitch 
Effect

Create hand-stitch effects 
which combine randomized 
stitch length, angle and 
count.

Cording
Apply cording effect to new 
or selected objects with run 
stitching. Contour, spiral, 
offset or stipple may be used.

Mirror copy 
horizontal

Duplicate and mirror 
horizontally and merge 
overlapping objects (optional). 

Mirror copy 
vertical

Duplicate and mirror vertically 
and merge overlapping 
objects (optional). 

Mirror copy 
horizontal & 
vertical

Duplicate and mirror selected 
objects around a center point.

Array

Duplicate designs, such as 
badges, automatically 
re-sequencing color blocks for 
efficient multiple design 
stitchouts.

Reflect
Duplicate and mirror objects 
or designs. Create decorative 
borders.

Wreath Duplicate objects around a 
center point.

Kaleidoscope Duplicate and mirror paired 
objects in a wreath.
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Shaping tools
When working with overlapping vector or 
embroidery objects, you can merge, trim or 
split them with the Shaping tools. See 
Shaping objects (Reference Manual).

Sequence tools
Sequence tools are used to resequence 
selected objects. Use them in conjunction 
with the Color-Object List. See 
Sequencing embroidery objects for details.

Transform tools
Use the Transform tools to mirror, rotate 
and skew objects. See Transforming Objects 
for details.

Rows: Set number of rows in the array.

Row spacing: Set spacing between 
rows in the array.

Columns: Set number of columns in 
the array.

Column spacing: Set spacing between 
column in the array.

Wreath points: Set number of 
duplicates (including source). 
Kaleidoscope works best with an even 
number.

Set precise distance and angle – 
measured from center of source object 
to center of wreath or kaleidoscope.

Weld
Merge selected overlapping 
objects into a single ‘flattened’ 
object.

Intersect
Trim selected overlapping 
objects so that only intersected 
areas remain.

Exclude
Trim selected overlapping 
objects and preserve individual 
properties.

Front-back
Trim selected overlapping 
objects so that only 
non-overlapping areas of the 
topmost object remain.

Back-front
Trim selected overlapping 
objects so that only 
non-overlapping areas of the 
bottommost object remain.

Flatten Trim all overlaps in selected 
overlapping objects.

Divide
Split selected objects into 
separate adjoining objects 
wherever they intersect.

Combine
Merge properties of selected 
overlapping objects and trim 
overlapping areas.

Keep 
original 
objects

Preserve original objects after 
shaping operations.

Overlap: Adjust object overlaps 
resulting from Flatten or Divide 
shaping operations.

Back 1 
object

Move selection back one object 
in the stitching sequence. 

Forward 1 
object

Move selection forward one 
object in the stitching sequence. 

Back 1 
color

Move selection back one color in 
the stitching sequence. 

Forward 1 
color

Move selection forward one color 
in the stitching sequence. 

Move to 
start

Move selection to start of 
stitching sequence. 

Move to 
end

Move selection to end of 
stitching sequence. 

Sequence 
by selects

Resequence objects in order of 
selection.

Sequence 
by color

Resequence all blocks of like 
color. (To maintain separate 
color blocks, use the 
Color-Object List.)
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Styles tools
Use the Styles toolbar to apply predefined 
styles to a design. The tools let you:
 Apply current settings to selected objects
 Change current settings, and
 Apply styles to selected objects.
The styles you select as ‘favorites’ are each 
assigned a tool icon on the toolbar. See 
Working with styles for details.

Stitch editing tools
Use the Stitch tools for stitch editing and 
processing operations. See also Stitches & 
Machine Functions (Reference Manual).

Function tools
Use the Function tools to insert machine 
functions manually. See Stitches & Machine 
Functions (Reference Manual).

Mirror 
horizontal

Flip selected objects 
horizontally.

Mirror 
vertical Flip selected objects vertically.

Mirror by 
reference 
line

Mirror objects around a 
defined axis using a reference 
line.

Rotate left 
15°

Rotate selection in 15° 
increments to the left.

Rotate right 
15°

Rotate selection in 15° 
increments to the right.

Rotate selection by specified 
amount – positive or negative 
– in degrees.

Skew selection by specified 
amount – positive or negative 
– in degrees.

Transform by 
reference 
line 
numerically

Transform selected objects 
using a combination of 
reference points and numeric 
values.

Transform by 
reference 
line freely

Rotate selected objects with 
the aid of reference points 
alone.

Make 
properties 
current

Make properties of a selected 
object current for the design.

Apply 
current 
properties

Apply current settings to selected 
objects.

Favorite 
style

Assign up to 10 favorite styles via 
Manage Styles. Select object 
and click button to apply.

Apply style Apply predefined style to 
selected objects.

Generate 
stitches

Generate stitches for selected 
objects.

Stitch edit Select individual stitches for 
editing.

Selects on 
/ off

Select a range of objects as you 
travel through the design.

Process 
stitches

Adjust stitch density of and/or 
scale whole or selected parts.

Split object
Split object in two at current 
needle position. Use with Travel 
by Stitch functions.

Penetrations Engage needles or borers. 
Disengage to create jumps. 

Borers Engage Borers function. Use 
for cutting holes in fabric.

Insert Stop Insert Stop function at current 
stitch cursor position. 

Insert Tie-off Insert Tie-off function at 
current stitch cursor position. 

Insert Trim Insert Trim function at current 
stitch cursor position.

Insert Empty 
stitch 

Insert Empty stitch function at 
current stitch cursor position.

Insert Empty 
jump

Insert Empty jump function at 
current stitch cursor position.
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Caution: When you insert stitches or 
machine functions manually, you must 
maintain them manually. If an object’s 
stitches are regenerated for any reason, all 
stitch editing and machine functions are 
lost.

Legacy feature tools
Newer machines use USB and wired or 
wireless network connections. Older 
machines use serial ports or even 
proprietary embroidery disks. Use the 
Legacy Features for connecting to older 
style machines. See Embroidery Output for 
details.

Travel tools
Use the Travel tools to view the stitching 
sequence of a design color-by-color, 
object-by-object, or stitch-by-stitch. 
Traveling can be initiated from any stitch in 
a design. See Viewing stitching sequence for 
details.

Sequin tools
Use the Sequin tools to digitize sequined 
designs for compatible machines. There are 
also tools for creating boring holes. See 
Sequin Embroidery (Reference Manual). 

Insert 
function

Insert machine function at 
current stitch cursor position.

Clear 
function

Remove machine functions 
from current stitch cursor 
position. 

Edit function Edit machine function at 
current stitch cursor position.

Slow Insert Slow function to set 
machine to low speed.

Fast Insert Fast function to set 
machine to high speed.

Send to 
Machine 
Manager

Send multiple designs to 
machine from 
BE EmbroideryStudio or 
DesignWorkflow and view or 
manage job queues. 

Send to 
Stitch 
Manager

Send current design direct to 
embroidery machine for 
production.

Embroidery 
disk

Open designs from or save to 
proprietary embroidery disk 
formats.

Hardware 
setup

Set up a machine connection 
with name, port, and protocol.

Start / end 
design

Move stitch cursor to start/end of 
design. Left/right-click.

Travel by 
object

Move stitch cursor to 
next/previous object. 
Left/right-click.

Travel by 
segment

Move stitch cursor to 
next/previous segment. Left/right 
click.

Travel by 
color

Move stitch cursor to 
next/previous color change. 
Left/right click.

Travel by 
function

Move stitch cursor to 
next/previous machine function. 
Left/right click.

Travel by 
trim

Move stitch cursor to 
next/previous Trim function. 
Left/right click.

Travel 
1000 
stitches

Move stitch cursor 
forwards/backwards 1000 
stitches at a time. Left/right click.

Travel 100 
stitches

Move stitch cursor 
forwards/backwards 100 stitches 
at a time. Left/right click.

Travel 10 
stitches

Move stitch cursor 
forwards/backwards 10 stitches 
at a time. Left/right click.

Travel 1 
stitch

Move stitch cursor 
forwards/backwards 1 stitch at a 
time. Left/right click.
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Beading tools
Use the Beading tools to create bead runs 
as well as fills for compatible machines. See 
Bead Embroidery (Reference Manual).

Bling tools
Use the Bling tools to create bling runs as 
well as fills for compatible machines. See 
Bling Digitizing (Reference Manual).

Sequin 
palette 
editor

Select sequins for the design 
from a sequin library.

Sequin Palette: Select sequin 
shapes for the current design.

Manual 
sequin

Digitize individual sequin 
drops. Right-click for settings.

Left sequin Switch to left sequin when 
digitizing twin-sequin designs.

Right 
sequin

Switch to right sequin when 
digitizing twin-sequin designs.

Sequin run 
auto

Create a string of sequins 
along a digitized line. 
Right-click for settings.

Sequin run 
manual

Digitize sequin-drops along a 
digitized line. Right-click for 
settings.

Sequin fill
Digitize and fill larger shapes 
with sequins. Right-click for 
settings.

Sequin 
edit

Fine-tune placement of 
individual sequins within 
selected sequin objects. 

Sequin 
Split Edit

Assign sequins to split areas 
of sequin fills.

Vectors to 
sequins

Create sequin runs from 
sequin artwork. Digitize a 
guideline connecting the 
sequins to include within a run.

Drop 
sequin

Left-click to insert a Drop 
Sequin function at current 
needle position. For 
twin-sequin machines, left- 
and right-click for alternative 
sequin drops.

Clear 
function

Remove machine functions 
(inc sequin) from current 
needle position.

Bead 
palette 
editor

Select shapes from a bead 
library, and define bead colors 
and sizes.

Bead palette

Manual 
bead Digitize individual bead drops.

Bead run 
auto

Create a string of beads along a 
digitized line. Right-click for 
settings.

Bead run 
manual

Digitize bead-drops along a 
digitized line. Right-click for 
settings.

Bead edit Fine-tune placement of beads 
within selected Bead objects.

Clear 
function

Remove machine functions (inc 
bead) from current needle 
position.

Bling 
palette 
editor

Select shapes from a bling 
library, and define bling colors 
and sizes.

Bling 
manual Digitize individual bling drops.

Bling run 
auto

Create a string of rhinestones 
along a digitized line. Right-click 
for settings.

Bling fill
Digitize and fill larger shapes 
with rhinestones. Right-click for 
settings. 

Bling 
lettering

Create bling lettering onscreen 
using native embroidery fonts or 
TrueType fonts. Right-click for 
settings.

Automatic 
overlap 
removal

Toggle on to remove excess 
rhinestones in overlapping Bling 
objects.
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Chenille tools
If you have the Chenille option installed, 
the Wilcom Workspace will include a 
Chenille toolbar containing specific Chenille 
stitch types and machine functions. See 
Chenille User Manual Supplement for 
details.

Schiffli tools
If you have the Schiffli option installed, the 
Wilcom Workspace will include a Schiffli 
toolbar containing specific Schiffli stitch 
types and machine functions. See Schiffli 
User Manual Supplement for details.

No 
automatic 
overlap 
removal

Toggle on to preserve 
rhinestones in overlapping Bling 
objects.

Highlight 
bling 
overlaps

Toggle on to highlight 
overlapping rhinestones. Use 
with manual edits.

Bling edit
Fine-tune placement of 
individual rhinestones within 
selected Bling objects.

Show bling 
work area

Visualize design within work 
area of selected machine 
model. Right-click for settings.

Chain

Switch to chain stitch mode to 
create decorative stitching 
resembling links of a chain – 
used for outlines and borders 
as well as monograms.

Moss

Switch to moss stitch mode to 
create dense cover using 
looped stitch typical of Chenille 
raised stitching – best with 
simple shapes.

Needle 
height

Control moss stitch loop height 
and chain stitch width.

Compound 
chenille

Use with Complex Fill to 
automatically generate moss or 
chain stitch run-arounds for 
complex shapes. Right-click for 
settings.

View by 
Chain / 
Moss

View chenille objects in special 
mode for easy identification of 
lockstitch (green), chain (blue), 
and moss (red) elements.

Blatt Reduce thread tension.

Stepp Increase thread tension.

End jump Engage needles or borers.

Begin jump Disengage needles or borers.

Slow Decrease machine speed.

Fast Increase machine speed.

Borer in Engage borer.

Borer out Disengage borer.

Borer depth: Determine borer 
hole size – valid depths are 
1-13 for Plauen and 0-12 for 
Saurer.

RPM- Decrease turning speed of 
machine.

RPM+ Increase turning speed of 
machine.

Fadenleiter- Decrease Fadenleiter stroke 
by one increment.

Fadenleiter+ Increase Fadenleiter stroke by 
one increment.

Thread 
brake-

Decrease thread brake 
pressure.

Thread 
brake+

Increase thread brake 
pressure.
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Manage design tools
Use the Manage Designs tools for fast 
searching of designs on shared network 
drives. This is important for businesses with 
multiple computers and multiple users 
creating and accessing EMB or machine 
format designs. See Design Management for 
details.

View (Design Library) tools
Design Library allows for fast searching of 
designs on shared network drives. The 
View (Design Library) toolbar contains 
functions for quick search, sort, and location 
of designs on your company network. See 
Design Management for details.

Drop sequin Trigger a sequin drop.

Schiffli 
arrangement

Split designs into color blocks 
arranged into logical parts.

New from 
selected

Create new designs from 
chosen template based on 
selected designs and/or 
bitmaps. Right-click to select 
template.

Open 
selected

Open designs currently selected 
in Design Library. 

Open 
recent 
designs

Open a design from list of 
recently opened designs.

Cut Cut selection and place on 
clipboard.

Copy Copy selection and place on 
clipboard. 

Paste Paste contents of clipboard.

Convert 
selected 
designs

Convert all designs currently 
selected in Design Library to 
different file formats. 

Send to 
Connection 
Manager

Send current design to machine 
via proprietary machine 
software. Right-click for settings.

Print 
selected

Print designs currently selected 
in Design Library to connected 
and configured printer.

Print 
selected to 
catalog

Print designs currently selected 
in Design Library to HTML 
catalog.

Export 
design list

Export list of design files visible 
in Embroidery Library, together 
with associated design 
information, to CSV or TXT file.

Manage 
embroidery 
library 
locations

Add or remove folders to/from 
Embroidery Library for fast 
searching and filtering.

Layout
Show/hide navigation pane, 
details pane, and/or preview 
pane.

Design 
information

Show design information – 
size, number of stitches, job 
order details, etc – and add 
comments for worksheets.

Keyboard 
design 
collection

Show/hide Keyboard Design 
Collection docker.

Exports

Show/hide Exports docker. 
View export status of current 
session. Conversion to older 
formats or machine files 
performed as background task.

Change 
view

Change current view of design 
lists.

Reset detail 
columns

Reset columns in details view 
to default layout. 

Group current design list by 
selected property.

Ascending 
order Sort designs in ascending or 

descending order. Descending 
order
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Sort current design list by 
selected property and sort 
order.

Filter current design list by file 
type. 

Filter designs based on 
specified search criteria – e.g. 
stitch range.
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Keyboard Shortcuts

In addition to shortcut keys, standard 
MS Windows® Alt key shortcuts apply in 
some cases. Use the Alt key with the letter 
underlined in the menu. To cancel an 
operation, press Esc twice.

General functions

To... Press
open design C+O or 

A+F+O

close design A+F+C

export machine file V+E

open Lettering dialog A

open online help 1

print design C+P or 
A+f+p

save design C+S

save as A+f+A

send design to EmbroideryConnect V+A+S

send design to EC Queue V+A+Q

start new design C+N 
toggle Color-Object List V+L

toggle Design Information docker A+p

toggle Grid V+G

toggle Overview window V+V

toggle Stitch List V+J

toggle measure tooltip C+i

measure distance on-screen M

cancel command E 
redo command C+Y 
undo command C+Z

exit application A+4 

Digitizing functions 

To... Press or
activate Auto Trace To Vectors 
for selected artwork

C+M

activate Branching I

activate Complex Turning 2

activate Complex Fill 3

activate Column A 4 V+A

activate Column B 5

activate Column C 6

activate Backtrack V+X

activate Appliqué 7

activate Single Run 8 V+N

activate Triple Run 9

activate Motif Run 0

activate Backstitch !

activate Stemstitch @

apply Satin stitch V+I

apply Tatami stitch V+M

delete last input point B

finish digitizing object (keep last 
stitch)

R

finish digitizing object (omit last 
stitch)

s

finish digitizing free shape 
boundary

R

generate stitches G

make combined vector object V+H 
switch between fill and run 
stitch

s

switch between fill and manual 
stitch

R

Selecting objects

To... Press
activate Select tool o 
deactivate Select tool E

select all objects C+A 
deselect all objects E or X 
activate Polygon Select tool C+L 
select by color C+A+a

* Stitch Edit tool selected

Digitizing functions  (cont)

To... Press or
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select object at current needle 
position

V+O 

select multiple objects C+[

select range of objects V+[

select next object T 
select previous object V+T 
select object beneath 2+[ 
add next object to selection C+T 
add previous object to selection C+V+

T 
group selected objects C+G 
ungroup selected objects C+U 
lock selected object K 
unlock all locked objects V+K 

Viewing designs

To... Press
toggle TrueView™ on/off T 
toggle stitches S

toggle outlines L

toggle needle points † .

toggle connectors V+C

toggle function symbols V+F

view by color A+c

hide others V+s

toggle bitmaps D

toggle vectors V+D

zoom (marquee) B 
zoom to 1:1 scale (100%) 1 
specify zoom factor F 
zoom in 2X Z 
zoom out 2X V+Z 
zoom to all design * 0

zoom to selected objects * V+0

zoom to product * C+0

zoom to hoop * A+0

zoom box in Overview window V+B

activate panning P 
deactivate (temporarily) Auto 
Scroll

^ V

toggle Auto Scroll on/off C+V+A

† Period * Zero ^ Hold down

Selecting objects (cont)

To... Press

* Stitch Edit tool selected

center current stitch in design 
window

C 

return to previous view V 
redraw (refresh) screen r

Viewing stitching sequence

To travel... Press
activate Stitch Player V+R

to start of design h

to end of design e

to next color x

to previous color z

to next object C+T

to previous object V+T

to next segment ^ C+r

to previous segment ^ C+l

to next function ^ C+x

to previous function ^ C+z

to next trim ^ A+r

to previous trim ^ A+l

1 stitch forward ^ r

1 stitch backward ^ l

10 stitches forward ^ b

10 stitches backward ^ t

100 stitches forward † +

100 stitches backward † -

1000 stitches forward † V++

1000 stitches backward † V+-

^ No object selected † Numeric keypad only, no object 
selected

Cutting & pasting objects

To... Press or
cut object C+X V+D

copy object C+C C+Z

paste object C+V V+Z

duplicate object C+D 
duplicate with offset C+V+D

paste special > object 
property position

V+Z

paste special > shift pasted 
objects

C+V+V

Viewing designs (cont)

To... Press

† Period * Zero ^ Hold down
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paste special > center at 
current stitch

C+A+V

paste special > start at current 
stitch

V+A+V

delete selected objects or last 
object

D

Modifying objects

To... Press or click
activate Reshape tool H 
activate Show Stitch Angles tool A+a

activate Show Reshape Nodes 
tool

A+N

activate Stitch Angles tool C+H

add outlines and/or offsets C+V+O

add stitch angles (Complex 
Turning) 

C+H

change reshape node type ^ [+M

check design integrity !

maintain proportions while 
resizing

† V+:

mirror horizontally C+1

mirror vertically A+1

move selected object 
horizontally or vertically

* C+:

nudge selected object [+t b l r 
remove overlaps C+V+E

toggle Auto Underlay on/off u

* Drag object † Drag handle ^ Select control point

Schiffli functions

To... Press
insert Blatt/Stepp function [ ]

insert Fadenleiter Plus/Minus < >

insert Boring Tension Start/End / \

insert RPM Plus/Minus : "

change Schiffli borer depth ;

show Schiffli repeats W

Editing stitches (Stitch Edit mode)

To... Press or click
activate Stitch Edit tool E 

Cutting & pasting objects (cont)

To... Press or
toggle stitch selection Q 
toggle stitch selection while 
traveling by stitches

T 

Editing stitches (cont)(Stitch Edit mode)

To... Press or click
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